Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-05-23, 22:07)Milhouse Wrote: The last OE version based on Kodi 13.2 is OE 4.2 using the 340.32 nvidia driver.

Are you saying you have the same nvidia invalid opcode bug with the 340.32 driver? Or did you just restore your 13.2 settings on top of a build (OE/LE 7, #0522) with the 352.79 driver?

Honestly, I don't know. After a manual downgrade to 13.2 / OE4.2.1 these random crashes happened again. I think I remember seeing the 'old' driver 340.32. Behavior was the same as with my 16.1 / 17a tests. I tried to gather some info while running the downgraded version and the crashes occurred. Though there was nothing. Just these (multiple) crashes and restart loops. Nothing in the logs and even dmesg did not show anything regarding nvidia or segfaulting or else ..

After that I did a OE 4.2.1 reinstall (image file) as I thought I messed something up. Btw, before OE 4.2.1 setup was running smooth for two years on this box. I'm there now without any customizing (During reinstall I did kill my OE4 backup for this nvidia system by accident .. was a bit in a hurry *sigh*).

While the crashes happened I thought about the HW and did some tests. memtest64 (v4 and 5) reported heavy errors. Therefore I will order some new SO-DIMM and see what happens.

(2016-05-23, 22:07)Milhouse Wrote:
(2016-05-23, 19:19)fritsch Wrote: Nvidia binary bug:
Quote:0x00007f326d0af310 in ?? () from /usr/lib/libnvidia-glcore.so.352.79

I'll bump the nvidia driver version in tonight's build to 361.42 from 352.79.

@lazyman can you test the next build (#0523) and report if it fixes the crashes, or causes any new problems. Thanks.

I'm back at work tomorrow with less time but will try to get a usb install working for test purposes. Als want to check whether new memory will fix the possible HW issue. If not I'm somewhat lost - and might have a nvidia test/QA system at hand.
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average


Messages In This Thread
RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - by lazyman - 2016-05-23, 23:04
3D HOU/HSBS issue - by .bismarck - 2016-06-20, 20:03
[Build #0903] breaks VAAPI - by MichaelAnders - 2016-09-04, 15:37
Update Failed - by n2vwz - 2016-09-27, 19:34


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111