•   
  • 1
  • 62
  • 63
  • 64(current)
  • 65
  • 66
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-06-21, 19:13)Milhouse Wrote: Interesting that you say it works with OE compiled from source - is this current OE master (based on 4.6-rc6 kernel) or something older?

I'm not running it at the moment so I can't verify the kernel, but the last working build I compiled was: 20160514 (OpenELEC-Generic.x86_64-8.0-devel-20160514192642-r22746-g0c2b455)

If I can find some time this week I can roll back and post the info (unless you can already tell from the build information)
(2016-06-21, 21:36)forkless Wrote:
(2016-06-21, 19:13)Milhouse Wrote: Interesting that you say it works with OE compiled from source - is this current OE master (based on 4.6-rc6 kernel) or something older?

I'm not running it at the moment so I can't verify the kernel, but the last working build I compiled was: 20160514 (OpenELEC-Generic.x86_64-8.0-devel-20160514192642-r22746-g0c2b455)

Yes, that's current tip of OE master - it hasn't updated for almost 2 months...

It could still be a kernel issue, as we're already on 4.6.2. Or it might be a driver issue as we're now using a more recent Nvidia driver.

What I would suggest is that you go back through my builds and try to identify the first build that doesn't suspend/resume properly. I'm not saying it will guarantee a fix, but it might at least narrow down the change that introduced the problem (could be a kernel or driver bump).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0621: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.2 #1 SMP Tue Jun 21 21:45:46 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160621214422-#0621-g0881ed2 [Build #0621]

Based on tip of LibreELEC.tv master (0881ed2f, changelog) and tip of XBMC master (7b8e6912, changelog) with the following modifications: Build Highlights:
  1. Re-introduce color correction PR after rebase
Build Details:
  1. LibreELEC.tv:
    • unclutter: initial package (PR:466, 2 commits, 6 files changed)
    • fix journal truncation on time jumps (PR:470, 1 commit, 1 file changed)
  2. XBMC:
    • VIdeoPlayer: Fix double mem alloation if streamcodec hasn't changed (PR:10018, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:9731: [WIP] 3dlut and simple ICC linking support for color correction
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I have been dropping frames on some YouTube videos like crazy. With version 615 it finally seemed to run good but has been getting worse with later versions. I played a offending video in 615 and 621. No frames dropped in 615 and countless in 621.

615 http://sprunge.us/gTDU

621 http://sprunge.us/MdWM

Thanks for the hard work, Eric
(2016-06-22, 02:25)EricSol Wrote: I have been dropping frames on some YouTube videos like crazy. With version 615 it finally seemed to run good but has been getting worse with later versions. I played a offending video in 615 and 621. No frames dropped in 615 and countless in 621.

615 http://sprunge.us/gTDU

621 http://sprunge.us/MdWM

Thanks for the hard work, Eric
So #0615 is OK, but #0616 is when the problem starts? There's really not much that changed in #0616...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-06-22, 02:53)Milhouse Wrote:
(2016-06-22, 02:25)EricSol Wrote: I have been dropping frames on some YouTube videos like crazy. With version 615 it finally seemed to run good but has been getting worse with later versions. I played a offending video in 615 and 621. No frames dropped in 615 and countless in 621.

615 http://sprunge.us/gTDU

621 http://sprunge.us/MdWM

Thanks for the hard work, Eric
So #0615 is OK, but #0616 is when the problem starts? There's really not much that changed in #0616...

616 may be ok, I can install and test if needed
(2016-06-22, 02:53)Milhouse Wrote:
(2016-06-22, 02:25)EricSol Wrote: I have been dropping frames on some YouTube videos like crazy. With version 615 it finally seemed to run good but has been getting worse with later versions. I played a offending video in 615 and 621. No frames dropped in 615 and countless in 621.

615 http://sprunge.us/gTDU

621 http://sprunge.us/MdWM

Thanks for the hard work, Eric
So #0615 is OK, but #0616 is when the problem starts? There's really not much that changed in #0616...

616 http://sprunge.us/UjHO
616 only dropped a few but subjectively doesn't look as smooth as 615
(2016-06-21, 03:09)startv Wrote:
(2016-06-20, 12:27)Milhouse Wrote:
(2016-06-20, 08:22)startv Wrote: "libreELEC settings" - "system" is blank from #0610 to last build, #0609 is OK. is that normal?

No, not normal. If you'd posted your debug log that would help.

It's probably due to a corrupted (or now incompatible) setting of some kind - hard to say without a log. Try deleting the settings and restarting:
Code:
rm /storage/.kodi/userdata/addon_data/service.libreelec.settings/oe_settings.xml
systemctl restart kodi
You'll then need to reconfigure anything you had configured in the Settings add-on (hostname etc.)

#0620 fixed this issue.

Thank you!

I found if there is no internet connected,then "libreELEC settings" - "system" will be blank.
The last worked build is #0609.

Here is the log:
http://pastebin.com/A3XqAafe
New LibreELEC.tv Krypton build #0622: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.2 #1 SMP Wed Jun 22 21:25:17 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160622212356-#0622-g0881ed2 [Build #0622]

Based on tip of LibreELEC.tv master (0881ed2f, changelog) and tip of XBMC master (1a0c596e, changelog) with the following modifications: Build Highlights:
  1. libnfs updates
Build Details:
  1. XBMC:
    • [Estouchy] update (PR:10021, 1 commit, 19 files changed)
  2. libnfs:
    • nfs_rewinddir: introduce additional nfs_rewinddir() (PR:151, 1 commit, 2 files changed)
    • Fix crash in nfs_truncate due to dereference of uninitialized data (4cc09b97)
    • Add comment that nfs_rewinddir will never block. (d9e75d56)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Just added an album and it seemed to double a few tracks (music is on a NFS share). Was trying to export the Music DB to see if I can track down the path of the dupes but the database is exporting as blank.

Looking in my DB folder - I have two music databases - 59 and 60. I added music after the migration to 60 so 59 is blank (and I verified with sqlite). Could the export be trying to export the old 59 database?

Debug log: http://pastebin.com/cG8cUJi4

Edit: tried removing the 59 database and exports for Music are still blank.
@GoodOmens? Kodi is using MyMusic60, it won't be looking at MyMusic59.

Not sure what you mean by "the database is exporting as blank" - do you mean the NFO files being created are blank? Or that no NFO files are being created? Looking at your log it appears the export isn't actually doing anything:
Code:
20:03:01  93.330818 T:139985228212288    INFO: Loading skin file: DialogConfirm.xml, load type: KEEP_IN_MEMORY
20:03:02  93.760231 T:139985228203776   DEBUG: CAnnouncementManager - Announcement: OnExport from xbmc
20:03:02  93.760406 T:139985228203776   DEBUG: GOT ANNOUNCEMENT, type: 32, from xbmc, message OnExport
20:03:02  93.760544 T:139985228212288   DEBUG: Keyboard: scancode: 0x24, sym: 0x000d, unicode: 0x0000, modifier: 0x0
20:03:02  94.009438 T:139985228212288   DEBUG: ------ Window Deinit (DialogConfirm.xml) ------
20:03:30 121.744331 T:139984837265152   DEBUG: Thread JobWorker 139984837265152 terminating (autodelete)

You can query your media library using texturecache.py (it's included in these builds) - try
Code:
texturecache.py jd songs "my generation"
to view details of all songs with the title "my generation" (substitute the name - or partial name - of one of your duplicated songs).

You should see the file path for each song, and this information may help explain why you have duplicates.

Knowing when this problem started would be useful, so if you were able to go back through the builds and identify the first build with duplicates and/or empty export then it would increase the chance of a fix.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Blank as in the the only contents of the export is:

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<musicdb />

Unfortunately I don't know when it began as I haven't done a DB export since the move to libreelec. I'll see if I can go through some older versions tomorrow when I have more time. I assume doing a DB export on music works fine for you?

Thanks for the query tip - I had previously found my dupe using the more tedious method using sqlite and SQL calls Confused - it was unrelated to Kodi and more to do with iTunes misbehaving.
Interested in what you find with the export.

I posted an issue on Kodi forum where export of TV only exported the TV show data, but didn't export any thing for episodes for the TV show.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
@Milhouse ready for some new problems soon by using 4.7 kernel? Tongue
AppleTV 4K, LG 65E6 OLED TV, Marantz NR1606, Harmony Elite
(2016-06-23, 09:45)_Spook_ Wrote: @Milhouse ready for some new problems soon by using 4.7 kernel? Tongue

Nope - I just got the BSW fix into upcoming 4.6.3 kernel .... no mood for yet another fuckup.

http://git.kernel.org/cgit/linux/kernel/...pass.patch
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
  •   
  • 1
  • 62
  • 63
  • 64(current)
  • 65
  • 66
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111