Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-07-20, 13:20)FernetMenta Wrote: Something is messed up with settings in these builds:

06:31:28 102.179161 T:139637015939136 DEBUG: ------ Window Init (DialogSettings.xml) ------
06:31:28 102.180824 T:139637015939136 DEBUG: CSettingsManager: requested setting (video.deinterlacemode) was not found.
06:31:28 102.180885 T:139637015939136 DEBUG: CSettingsManager: requested setting (video.interlacemethod) was not found.
06:31:28 102.180962 T:139637015939136 DEBUG: CSettingsManager: requested setting (video.scalingmethod) was not found.

I see this in Ubuntu too, with latest Kodi master, so not specific to these builds: http://sprunge.us/QJTd (this is a totally "clean" .kodi - everything default. I only added a single entry to source.xml in order to load a local video)

Although the "not found" message is being output, if you change a setting in one of the dialogs it will be stored and subsequently loaded next time the dialog is opened, eg. set audio.volume to -20db and it will be saved/loaded despite the "not found" message appearing each time the Audio dialog is opened. So this looks like some weird behaviour of CSettingsManager that's always been there, but may only affect certain platforms (Fernet doesn't see this on OSX, I see it on Ubuntu and LE).

I've gone back to LE build #0601 and this CSettingsManager behaviour is the same there, so hasn't been introduced with build #0717 - build #0716 also has this same CSettingsManager behaviour.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average


Messages In This Thread
3D HOU/HSBS issue - by .bismarck - 2016-06-20, 20:03
RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - by Milhouse - 2016-07-20, 16:51
[Build #0903] breaks VAAPI - by MichaelAnders - 2016-09-04, 15:37
Update Failed - by n2vwz - 2016-09-27, 19:34


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111