Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-07-31, 06:10)Milhouse Wrote:
(2016-07-31, 04:32)sciascia88 Wrote: @Milhouse
Here's my Debug Log from the current build. The VPN manager acts as if it connects to the New York server, but actually does not. It works fine on the Alpha build (7.90.003).

Hope that helps.

If you were able to identify the last working build that would help towards a solution.

Although to be honest a quick look at your logs (dmesg/journalctl) shows OpenVPN is likely to be the least of your problems as it appears you're suffering from a serious hardware problem with your /dev/sda hard disk - it might be on it's last legs:
Code:
Jul 30 22:03:15 LibreELEC kernel: ata1.00: exception Emask 0x10 SAct 0x2 SErr 0x280100 action 0x6 frozen
Jul 30 22:03:15 LibreELEC kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Jul 30 22:03:15 LibreELEC kernel: ata1.00: cmd 60/00:08:00:70:04/02:00:00:00:00/40 tag 1 ncq 262144 in
                                           res 40/00:08:00:70:04/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
Jul 30 22:03:15 LibreELEC kernel: ata1: hard resetting link
Jul 30 22:03:15 LibreELEC kernel: ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Jul 30 22:03:15 LibreELEC kernel: ata1.00: configured for UDMA/133
Jul 30 22:03:15 LibreELEC kernel: ata1: EH complete
Jul 30 22:03:15 LibreELEC kernel: ata1.00: exception Emask 0x10 SAct 0x30000 SErr 0x280100 action 0x6 frozen
Jul 30 22:03:15 LibreELEC kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Jul 30 22:03:15 LibreELEC kernel: ata1.00: cmd 60/00:80:00:7b:04/01:00:00:00:00/40 tag 16 ncq 131072 in
                                           res 40/00:80:00:7b:04/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
Jul 30 22:03:15 LibreELEC kernel: ata1.00: cmd 60/00:88:00:7c:04/01:00:00:00:00/40 tag 17 ncq 131072 in
                                           res 40/00:80:00:7b:04/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
Jul 30 22:03:15 LibreELEC kernel: ata1: hard resetting link
Jul 30 22:03:15 LibreELEC kernel: ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Jul 30 22:03:15 LibreELEC kernel: ata1.00: configured for UDMA/133
Jul 30 22:03:15 LibreELEC kernel: ata1: EH complete
Jul 30 22:03:15 LibreELEC kernel: ata1.00: exception Emask 0x10 SAct 0x300 SErr 0x280100 action 0x6 frozen
Jul 30 22:03:15 LibreELEC kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Jul 30 22:03:15 LibreELEC kernel: ata1.00: cmd 60/00:40:00:b8:04/01:00:00:00:00/40 tag 8 ncq 131072 in
                                           res 40/00:40:00:b8:04/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
Jul 30 22:03:15 LibreELEC kernel: ata1.00: cmd 60/00:48:00:b9:04/01:00:00:00:00/40 tag 9 ncq 131072 in
                                           res 40/00:40:00:b8:04/00:00:00:00:00/40 Emask 0x10 (ATA bus error)

I do see you've managed to bring up the tun interface and from the #0730 kodi.log it looks like it's connecting to New York:
Code:
22:07:12 252.597366 T:140221614122752   DEBUG: VPN Mgr : Connecting using profile US New York City (UDP).
22:07:12 252.610611 T:140221614122752   DEBUG: VPN Mgr : (Linux) Starting VPN with /usr/sbin/openvpn "/storage/.kodi/addons/service.vpn.manager/PIA/US New York City (UDP).ovpn" > /run/openvpn.log &
...
22:07:14 254.672470 T:140221614122752   DEBUG: VPN Mgr : Reading log file
...
22:07:16 256.678101 T:140221614122752   DEBUG: VPN Mgr : Reading log file
22:07:16 256.680969 T:140221614122752   DEBUG: VPN Mgr : VPN connection status is 1
22:07:16 256.684662 T:140221614122752   DEBUG: VPN Mgr : Getting IP info from IP-API
22:07:17 257.311218 T:140221614122752  NOTICE: Previous line repeats 1 times.
22:07:17 257.311279 T:140221614122752  NOTICE: VPN Mgr : (common.py) Connected to a VPN in Pennsylvania, United States.
                                            Using profile US New York City (UDP).
                                            External IP address is 67.xxx.xxx.xxx.
                                            Service Provider is Comcast Cable.
22:07:17 257.375153 T:140221614122752   DEBUG: VPN Mgr : Update service requested
22:07:17 257.382080 T:140221614122752   DEBUG: VPN Mgr : Requesting service restarts
22:07:17 258.008118 T:140221874165504   DEBUG: VPN Mgr : Service received a start request

If you're having problems, look in the OpenVPN log: /run/openvpn.log

Though to be honest I'm not an OpenVPN expert, and given your hardware problems I'd suggest fixing that first. Then, if the VPN problem continues, determine the last working Milhouse test build. Comparing these test builds with 7.90.003 doesn't really tell me much, other than OpenVPN worked in a build with a Kodi version from 4 weeks ago, a totally different kernel and a whole bunch of packages that haven't been bumped in the last few weeks, so if you can tell me which of my builds is the last working version that would help a lot.

Alright, when I get more time to test different builds I'll send the logs. The VPN manager does go through the motions and says it is connected to NY, but that IP is my actual IP, not the one it should show from NY. The OpenVPN log says "ERROR: Linux route add command failed: external program exited with error status: 2" four times before completing the sequence, but I have no idea what that even really means and the developer seemed to not have much insight either.

Thanks for pointing out the hard drive errors too. It's the OS drive and I had a feeling that it wasn't healthy.
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average


Messages In This Thread
3D HOU/HSBS issue - by .bismarck - 2016-06-20, 20:03
RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - by sciascia88 - 2016-07-31, 06:20
[Build #0903] breaks VAAPI - by MichaelAnders - 2016-09-04, 15:37
Update Failed - by n2vwz - 2016-09-27, 19:34


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111