Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
Hi,

I have recently bought an Intel NUC6i7KYK (Skull Canyon) and have been struggling to get 3840x2160 at 60hz in LibreELEC.

I’ve been trying countless things to get this working, but I can’t seem to get it right.
To clear things up, I have a Sony UHD TV (Sony KD-79X9000B) and a direct link from TV to NUC (HDMI 2.0 Cable, (I tried different brands of cables too)).
I have installed the HDMI* 2.0 Firmware Update Tool and installed the latest BIOS at this time (KYSKLi70.86A).
LibreELEC running Krypton build #0801 (current at time of posting) - I have been installing nearly every build released for about 1 month… yes, that’s how long I have been working on this.

I am able to get 1920x1080 60hz, but when I select 3840x2160 in LibreELEC, the TV displays “Unsupported signal, Check your device output”
After SSH into LibreELEC, I checked xrandr and saw that 3840x2160 is listed (though not 60hz): Log here (after switching to 3840x2160 and xrandr, I get: this log)
The NUC has Intel Pro Graphics 580 and 3 ports for displays:
• One HDMI 2.0
 • One Thunderbolt 3
 • One Mini DisplayPort 1.2
I have an adapter for the Mini DisplayPort, so I tried that instead of the standard HDMI port. LibreELEC and xrandr didn’t list 3840x2160 as a resolution at all… I will come back to this as I did find a workaround.

I wanted to check if it was a LibreELEC issue or hardware, so I installed Windows 10 and used the HDMI port (not the adapter for Mini DP) and 3840x2160 at 60hz was working perfectly, I installed Kodi to make sure it worked ok at 2160p and all was good.
So I installed Ubuntu 16.04 (with all available system updates) and had the same issue as LibreELEC using the HDMI port (“Unsupported signal, Check your device output”), but after switching to Mini DP with the adapter, I was able to get 2160p at 30hz, installed Kodi and was working fine (I wasn’t able to get 60hz though).
Since I was able to see the xrandr details for the 30hz working setup In Ubuntu, I copied the details from xrandr and re-installed LibreELEC, plugged in the Mini DP adapter (which only showed 1080p before), SSH back in and entered these:
xrandr --newmode "[email protected]" 296.703 3840 4016 4104 4400 2160 2168 2178 2250 +hsync +vsync
xrandr --addmode HDMI3 [email protected]
xrandr --output HDMI3 --mode [email protected]
Please note ‘HDMI3’ is what xrandr sees the Mini DP as. DP1 is what xrandr sees the HDMI port as.
With the manual mode entry copied from Ubuntu, I was able to get LibreELEC displaying 3840x2160p at 30hz. (After rebooting I lose that configuration)

I tried running that command but entering it for the HDMI port instead to see if the same custom mode would work, but it still said “Unsupported signal, Check your device output”.
What I am trying to get is 3840x2160 at 60hz on the HDMI port.
At the moment, the HDMI port displays at 1080p fine, but after returning from suspend, I don’t get a display; xrandr shows VIRTUAL1 as the connected display and won’t switch back to HDMI (I have to reboot), I saw this issue here; but it isn’t working for me.
If I use the Mini DP adapter, I am able to use the NUC at 1080p 60hz and resume from suspend without issue

I’m not sure if this is something that needs to be added to the linux kernel or if LibreELEC needs patching, but I would greatly appreciate and assistance in resolving this.
Please let me know if there are any logs, outputs, details or other information you need from me (I probably left some stuff out).

Thanks.
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average


Messages In This Thread
3D HOU/HSBS issue - by .bismarck - 2016-06-20, 20:03
RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - by Ichabod Fletchman - 2016-08-02, 10:58
[Build #0903] breaks VAAPI - by MichaelAnders - 2016-09-04, 15:37
Update Failed - by n2vwz - 2016-09-27, 19:34


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111