Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2017-01-26, 19:15)lleon596 Wrote:
(2017-01-26, 18:33)fritsch Wrote:
(2017-01-26, 08:14)lleon596 Wrote: "Sync playback to display" is disabled. Passthrough is working on DTS and AC3 but EAC3 is downmixed to stereo , in the log I see :

23:49:06.562 T:139801579742976 DEBUG: FactoryCodec - Audio: passthrough - Opening
23:49:06.562 T:139801579742976 DEBUG: FactoryCodec - Audio: passthrough - Failed
23:49:06.562 T:139801579742976 DEBUG: FactoryCodec - Audio: FFmpeg - Opening

I've attached full kodi.log ...

Quote:23:41:23.420 T:139802529502656 NOTICE: m_displayNameExtra: MEI Panasonic-TV on HDMI
23:41:23.420 T:139802529502656 NOTICE: m_deviceType : AE_DEVTYPE_HDMI
23:41:23.420 T:139802529502656 NOTICE: m_channels : FL,FR
23:41:23.420 T:139802529502656 NOTICE: m_sampleRates : 32000,44100,48000
23:41:23.420 T:139802529502656 NOTICE: m_dataFormats : AE_FMT_RAW,AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE,AE_FMT_RAW

That won't work as long as your box syncs with the TV instead of the AVR. Disable ARC and retry. For HD Audio you need 192 khz samplerate and 8 channels.


I did not quite understood you Smile
The box connected to Sharp HB60 soundbar which have Dolby/DTS decoders via HDMI and the soundbar output to TV HDMI(ARC) input .
I had no problems ever to passthrough DTS and Dolby with that setup .
How should I disable ARC ? Different HDMI port in TV ?
Also in log the stream audio properties :
Stream #0:1[0x101](ger): Audio: eac3 ([6][0][0][0] / 0x0006), 48000 Hz, 5.1(side), fltp, 256 kb/s

Thanks..

EAC3 needs 192 khz, but your bar only announces 48 khz. So it won't work. Enable Dolby Transcode and you get AC3.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average


Messages In This Thread
RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - by fritsch - 2017-01-26, 20:46