Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
Hey Guys,

Since last week, i own a new 4k HDTV ( Sony KD-65XD7505). My Kodi-hardware is an Apollo Lake based Asrock j3455-ITX HTPC.

i tried to play some 4k content and encountered an issue: After selecting the tvshow, kodi changes the resolution to 3840 × 2160. According to the PlayerProcessInfo Window, its playing correctly with 23.976Hz.
But the video is not smooth at all. I figures out, that the actual frames per second are too low. According to the debug Overlay, FPS are around 15-22 which is too low obviously.

Since the video i wanted to play is h265, i tried an h264 4k video, too. Same result: low fps. 1080p content no issue btw. Just to notice: CPU usage is around 10-20% while playing the laggy video.

Then i found some workaround: unplugging/replugging the HDMI cable, powercycling the TV or just changing some kodi settings(e.g. toggle audio passthrough, (i know this sounds crazy)) while the playback is running solves the problem until i stop the video. FPS are fine then.


I tested several video-related Kodi settings, but it does not make any difference.
I also tried plugging in the HTPC directly into the TV, but this does not work either.

debug log: https://paste.ubuntu.com/24873848/
xrandr output: https://paste.ubuntu.com/24873913/
guisettings: https://paste.ubuntu.com/24873936/


any idea? fritsch maybe ? Smile

thanks
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average


Messages In This Thread
RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - by Nafi - 2017-06-16, 19:51