Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-04-06, 00:52)Milhouse Wrote:
(2018-04-05, 23:53)billbillw Wrote: I'm just wondering if the AMDGPU DC flag discussed here: (at Phoronix.com) has anything to do with my problem. Does AMDGPU have anything to do with what is being done with LibreELEC? Was it ever part of any previous Test builds?

There is no AMDGPU DC in 4.14.y, this was only added in 4.15.y. You can try a 4.15.0 LibreELEC build and see if that makes any difference. If you need a more recent mainline kernel to fix this issue then you'll need to look elsewhere as LibreELEC only ships LTS kernels now, which means 4.14.y for the next 12 months or so.    
 So, I made a discovery last night. After trying several different LE9.0 builds, including #0129x version based on Linux 4.15.y (which supposedly adds AMDGPU DC). Still no luck. When I queried the modules (SSH>lsmod) it didn't show anything related to AMDGPU. After this, I was getting tired of messing around with the box and was ready to accept having Kodi convert the lossless audio to PCM multichannel. 

So, I rolled it back to an official build (8.4.x?). I didn't spend to much time in the settings. To my amazement, it was all of a sudden passing DD+, DTS-HD MA and TrueHD!  

What was the difference? It took me awhile of checking settings, and run some additional testing, but I finally realized that the difference is whether or not I select to have Kodi adjust the display rate to match the video (not sync display). If I have it set to adjust at start/stop, the lossless doesn't pass-through. If I turn off "adjust refresh rate" and let it stay at 60p, it will pass-through the lossless codecs.

 I have ALWAYS had my Kodi boxes set to adjust the refresh rate at start/stop and it never prevented pass-through. So, there is something still not right with the drivers or Kodi. It should be able to pass lossless no matter what the frame rate. It should be EASIER for the box to send 24p. No reverse pulldown, no frame interpolation, etc. 

Any thoughts? 

Milhouse thought that maybe @fritsch or @FernetMenta could help?

This problem only seems to be an issue with this AMD GX-415GA SOC processor (eKabini, Radeon 8330e). I've used nearly identical settings on older (G-T48E) AMD APU chips, as well as with the Haswell Chromebox. Never an issue passing lossless.
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average


Messages In This Thread
RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - by billbillw - 2018-04-06, 15:09