•   
  • 1
  • 296
  • 297
  • 298(current)
  • 299
  • 300
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
yesterday afternoon i've upgraded to #929 and was watching an 1080p movie after that I've watched a few YouTube videos without any issues.

suddenly with one YouTube clip started. the screen would stay black (video was showing black) sound was perfectly fine. first I thought my projector had turned itself off or some HDMI signal issue. but then I pressed pause and I could see the video player interface showing up perfectly fine. player debug information too with proper info.

so I thought the YouTube video was uploaded wrong. I stopped the clip and started another clip from another channel. same thing. without any kodi crash/reboot. video output would just be black. so I decided to reboot libreelec. which fixed the problem. I never experienced that issue ever before with previous builds.

cables and settings where fully untouched.
I haven't wiped the logs yet. which I do when I upgrade to newer builds. which I was planning to do tonight.
might any of them be of interest?
(2018-10-01, 13:06)Celox Wrote: I haven't wiped the logs yet. which I do when I upgrade to newer builds. which I was planning to do tonight.
might any of them be of interest?

If it's reproducible then a debug log might be useful.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #1001: Generic
(Supercedes previous build)

SHA256 Checksum: bf3b74ce963038843a1e310ea1c373d439e4689bb071989cbabb3c3c4cc545fa (Generic)

# uname -a
Linux NUC 4.18.11 #1 SMP Mon Oct 1 21:05:31 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181001210358-#1001-gbf09c1f [Build #1001]

# Kodi version
(18.0-BETA3 Git:6fb44a8). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (bf09c1f, changelog) and tip of XBMC master (6fb44a8, changelog) with the following modifications: Build Highlights:
  1. AE, VideoPlayer and GUIInfo fixes
Build Details:
  1. LibreELEC.tv:
    • v4l-utils: remove broken and unused keymaps (PR:3007, 1 commit, 3 files changed)
  2. XBMC:
    • [guiinfo] Fix Visualisation.Locked. (PR:14503, 1 commit, 1 file changed)
    • AESinkAudioTrack: Support multi channel float (PR:14380, 1 commit, 2 files changed)
    • VideoPlayer: fix subtitle on/off setting (PR:14506, 1 commit, 1 file changed)
  3. pvr.vuplus:
    • New settings feature switch and fix for more missing and more than one channel (PR:96, 6 commits, 11 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:3006 (perma): linux (Generic/RPi): update to linux-4.18.11
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-09-28, 02:02)Ipaddle Wrote:
(2018-09-27, 16:06)Milhouse Wrote:
(2018-09-27, 15:59)oneneo Wrote:  Correct. I use it in an Home Built HTPC with a I3 Coffe Lake and I have the artefacts since #814.
When I put an NViDIA gt1030 in the HTPC it works fine but no 4k/10 bits.
By the way the problem is common to all the skins I tested, Estuary included.
JM

Either I'm not testing correctly, or a Skylake i5 NUC isn't affected either.

Can someone provide step-by-step instructions so there's no mistake how this can be reproduced? 

It is not skin related. I tried Estaury, Mq8 and MQ6 mod skins. See a Video in Full Screen mode and then activate and deactivate the menu. You will see a rest of it at the bottom of the screen. You can also do this with info screen. Same result. You get artifacts on the screen. Not in the picture though, but on top and botttom of the screen. 
 Exactly. I ran this build on a custom build HTPC with  ASRock Fatal1ty Z270 Gaming-ITX/ac LGA1151 HDMI 2.0 ITX and Intel Core i7 7700T with HD 630 connected to LG OLED77C8P and have these artifacts as soon as menu's are displayed. Only on top and bottom as Ipaddle mentioned. I'm also ran it on a NUC Core i5-7260U and there the problem was not visible, so it looks related to hardware? As i mentioned earlier i reverted to build #0813 as this works on both without artifacts and working emby plugin
New LibreELEC.tv Leia build #1002: Generic
(Supercedes previous build)

SHA256 Checksum: 0707c4ff78f1e67c539281eacf3245b88cca5bdb202c42865c0ec50108b878f1 (Generic)

# uname -a
Linux NUC 4.18.11 #1 SMP Tue Oct 2 21:04:30 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181002210250-#1002-g676d13b [Build #1002]

# Kodi version
(18.0-BETA4 Git:bdb4926). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (676d13b, changelog) and tip of XBMC master (bdb4926, changelog) with the following modifications: Build Highlights:
  1. Start of Kodi 18 Beta 4
  2. RFC: Cve 2017 5982
  3. Lots of game/controller fixes
Build Details:
  1. LibreELEC.tv:
    • retroplayer: update add-ons (PR:3004, 1 commit, 87 files changed)
    • libretro-genplus: bus error fix for non RPi arm based systems (PR:3008, 1 commit, 1 file changed)
    • scripts: image: show BUILDER_NAME in System Information and LE settings (PR:3003, 1 commit, 1 file changed)
    • update and cleanup dvb-tools (PR:2995, 12 commits, 13 files changed)
    • ffmpegx and tvh (PR:2916, 14 commits, 20 files changed)
  2. XBMC:
    • [fix] Fix a stack overflow in LangCodeExpander (PR:14505, 1 commit, 1 file changed)
    • Controller dialog: Make it more awesome (PR:14494, 4 commits, 10 files changed)
    • Game OSD: Finish renaming "View mode" to "Stretch mode" (PR:14496, 1 commit, 30 files changed)
    • Fix getting stuck using VideoPlayer and breaking game launching (PR:14478, 1 commit, 3 files changed)
    • Game OSD: Extend help dialog to explain lack of remote support (PR:14498, 1 commit, 2 files changed)
    • Controller dialog: Fix keyboard and mouse ignored in sub-dialogs (PR:14502, 2 commits, 7 files changed)
    • CDRMPRIMEEGL: specify EGL colorspace and colorrange (PR:14432, 1 commit, 4 files changed)
    • bump to v18.0 beta 4 (PR:14468, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [pkg] patch: input: libinput: add setting to allow changing keymap layout
    • Added: [pkg] PR:14501 (perma): RFC: Cve 2017 5982
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Weekly Linux 4.19-rc6 build #1002x: Generic

Packages disabled/not included:

DVB Driver Addons (CrazyCat incompatible with 4.19-rc)
Packages added/updated:

Fixes for r8169 resume issues (10Mbit/Half, and WOL from S5)
Known issues:

RTL8188EU, RTL8192CU/DU/EU, RTL8812AU: driver changes untested
xf86-video-nvidia: driver changes untested
r8169 WOL from S5 not working
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-10-02, 16:51)posixx Wrote:
(2018-09-28, 02:02)Ipaddle Wrote:
(2018-09-27, 16:06)Milhouse Wrote: Either I'm not testing correctly, or a Skylake i5 NUC isn't affected either.

Can someone provide step-by-step instructions so there's no mistake how this can be reproduced? 

It is not skin related. I tried Estaury, Mq8 and MQ6 mod skins. See a Video in Full Screen mode and then activate and deactivate the menu. You will see a rest of it at the bottom of the screen. You can also do this with info screen. Same result. You get artifacts on the screen. Not in the picture though, but on top and botttom of the screen.  
 Exactly. I ran this build on a custom build HTPC with  ASRock Fatal1ty Z270 Gaming-ITX/ac LGA1151 HDMI 2.0 ITX and Intel Core i7 7700T with HD 630 connected to LG OLED77C8P and have these artifacts as soon as menu's are displayed. Only on top and bottom as Ipaddle mentioned. I'm also ran it on a NUC Core i5-7260U and there the problem was not visible, so it looks related to hardware? As i mentioned earlier i reverted to build #0813 as this works on both without artifacts and working emby plugin 
I suffer the same problem, artifacts of the menu interface while watching a movie or TV episode. Live TV does not display the artificacts. Mine are on the bottom and right side. Its an older Asus Chromebox (2014).
(2018-10-03, 09:51)menno Wrote:
(2018-10-02, 16:51)posixx Wrote:
(2018-09-28, 02:02)Ipaddle Wrote: It is not skin related. I tried Estaury, Mq8 and MQ6 mod skins. See a Video in Full Screen mode and then activate and deactivate the menu. You will see a rest of it at the bottom of the screen. You can also do this with info screen. Same result. You get artifacts on the screen. Not in the picture though, but on top and botttom of the screen.  
 Exactly. I ran this build on a custom build HTPC with  ASRock Fatal1ty Z270 Gaming-ITX/ac LGA1151 HDMI 2.0 ITX and Intel Core i7 7700T with HD 630 connected to LG OLED77C8P and have these artifacts as soon as menu's are displayed. Only on top and bottom as Ipaddle mentioned. I'm also ran it on a NUC Core i5-7260U and there the problem was not visible, so it looks related to hardware? As i mentioned earlier i reverted to build #0813 as this works on both without artifacts and working emby plugin  
I suffer the same problem, artifacts of the menu interface while watching a movie or TV episode. Live TV does not display the artificacts. Mine are on the bottom and right side. Its an older Asus Chromebox (2014). 
I had the same problems and I managed to correct them entering in the whitelist the modes supported by my Display.
Till #814 that wasn't necessary.
JM
For those suffering from artefacts I'll upload some test builds later today that will hopefully narrow down/confirm the breaking change.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Can someone with the artefacts issue post a debug log (I don't think we've had one so far, but could be wrong - can't find one anyway). Thanks.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Those with the artefact problem, can you please test the following builds:

1002b: Generic - same as #0813
1002c: Generic - 1002b + PR14291
1002d: Generic - 1002c + PR14282
1002e: Generic - 1002d + PR14295

1002b should not have the artefact issue, while 1002e should have the artefact issue. I'm not expecting c & d to have it, but who knows for sure so please test them too.

Assuming the issue is confirmed as starting with 1002e then I might try and narrow it down to the specific commit with additional test builds.

Edit: We still need a debug log from an affected build which may reveal some specific GL/mesa behaviour that is hardware dependent.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-10-03, 15:33)Milhouse Wrote: Those with the artefact problem, can you please test the following builds:

1002b: Generic - same as #0813
1002c: Generic - 1002b + PR14291
1002d: Generic - 1002c + PR14282
1002e: Generic - 1002d + PR14295

1002b should not have the artefact issue, while 1002e should have the artefact issue. I'm not expecting c & d to have it, but who knows for sure so please test them too.

Assuming the issue is confirmed as starting with 1002e then I might try and narrow it down to the specific commit with additional test builds.

Edit: We still need a debug log from an affected build which may reveal some specific GL/mesa behaviour that is hardware dependent.

Can NOT test Them before oct 10th, as I am on a business trip.
KODI 18.0 - RC5 - Milhouse builds #0106
Intel NUC 4250U in Abel H2 chassis, 40PFL9704
Please increase my reputation if you think my post was helpful.
New LibreELEC.tv Leia build #1003: Generic
(Supercedes previous build)

SHA256 Checksum: eb7ebfd472ec1e7a4dd7a2a6d6f2ee98dac0a0706395a4add381e65e014d8946 (Generic)

# uname -a
Linux NUC 4.18.11 #1 SMP Wed Oct 3 21:07:38 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181003210259-#1003-gf262797 [Build #1003]

# Kodi version
(18.0-BETA4 Git:4e8fd14). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (f262797, changelog) and tip of XBMC master (4e8fd14, changelog) with the following modifications: Build Highlights:
  1. Support "Play" on Home screen
Build Details:
  1. LibreELEC.tv:
    • kodi: update to 18.0b3-Leia (PR:3009, 4 commits, 4 files changed)
    • comskip: fix build (PR:3010, 1 commit, 1 file changed)
    • kodi-binary-addons: update to latest versions (PR:3011, 1 commit, 9 files changed)
    • kodi (RPi): update SHA for corrected newclock5_18.0b3-Leia tag (PR:3012, 1 commit, 1 file changed)
    • Rockchip: update rkbin, u-boot, rkmpp and linux (PR:2925, 7 commits, 49 files changed)
    • Rockchip: add kodi HDR patches (PR:2927, 2 commits, 4 files changed)
  2. XBMC:
    • Controller dialog: Hide features not supported by game add-on (PR:14508, 4 commits, 17 files changed)
    • Add PVR_TIMER_TYPE_SUPPORTS_READONLY_DELETE flag (PR:14507, 1 commit, 5 files changed)
    • [guilib] GUIBaseContainer: Add support for ACTION_PLAYER_PLAY (PR:14513, 1 commit, 1 file changed)
  3. pvr.vuplus:
    • Genres episodes (PR:98, 5 commits, 19 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [pkg] PR:14341 (perma): input: libinput: add setting to allow changing keymap layout
    • Added: [pkg] PR:14514 (perma): EGLUtils: rework the way we choose the egl config
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
There will be an interruption to service for a week or so as I'm having some redecorating done and need to take equipment offline.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-10-03, 15:33)Milhouse Wrote: Those with the artefact problem, can you please test the following builds:

1002b: Generic - same as #0813
1002c: Generic - 1002b + PR14291
1002d: Generic - 1002c + PR14282
1002e: Generic - 1002d + PR14295

1002b should not have the artefact issue, while 1002e should have the artefact issue. I'm not expecting c & d to have it, but who knows for sure so please test them too.

Assuming the issue is confirmed as starting with 1002e then I might try and narrow it down to the specific commit with additional test builds.

Edit: We still need a debug log from an affected build which may reveal some specific GL/mesa behaviour that is hardware dependent.
Tnx for the builds. Results:

1002b: OK, no artefacts
1002c: OK, no artefacts
1002d: OK, no artefacts
1002e: NOT OK, artefacts

So your assumption is right. I was unable to paste the logs using Kodi, so i downloaded logs from 1002d and 1002e. I sent you a PM with download URL. 

Regards,

Frans
  •   
  • 1
  • 296
  • 297
  • 298(current)
  • 299
  • 300
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524