•   
  • 1
  • 304
  • 305
  • 306(current)
  • 307
  • 308
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
Hi Milhouse,

I am getting a crash fairly often since #1025.

Can you take a quick look? link

Thanks
--
Frontend : OpenELEC PVR runnig on Acer Revo 3700
Backend : Ubuntu 11.10 running with TVHeadend 1 x DVB-T, 1 x Dual DVB-S2
(2018-10-27, 14:34)xxxnelly Wrote: Hi Milhouse,

I am getting a crash fairly often since #1025.

Can you take a quick look? link

Thanks
Fix should be in tonight's build.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-10-27, 00:01)Nekromantik Wrote: since 1025 i been getting issue with watchdog plugin.
i use it to monitor my nfs shares for changes and then update library.
works well until now, from 1025 it keeps checking for changes even though there are none.
before it used to scan if there was a change but now it does it every few mins.
@millhouse  anything you can think of that could cause this?
Nothing springs to mind, can you provide a debug log (wiki)? What version were you using prior to #1025, was it #1024?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I experience a lot of slowness when browsing and starting playback from SMB-shares, from release #1023 and onwards. Just opening a share can take up to a minute and videos just buffer for 90 seconds or so and are unplayable. I think this release was the first one with kernel 4.19? I think this kernel has som major changes for CIFS, but I am really unsure if that is the problem. I have tested playback from both Samba 4.5.12 on Debian 9.3 and from Windows 7 shares, with the same results. Anoyone having similar issues?
(2018-10-27, 21:22)whocarez1 Wrote: I experience a lot of slowness when browsing and starting playback from SMB-shares, from release #1023 and onwards. Just opening a share can take up to a minute and videos just buffer for 90 seconds or so and are unplayable. I think this release was the first one with kernel 4.19? I think this kernel has som major changes for CIFS, but I am really unsure if that is the problem. I have tested playback from both Samba 4.5.12 on Debian 9.3 and from Windows 7 shares, with the same results. Anoyone having similar issues?
smb:// or OS mounted shares?

debug log (wiki)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I’ve just started using latest builds again from around 1000 and noticed the pressing the power button on my NUC doesn’t shutdown the NUC. Running Shutdown from the Kodi iOS app does shutdown ok. Should I post a log?
(2018-10-27, 14:41)Milhouse Wrote:
(2018-10-27, 00:01)Nekromantik Wrote: since 1025 i been getting issue with watchdog plugin.
i use it to monitor my nfs shares for changes and then update library.
works well until now, from 1025 it keeps checking for changes even though there are none.
before it used to scan if there was a change but now it does it every few mins.
@millhouse  anything you can think of that could cause this?
Nothing springs to mind, can you provide a debug log (wiki)? What version were you using prior to #1025, was it #1024? 
 No longer occurs.
If it happens again on next update I will post debug log.
Thanks
(2018-10-27, 22:41)HomerJau Wrote: I’ve just started using latest builds again from around 1000 and noticed the pressing the power button on my NUC doesn’t shutdown the NUC. Running Shutdown from the Kodi iOS app does shutdown ok. Should I post a log?

You may need to be more specific - pressing the power button now brings up the power menu and it's been this way since #0501.

If you want the pre-#0501 behaviour:

sed 's/HandlePowerKey=.*/HandlePowerKey=poweroff/' /etc/systemd/logind.conf > /storage/.config/logind.conf.d/logind.conf
then reboot.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #1027: Generic
(Supercedes previous build)

SHA256 Checksum: a75a0f6fbf1a28f1a921d3c57c81ac97a71e3385218779df40186d6ea27e34d2 (Generic)

# uname -a
Linux NUC 4.19.0 #1 SMP Sat Oct 27 21:06:11 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181027210356-#1027-g75688f2 [Build #1027]

# Kodi version
(18.0-BETA5 Git:ace36f6). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (75688f2, changelog) and tip of XBMC master (ace36f6, changelog) with the following modifications: Build Highlights:
  1. Fix RDS stream support (should stop recent tvheadend crashes)
Build Details:
  1. LibreELEC.tv:
    • getedid: Fixed typo in order to make "getedid delete" work again (PR:3063, 1 commit, 1 file changed)
    • valgrind: update to 3.14.0 (PR:3065, 1 commit, 1 file changed)
    • updated libretro and game.libretro packages (PR:3056, 5 commits, 118 files changed)
  2. XBMC:
    • Game Infolabel and GUI settings update (PR:14720, 4 commits, 9 files changed)
    • windowing/gbm: authorize drm master if drmSetMaster fails (PR:14714, 1 commit, 1 file changed)
    • Code quality improvements (PR:14672, 8 commits, 16 files changed)
  3. inputstream.rtmp:
    • [depends] bump openssl to 1.1.1 (PR:42, 5 commits, 25 files changed)
  4. pvr.hts:
    • Fix RDS stream support. (PR:383, 1 commit, 4 files changed)
    • [ci][appveyor] switch to Visual Studio 14 & build for WindowsStore (4d0cb6d)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2954 (perma): linux (Generic/RPi): update to linux-4.19
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-10-27, 23:44)Milhouse Wrote:
(2018-10-27, 22:41)HomerJau Wrote: I’ve just started using latest builds again from around 1000 and noticed the pressing the power button on my NUC doesn’t shutdown the NUC. Running Shutdown from the Kodi iOS app does shutdown ok. Should I post a log?

You may need to be more specific - pressing the power button now brings up the power menu and it's been this way since #0501.

If you want the pre-#0501 behaviour:

sed 's/HandlePowerKey=.*/HandlePowerKey=poweroff/' /etc/systemd/logind.conf > /storage/.config/logind.conf.d/logind.conf
then reboot.

Thanks Milhouse!
Thanks this fixes the RDS issue in #1025
--
Frontend : OpenELEC PVR runnig on Acer Revo 3700
Backend : Ubuntu 11.10 running with TVHeadend 1 x DVB-T, 1 x Dual DVB-S2
(2018-10-25, 12:09)Milhouse Wrote:
(2018-10-25, 03:58)winux Wrote: hello i have a problem with builds > #1019. #1019 was the last one without any problems.
when i try to update to #1020 i get a checksum error and it won't update so i skipped that build to #1021 and that one is updating fine but
the screen is black as soon as kodi starts. same behaviour for builds > #1021 to present.

here is a log from #1021:
kodi.log https://del.dog/KODI_log
system.log https://del.dog/system_log
hardware.log https://del.dog/hardware_log

I've just downloaded #1020 and upgraded to it, and there is no checksum problem on an i5 Skylake NUC, so any invalid checksum behaviour is down to either a corrupted download, or a hardware error.

The sha256 hash for the tar file is 96d1b6da1c502aab7c4d9b4d39e9b02622887d3618b176fd5f0b8488b2330dc2 which will help rule out a corrupted download.

Once you are sure your download is not corrupted, if you continue to experience checksum errors then I would suggest you run MemTest86 on your system to verify you don't have any RAM issues. There is also the built-in memtester but I'm not sure how good that is for x86 - I would suggest MemTest86 is likely to be more thorough. If you continue to experience checksum errors then I would strongly suggest there is a hardware error of some kind.

Assuming you are able, can you install #1020 and confirm if that has the same black screen problem, so that we can focus on #1021?

In the #1021 log I see these errors:

01:33:48.131 T:140039425247360 NOTICE: Checking resolution 16
01:33:48.205 T:140039425247360 NOTICE: Using visual 0x20
01:33:48.226 T:140039425247360 ERROR: failed to create EGL context
01:33:48.288 T:140039425247360 ERROR: CYUVShaderGLSL::CYUVShaderGLSL - failed to open file gl_shader_frag_texture_lim.glsl
01:33:48.289 T:140039425247360 NOTICE: GL: No pixel shader, fixed pipeline in use
01:33:48.301 T:140039425247360 NOTICE: GL_VENDOR = Intel Open Source Technology Center
01:33:48.301 T:140039425247360 NOTICE: GL_RENDERER = Mesa DRI Intel® 945G
01:33:48.301 T:140039425247360 NOTICE: GL_VERSION = 1.4 Mesa 18.2.3
01:33:48.301 T:140039425247360 NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20
01:33:48.301 T:140039425247360 NOTICE: GL_EXTENSIONS = GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_multitexture GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_3DFX_texture_compression_FXT1 GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_APPLE_packed_pixels GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_ARB_half_float_pixel GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_pixel_buffer_object GL_ARB_texture_rectangle GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_packed_depth_stencil GL_APPLE_object_purgeable GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_EXT_gpu_program_parameters GL_EXT_texture_sRGB_decode GL_OES_EGL_image GL_ARB_copy_buffer GL_ARB_map_buffer_range GL_ARB_ES2_compatibility GL_ARB_debug_output GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_EXT_provoking_vertex GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_separate_shader_objects GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_compressed_texture_pixel_storage GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_texture_storage GL_AMD_shader_trinary_minmax GL_ARB_clear_buffer_object GL_ARB_explicit_uniform_location GL_ARB_invalidate_subdata GL_ARB_program_interface_query GL_ARB_vertex_attrib_binding GL_KHR_debug GL_ARB_multi_bind GL_ARB_get_texture_sub_image GL_KHR_context_flush_control GL_KHR_no_error
01:33:48.305 T:140039425247360 ERROR: CYUVShaderGLSL::CYUVShaderGLSL - failed to open file gl_shader_frag_texture_lim.glsl
01:33:48.306 T:140039425247360 NOTICE: GL: No pixel shader, fixed pipeline in use
01:33:48.322 T:140039425247360 ERROR: CYUVShaderGLSL::CYUVShaderGLSL - failed to open file gl_shader_frag_texture_lim.glsl
01:33:48.323 T:140039425247360 NOTICE: GL: No pixel shader, fixed pipeline in use
01:33:48.594 T:140039383140096 NOTICE: Running database version Addons27

I don't really know what is causing this. I don't see any obvious change in #1020, but in #1021 there is a new kernel, and maybe the following could also be responsible:
(2018-10-21, 22:43)Milhouse Wrote: Build Details:
  1. XBMC:
    • X11: ability to start headless and trigger on change of EDID (PR:14612, 4 commits, 8 files changed)
 

Or it's a hardware failure. 
 
nah, it's not a mem error neither it is a hardware failure. i'm guessing you are right and the bug is related to the changes in X11.
i've also had a problem last october where no fonts where showing in the ui. fernet menta fixed it 7 months later.

this time it's similar, i just tried #1027 same prob. (it's updating/booting up fine) no more picture output at all but the menu seems to work because i can hear the menu sounds clicking when i use the cursor keys on the keyboard.
when i downgrade back to #1019 and below, everything is working fine gain.  @FernetMenta 

I can't update to #1020 because there is an error when it's updating...
this error was fixed in #1021 see "kernel: Fix for hw csum failure".
All builds #1021 to present end up having a black screen but are updating fine.
We don't support

Quote:01:33:48.301 T:140039425247360 NOTICE: GL_RENDERER = Mesa DRI Intel 945G
01:33:48.301 T:140039425247360 NOTICE: GL_VERSION = 1.4 Mesa 18.2.3
01:33:48.301 T:140039425247360 NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20

You are on your own. 2.1 is our suggested bare minimum and 4.x is suggested!
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2018-10-28, 12:14)fritsch Wrote: We don't support
Quote:01:33:48.301 T:140039425247360 NOTICE: GL_RENDERER = Mesa DRI Intel 945G
01:33:48.301 T:140039425247360 NOTICE: GL_VERSION = 1.4 Mesa 18.2.3
01:33:48.301 T:140039425247360 NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20

You are on your own. 2.1 is our suggested bare minimum and 4.x is suggested! 
 Is there a way to detect that and gracefully let the user know he's out of luck?
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Yes - we could just exit gracefully to desktop.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
  •   
  • 1
  • 304
  • 305
  • 306(current)
  • 307
  • 308
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524