v16 MYSQL Database doesn't work
#1
Hi all,

I'm trying to set up a mysql database for kodi with the advancedsettings file but doesn't work.

I was created this file with the exemple on kodi wiki and I place to .kodi/userdata .

When I start Kodi, my library doesn't load and the movie and series categories no longer appear. Furthermore, kodi doesn't create databases.

If I delete this file, kodi works fine and I can use my library.

My advancedsettings.xml
Code:
<advancedsettings>
  <videodatabase>
    <type>mysql</type>
    <host>192.168.1.14</host>
    <port>3306</port>
    <user>administrator</user>
    <pass>administrator</pass>
  </videodatabase>
  <musicdatabase>
    <type>mysql</type>
    <host>192.168.1.14</host>
    <port>3306</port>
    <user>administrator</user>
    <pass>administrator</pass>
  </musicdatabase>
  <videolibrary>
    <importwatchedstate>false</importwatchedstate>
    <importresumepoint>false</importresumepoint>
  </videolibrary>
</advancedsettings>

Where could be the problem ?

Thanks you in advance for your help.

Catskan
Reply
#2
a debug log would help, but make sure you followed all the mysql instructions, particularly the server setup.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#3
A common mistake with mysql setup is that mysql server is not configured to listen for incoming connections on LAN,
by default it only listens on 127.0.0.1 , or username% was not configured.

As @nickr said a debug log might provide more clues about what's wrong.
Reply
#4
Hi guys, thanks you for your help.

I have modify the ip by 127.0.0.1. My user can connect to my MYSQL Server because it's the administrator user (for the moment) ...

Kodi's log does not indicate an error but my library doesn't displayed .

Kodi.log
Code:
19:40:59 T:140650481686272  NOTICE: PVRManager - starting up
19:40:59 T:140651473344832  NOTICE: starting zeroconf publishing
19:40:59 T:140651473344832  NOTICE: starting upnp client
19:40:59 T:140649617671936  NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
19:40:59 T:140649617671936  NOTICE: UDP: Listening on port 9777
19:40:59 T:140650464900864  NOTICE: VideoInfoScanner: Starting scan ..
19:40:59 T:140650464900864  NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:00
19:41:02 T:140650464900864  NOTICE: Start - EPG thread started
19:41:05 T:140650498471680  NOTICE: Skin Helper Service --> skin helper service version 1.0.100 started
19:41:05 T:140650498471680  NOTICE: Skin Helper Service --> WebService - start helper webservice on port 52307
Reply
#5
Debug log, please, and no snippets - use pastebin.com for the whole log and provide the link here.
Search | Banned addons (wiki) | Forum rules (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug log (wiki)Free Content
Reply
#6
Hi,

I have enabled log level 2 : http://pastebin.com/mar2g8th

Now, I have the two databases but, when I imported my library, nothing happens ...
Reply
#7
Is your mysql server on the same machine as kodi?
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#8
Yes yes.

I have the databases "MyVideoxx" and "MyMusicxx" but I can't import my backed up library. Films and Series menus no longer display.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
MYSQL Database doesn't work00
This forum uses Lukasz Tkacz MyBB addons.