Kodi 17 - UPnP/DLNA client in Kodi broken for pictures

  Thread Rating:
  • 2 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
cncb Offline
Senior Member
Posts: 117
Joined: Dec 2010
Reputation: 0
Post: #1
The UPnp/DLNA client seems to be broken for Pictures. I have tried 2 servers, Plex and JRiver MC with the same results. The problem is at some random point it fails to navigate down into "subfolders" and just keeps presenting the same folder that you select so you can never get to the pictures. For example, I select my Plex server, then select Photos, My Photos Library, By Year, 2015. When I select 2015 it just keeps displaying the 2015 folder. It seems to happen randomly and not at the same folder level every time.

Note that this doesn't seem to happen in the Kodi DLNA client when browsing the same servers for videos (just pictures). Also note that I am able to browse pictures fine for these same servers with different DLNA clients other than Kodi.
(This post was last modified: 2017-01-13 00:02 by cncb.)
find quote
sherrymaus Offline
Junior Member
Posts: 2
Joined: Oct 2016
Reputation: 0
Post: #2
I do have the same behaviour with Windows Server 2012 R2 as DLNA Server.
find quote
[email protected] Offline
Junior Member
Posts: 1
Joined: Apr 2016
Reputation: 0
Post: #3
I agree fully that dlna does not function reliably in Krypton, while it was at least for my concerns fault-free under Jarvis.

I use dlna to stream pictures and videos from my android device to Kodi. The first two or three pictures are displayed by Krypton but then the streaming stops without any further response. I observed that it also occurs if the picture format and type changes and if I switch quite fast to the next picture.

Is there anybody else that is affected by the problem as well? May you please check it and response?!
find quote
cosi Offline
Junior Member
Posts: 1
Joined: Feb 2017
Reputation: 0
Post: #4
I also encounter a problem using UPnP mode accessing a FritzBox. Indexation and creation of preview pictures seem to work but the actual picture cannot be displayed. A black screen is displayed but the picture never appears.
It works when accessing the box via SMB or FTP protocol.
It worked in version 16.
I could reproduce it on Android TV and a 'real' Android on my tablet, both are on 5.1.
... and just now I also reproduced on Windows 10 client.
(This post was last modified: 2017-02-13 13:09 by cosi.)
find quote
ComboDrums Offline
Junior Member
Posts: 2
Joined: Jul 2016
Reputation: 0
Post: #5

Same problem here with an Sony Bravia / Kodi 17 and a Synology NAS...

Tried on an iPhone with AcePlayer and everything is Ok...

Please fix that bug quickly because it's a feature I always use to show my work (photograph) at the office... Confused

I will disable the automatic update in the future...

(This post was last modified: 2017-03-18 19:57 by ComboDrums.)
find quote
janvonflotow Offline
Junior Member
Posts: 1
Joined: Apr 2017
Reputation: 0
Post: #6
Same here, although completely new with Kodi, started with 16.1, UPNP/DLNA connection with Synology NAS server was fine and reliable
upgrade to Krypton 17.1 and the same connection didn't work anymore.

I can connent via UPNP to my NAS, I can stream a video, but I can not get the subtitle streamed at the same time,
it's not the videoplayer in Krypton, becauses connected via NFS works fine.
Only disadvantage from NFS is that it is slower in connection with the NAS

I hope full UPNP/DLNA service will be updated very soon
find quote