•   
  • 1
  • 78
  • 79
  • 80(current)
  • 81
  • 82
  • 115
  •   
EMINENCE 2 MOD (REVIVED)
@marcd2k13  Hello and welcome! Glad you like the skin! Big Grin

Regarding search functions, you need the global search script for everything to work as expected. If you're on Leia, the skin for the add-on is broken, but I'll fix it soon enough.

The problem with menus and mouse support is a thorn in my side. There are many skins with centralised "popup" menus that the mouse triggers like crazy (the original Eminence among them). Basically, in order for everything to work seamlessly, I'd have to define an invisible area in order to make it triggerable, but Kodi seems to register the cursor as constantly active. So anytime you'd get close to that area, the menu would appear. Unfortunately, there just needs to be some kind of barrier between the menu and the mouse. By far the most acceptable solution to this problem is a side sliding menu like in Aeon Nox, but it's not really applicable in this skins' layout.

In the past, I tried to add an optional vertical layout to the menu itself, move it to the center, etc, but that failed to resolve the issue I just mentioned, in fact, it made it worse. Even in that case, any mouse movement outside the defined menu box made Kodi believe that you wanted to leave, and promptly removed the menu. Basically, the only way to make this kind of interaction work would be to exclude the mouse initially - in that case you would have to trigger the menu with M or by using left/right keyboard shortcuts, that would reveal a menu in the center. You could then use the keyboard/mouse to do your business, but the only way of leaving the menu would be another press with M or left/right, but that sort of process is really annoying for me.

Since I also use the mouse, the best way I've found so far is to just move the cursor upwards, usually near the clock, then trigger the menu with M. What usually happens is that the focus moves to the closest button, and that gives me back mouse control. Obviously, you have to pay attention and not leave the narrow button strip, but that still seems more usable to me than all the other alternatives.

Another thing to consider is using the QuickNav menu. That's a primarily mouse-triggered top menu, that descends whenever the cursor is located in the top portion of the screen. Inside you can put a set of basically all shortcuuts you can think of, anything that the skin shortcuts are capable of. One of those shortcuts can be the view selector window. Go to "Customise QuickNav shortcuts" in the settings, add a menu, input "ActivateWindow(1195)" in the "Action" fiield, enter a label, and the button should work just fine, with one caveat. If you've previously locked a view, the window will still open even when it should be locked, but the viewtype will not change. For that, you'll have to go to the original window as per usual.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
Hi, thanks for replying

I managed to figure out the search issue, and now I've put a search on the home menu using the same script. 

I know what you mean about the menu issue, i had that issue with Eminence 2, which is what led me to your mod as it was more or less a dealbreaker in an otherwise perfect skin as it was impossible to select the 4th poster on each row as that area of the screen triggered the menu.

With regards to the drop down view options menu, could you do something like create a giant redundant button that sits underneath the other buttons, so the menu wouldn't lose focus if your mouse came off a button because it'd be landing on the large one underneath?

I tried the quicknav bar, thanks for the tip on that, i had no idea what it was and just sort of ignored it. I think i will find some uses for it, but unfortunately it doesn't help in this instance as one of the buttons i wanted easy access to was the "hide watched" checkbox as for normal day to day use i like to have stuff i've already watched hidden from view, but there are times when i want to see them, and i couldn't figure out how to put that in the quicknav.

Alternatively, is there a way to add that as an option in the hub or submenu, then i could have an "all movies" and "unwatched movies" button to take me to the different views?
Reply
The problem with big background buttons is that technically the menu interface is already running on a background across the entire screen, so a button wouldn't make much difference. It's the fact that the focus on the menu list is the condition which triggers the menu to appear in the first place that's the real problem. If you set something else to trigger the menu, like an M key or a dedicated button, then anything that unfocuses it hides the menu back, like an accidental mouse movement. And that's the way it's done in all the skins. So really, I need to find a condition that triggers the menu that will have the same effect, so that folks don't need to relearn a new mechanic, but that's also stable enough to ignore accidental mouse movement. Oo

You can achieve the same effect as that button through the following action: SendClick(14). That should toggle between watched/unwatched, and you can use it in the same manner as I've described. However, that's only useful as a switch that you'd like to add somewhere - that's a Kodi command just like the setting in the original submenu. I think that Kodi views the library as one solid block and applies the watched as a filter of sorts, so that there is no native way of separating the two.

The best solution for what you are trying to accomplish in the hub is one that's already available - somewhere among the options in the video library shortcuts selection screen there is an Unwatched Movies playlist that you can add as a hub item, main menu item, etc. The fact it's a playlist means that it will retain a view separate from that of the movie library. So, you can add it in the hub right below the movies, which you can set to watched only or all movies, and the content of the playlist itself won't change unless you watch a movie or mark it watched.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
Ah, playlists achieves what i want, thanks! The built in unwatched movies one only returns 25 movies for some reason but i made my own one with Play Count = 0 and that returns all the ones not marked as watched Smile
Reply
Firstly thanks for a great skin and secondly I apologize if it's been asked before. In Eminence 2 the video osd had a link to ext info. The modded version has a link to info only, is there a way to get ext info on the osd in the modded version?
Reply
(2018-06-30, 01:49)Alanon Wrote:
(2018-06-29, 23:01)barev Wrote: Thanks much Alanon, appreciate your prompt response!
Another quick question: Are animated weather icons supported? When I choose such they do not display, the regular icons are fine.
I am using the Krypton version as under android Leia is still a no-go.
 Yes, I see what you mean. It seems it's broken in Leia as well. I just pushed an update for Krypton, let me know if the icons work for you! 
Thanks man, now it works fine in Krypton!
Reply
I'm surely do something wrong for weather widget.


5. For the Weather widget to work, you must install the multi fanart artwork. For the moment it is needed for the widget to appear.

Image Image Image

I really appreciate eminence skin and more over your mod for the New view and the music osd but don't be able to make weather widget to work.....
Reply
@MrPatate This looks like an issue with the widget shortcut setting, but to tell you anything more precise, I will need more information. Which skin version are you running, what system? Did this issue appear in a particular version or has it been there for a while? I can't reproduce this behaviour on my end. What I can say is, if the location is correctly set up (which it is) and all the resources are selected properly (which they seem to be), then you should see the widget. Even if the temperatures or icons do not display properly, you should at least see the weather fanart. Your screenshot looks as if the widget has not even loaded.

Depending on your current skin version, you could attempt to revert to an earlier one and see if it might fix something. You could also remove and then add the weather widget again, and also reselect the multi fanart, just in case. You might also uncheck or check the "Allow widget reloading" setting (depending on what's currently set up), and see if that helps. If everything else fails, you can always try and reset the skin settings completely and set up the widgets again. This is all just generic advice that might and might not work, if you can provide a link to your debug logs, I can look through them and see if there are any precise clues to what's going on.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
I'm using 2.5.4 version of the skin (don't know How to downgrade to another version) on android tv plateform, using kodi 17.6.

I try to remote and refuse the Weather widget, force reload of widget, try to reset my skin settings without succes. The météo widget work like a charm on eminence original skin.
Don't know if the issue are on other version cause i only try this mod for few days now.

Don't know How to find debug log on android tv.....

Really desapointing cause many option in this mod are absolutly amasing !
Reply
@MrPatate You can look through this guide to find the debug log on our device. After you retrieve it, you can just upload it to any file host and send me the link.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
Hi @Alanon another issue I noticed on Krypton is that in all addons I have keep getting the same annoying error:
Quote:18:30:27.189 T:11368   ERROR: Unable to find plugin extrafanart
18:30:27.189 T:11368   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://extrafanart/
18:30:27.358 T:10640   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
18:30:29.490 T:10640   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
18:30:29.490 T:10640   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
18:30:29.495 T:11368   DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin ExtendedInfo Script('plugin://script.extendedinfo/extrafanart/','4','')
18:30:29.496 T:9772   DEBUG: Thread LanguageInvoker start, auto delete: false
18:30:29.496 T:9772    INFO: initializing python engine.
18:30:29.496 T:9772   DEBUG: CPythonInvoker(15, F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py): start processing
18:30:29.546 T:9772   DEBUG: -->Python Interpreter Initialized<--
18:30:29.546 T:9772   DEBUG: CPythonInvoker(15, F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py): the source file to load is "F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py"
18:30:29.547 T:9772   DEBUG: CPythonInvoker(15, F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py): setting the Python path to F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo;F:\iso\Kodi_dev\kodi-17.6-final\addons\script.module.pil\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.addon.signals\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.autocompletion\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.certifi\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.chardet\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.idna\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.kodi65\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.requests\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.routing\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.simplejson\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.urllib3\lib;F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.youtube.dl\lib;F:\iso\Kodi_dev\kodi-17.6-final\system\python\DLLs;F:\iso\Kodi_dev\kodi-17.6-final\system\python\Lib;F:\iso\Kodi_dev\kodi-17.6-final\python27.zip;F:\iso\Kodi_dev\kodi-17.6-final\system\python\lib\plat-win;F:\iso\Kodi_dev\kodi-17.6-final\system\python\lib\lib-tk;F:\iso\Kodi_dev\kodi-17.6-final;F:\iso\Kodi_dev\kodi-17.6-final\system\python;F:\iso\Kodi_dev\kodi-17.6-final\system\python\lib\site-packages
18:30:29.547 T:9772   DEBUG: CPythonInvoker(15, F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py): entering source directory F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo
18:30:29.547 T:9772   DEBUG: CPythonInvoker(15, F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py): instantiating addon using automatically obtained id of "script.extendedinfo" dependent on version 2.25.0 of the xbmc.python api
18:30:29.550 T:10640   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
18:30:30.266 T:9772  NOTICE: script.module.youtube.dl: youtube_dl core version: 2018.04.25
18:30:30.286 T:9772   DEBUG: script.extendedinfo: version 5.6.1 started
18:30:30.287 T:9772   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'routing.RoutingError'>
                                            Error Contents: No route to path "/extrafanart/"
                                            Traceback (most recent call last):
                                              File "F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py", line 8, in <module>
                                                router.run()
                                              File "F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\resources\lib\router.py", line 53, in run
                                                plugin.run()
                                              File "F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.routing\lib\routing.py", line 115, in run
                                                self._dispatch(path)
                                              File "F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.module.routing\lib\routing.py", line 128, in _dispatch
                                                raise RoutingError('No route to path "%s"' % path)
                                            RoutingError: No route to path "/extrafanart/"
                                            -->End of Python script error report<--
18:30:30.297 T:10640   DEBUG: ------ Window Init (DialogNotification.xml) ------
18:30:30.348 T:9772 WARNING: CPythonInvoker(15, F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py): the python script "F:\iso\Kodi_dev\kodi-17.6-final\portable_data\addons\script.extendedinfo\plugin.py" has left several classes in memory that we couldn't clean up. The classes include: class XBMCAddon::xbmcgui:Big GrinialogBusy
This is just an example with ExtendedInfo but happens virtually with all addons. I can provide a full log if needed. I cannot understand how to switch this search for an extrafanart folder?
Reply
@barev There's something going on with your file structure, that's why there are so many errors. Something in the way you have everything set up is clearly not to the add-ons' liking. For starters, you seem to run everything in portable mode, and I have no idea if all Kodi add-ons are able to work like that. Perhaps there's some particular procedure that would make things function properly.

The concrete error in the log seems to indicate you don't have an extrafanart filepath set up, which complicates things, given your portable use. Perhaps you had configured your library with a centralised artwork folder, and ExtendedInfo expects a path in the same tree, or something of the sort? As far as the memory leak warnings and other warnings that ExtendedInfo produces, they are just a consequence of the add-on itself.

Basically, if the errors are seriously impeding your usage, I would advise you to revise the way you have things set up, or see if there are any specific library artwork tweaks you can apply to lessen the number of errors, although by the sound of it, it appears to be a more serious issue. Regarding the warnings in the logs, we're all pretty much stuck with them until the add-on is updated.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
(2018-07-08, 22:50)Alanon Wrote: @barev There's something going on with your file structure, that's why there are so many errors. Something in the way you have everything set up is clearly not to the add-ons' liking. For starters, you seem to run everything in portable mode, and I have no idea if all Kodi add-ons are able to work like that. Perhaps there's some particular procedure that would make things function properly.

The concrete error in the log seems to indicate you don't have an extrafanart filepath set up, which complicates things, given your portable use. Perhaps you had configured your library with a centralised artwork folder, and ExtendedInfo expects a path in the same tree, or something of the sort? As far as the memory leak warnings and other warnings that ExtendedInfo produces, they are just a consequence of the add-on itself.

Basically, if the errors are seriously impeding your usage, I would advise you to revise the way you have things set up, or see if there are any specific library artwork tweaks you can apply to lessen the number of errors, although by the sound of it, it appears to be a more serious issue. Regarding the warnings in the logs, we're all pretty much stuck with them until the add-on is updated.
Thanks for the prompt reply! You're right I am running in portable mode, actually I've always used kodi like that for years and never had an issue ... actually if I switch the skin I do not get any errors.
The thing is the error is there for absolutely every addon I have installed, the extendedinfo was just an example. I have installed ArtWork Beef and it works, downloads all extended artwork and it is visible. I got this from their documentation:
https://rmrector.github.io/script.artwor...laceextra/
As far as I understand one way for extended art to work is to have a sub-folder in each library folder but then there is the option described in the ArtWork Beef docs. I do not know where is this option to set the extrafanart behaviour? 
If you really think this is because of portable mode I can do a test clean install and provide a log but I get the same error ...
Reply
It would be better if you provide a full debug log. Snippets can be misleading as we cannot see the full picture.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
@barev Let's hold off on the clean install for now, a full log is much easier to create.

Artwork Beef works by ascribing the links to the proper images. Kodi then retrieves and caches the images as necessary, keeping a proper record of what is where. The process can cause some delays and black screens until the images are all cached and loaded. I thought that perhaps you'd used Artwork Downloader which had the centralised folder option and that something broke when you made the switch. However, even if you had, Artwork Beef has compatibility settings that work in such cases, which should have pointed the skin in the right direction. The thing is, none of this in itself should cause any issues at all.

I'm still trying to wrap my brain around the nature of the issue, especially these other add-ons that also produce errors. The skin only contains calls standard add-on calls, and not really that many hardcoded paths, certainly nothing that ought to be expected to cause massive errors. I'd like to know more about the overall behaviour. What do you see while you're in the skin? Does the interface appear normal? Are there any error notifications popping up? While browsing the library, is all the fanart properly displayed? Does the internal info screen work like it should, etc? When you're in the add-ons menu, can you open and change add-on settings, etc? Anything else you can think of to describe your experience might be helpful.
Eminence 2 MOD, Revived & Improved

If you've found me helpful, eh, maybe press the Like button? If you like, you can click here for donations. :)
Reply
  •   
  • 1
  • 78
  • 79
  • 80(current)
  • 81
  • 82
  • 115
  •   
 
Thread Rating:
  • 20 Vote(s) - 4.9 Average



Logout Mark Read Team Forum Stats Members Help
EMINENCE 2 MOD (REVIVED)4.920