Problems speed slideshow Kodi 17.x
#1
When viewing a slideshow of pictures in Kodi17.x it takes a long time to change photo's.
More than 20 seconds even if the delay time is set for 1 second.
The pictures are no bigger than 200 kb and be loaded from a USB stick.
The maximum resolution is 1500x1000, JPG type.
In Kodi Jarvis it works okay.

I use a Raspberry Pi 1B +. What could be the cause?
Reply
#2
please post a Debug Log
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
The URL for te Debug Log: https://paste.ubuntu.com/24077112/
Reply
#4
the lattest nightly (14.3.17 Windows) still has this problem.
Reply
#5
Hi,
same here on a RPi 2 using LibreElec 8.0.1 (Kodi 17.1).
I prepared a test using 55 pictures, about 1.5MB each, 2048x1536, over a SMB share (the same share is where all my media is).
Debug log can be found here: https://paste.ubuntu.com/24314390/

Same beaviour with LibreElec 8.0 (Kodi 17). Up until LibreElec 7.0.3 no slowness whatsoever.

Regards
Reply
#6
Hi all,
I would like to know if the debug log was useful and there are some findings/fixes/plans for this beaviour.

Thank you
Regards
Reply
#7
I have a similar problem using Kodi 17.3 on my Android TV.
Showing even large Photos worked fine using Jarvis 16.1. Now its very slow and often program fails totally.

Is it in any way possible to find and download the old Jarvis 16.1 app again ??
Reply
#8
Similar situation here - running 17.3 on Minix 9H, MiBox, ATV, Bravia 2017 model and Win7 Intel PC, all connected to a Windows file server via GigE. As stated loading (and thumbnail creation) of pictures takes a long time - between 5-7 seconds. Granted - some of the pictures are 20MB JPEG's but that should not be an issue over GigE.

All but the Wintel PC have the same problems. the Wintel PC loads fine and quick - so I have to conclude that the delay is not caused by pulling the image over the network. This is also confirmed by running a slideshow from MCE, also running on the PC - fast and smooth.

Strangest of all - when using the Kodi PictureShow screen saver on any of the devices there is no slowness whatsoever - image gets loaded within the 3 seconds cycle. Must be some difference in pre-fetching going on between the normal picture slideshow and the screen saver.

Any ideas of what is going on here??

thnx
Reply
#9
Disable exif parsing.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#10
Disabling exif parsing didn't resolve this problem.
Reply
#11
Just installed 17.4 and the amount of time set is still ignored.
Reply
#12
it seems, that if I set 5 seconds (default) it will show for 10 seconds or if I set 2 seconds it is there for 4 seconds. I guess better than before...
Reply
#13
With the Confluence skin instead of Estuary, it works better, but not optimally.
Reply
#14
(2017-09-01, 18:59)gert017 Wrote: With the Confluence skin instead of Estuary, it works better, but not optimally.

Thank you for this tip, I'll try it asap.
I haven't thought that the skin might be involved. Up until all 16.x I used Aeon Nox, but I found Estuary to be really good looking so I stuck with it.

Regards
Reply
#15
Using Aeon Nox works better than with Estuary.
Transitions are smooth and each picture is shown for about 10 seconds, with Estuary it takes about 40 seconds and transitions are slow.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Problems speed slideshow Kodi 17.x51