Thread Rating:
  • 0 Vote(s) - 0 Average
Kodi 17 - Using Logitech Companion (BT) ignores Kodi's keymap on letters
#1
I have mapped certain buttons on my Logitech Companion (with Hub) to certain letters to use with Kodi. But when I press the buttons, rather than do what I intend, it will act as if I'm browsing with initials.

Pressing DVR, which I've set to W in Logitech's software, should mark a show/movie/episode as watched. But it just skips down to first title starting with W. Same with C and I, and other keys I've mapped in ~/keymaps/gen.xml.

Buttons I've remapped to F1, F2 and so on works as intended.

The Hub is connected to the PC with Bluetooth.

What am I doing wrong?
I make set posters! (I also take requests)
Reply
#2
Have you programmed them in the remote as capitalized letters or small?
In Kodi, "W" (Shift-W) will jump to the letter W while "w" will be recognized as an action in Kodi.

While the bluetooth control is a good alternative for infrared, it needs a bit of fiddling (and swearing, a clear head and lots of coffee) since the Harmony seems to only understand MCE-remote like devices and can't emulate full keyboard commands.
I think all righthtinking people in this country are sick and tired of being told that ordinary, decent people are fed up in this country with being sick and tired.
Reply
#3
I tried mapping them to both W/I and w./i. in the Harmony software. Same result.

Using the Hub with BT to a PC, you get a full keyboard. You can even map simple commands like alt-tab to a button.
I make set posters! (I also take requests)
Reply



Using Logitech Companion (BT) ignores Kodi's keymap on letters00