Change live TV default audio stream
#1
Hi

I'm using the DVBlink PVR addon with Kodi 17. Not sure if this is a Kodi or DVBlink addon issue.

The problem I'm having is that when watching tv Kodi is defaulting to the first audio stream, which in my case is descriptive audio. I need to default to the second stream (which is English) for all channels but I can't seem to find a way to globally set this. Am I missing something or is this feature missing?

Cheers!
Reply
#2
At the bottom of the audio window - where you change the stream - there's an option to save your selection as default.

Not sure if it will do what you want, but it's worth a try.

Andy
Reply
#3
Thats where I have been changing it but it doesn't seem to change it for all channels, or persist after reloading Kodi/restarting the PC
Reply
#4
There's a setting i use to solve this, it's the 'Prefer default audio stream' option.
I think i had to uncheck it to get the right audio stream.

In Krypton, for some reason it's tucked away in the Language settings.
Reply
#5
(2017-05-09, 00:12)Nomarky Wrote: Hi

I'm using the DVBlink PVR addon with Kodi 17. Not sure if this is a Kodi or DVBlink addon issue.

The problem I'm having is that when watching tv Kodi is defaulting to the first audio stream, which in my case is descriptive audio. I need to default to the second stream (which is English) for all channels but I can't seem to find a way to globally set this. Am I missing something or is this feature missing?

Cheers!

I have exactly the opposite. I also use DVBlink. I am in the Netherlands and use Ziggo as provider. 
Most channels have the choice: 
- Dutch-1/2
- Dutch-ac3 2/3
- Unknown'

Kodi always uses the second (ac3) as default audio stream but i need the first one since it's much more loud and clear. (my AV receiver does all the audio decoding)
I have tried anything in the language settings but unfortunately no solution.

Now i have to switch audio streams manually every time i change a channel.
It is driving me insane

btw. I am using the DSplayer version of Kodi. But the LiveTV is played by the default Kodi player
Reply
#6
(2017-05-10, 09:34)Atreyu Wrote: There's a setting i use to solve this, it's the 'Prefer default audio stream' option.
I think i had to uncheck it to get the right audio stream.

In Krypton, for some reason it's tucked away in the Language settings.
 I am using Ziggo with tvheadend and the 5.1 channels are played as stereo for some reason and they sound horrible.
After unchecking the 'Prefer default audio stream' the 2.0 channels are used by default.
Thanks for the tip!

Update 2017-11-29:
Unfortunately the 'Prefer default audio stream' does not seem to work after all.
I have played a bit with the audio settings and did a reboot.
It now still picks the 5.1 channels but they sound correct now.
Now I will have to wait and see how long it will last Smile
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Change live TV default audio stream00