20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 15
  •   
v17 Problem with video after Windows 10 Fall Creators 2017 Update
#1
Hi, there!

I run KODI 17.4 (Windows store app version) on a Zotac ID68 with Intel HD4400 Graphics adapter.

After I updated Windows 10 to the Fall Creators 2017 Update I got black screen every time I start a video on KODI. The audio runs normal, but no video.

I have to ctrl+alt+del so Task Manager screen appears and after hit ESC everything goes normal. When i hit STOP, black screen comes again and I have to go to the same keyboard procedure to bring the video back.

One thing I noticed is that the monitor accuses the refresh rate changes when I start and stop video as everything is OK, but the KODI screen is black.

A friend of mine who has the same hardware but runs modified KODI 17.4 to run 3D MVC, said me he got the same problem, but once he runs a 3D ISO there's no black screen anymore, even with 2D, until he restarts KODI.

Does anybody knows how to solve this issue?
Reply
#2
I have the same issue after windows10 updated to 1709, KODI 17.3
Reply
#3
This sounds more like graphics adapter illness. Wondering when this anomaly pops up what a few jabs on the keyboard slash do (windowed vs screen). Sounds like the interface is hidden behind a background and graphics memory limits the image refresh. Since two of you seem to be experiencing the same symptoms and without a debug log pro-offered, throw in a portable version of Kodi Leia and let's see where that takes us; debug log (wiki) and all.
Reply
#4
I have the same issue with Kodi 17.4 after windows10 updated to 1709.
My NUC PC has a HD6000 gpu. Even if I reinstall the latest Intel HD6000 driver the problem occurs.

But if I disable "Adjust display refresh rate" in the Kodi video settings the video is visible again.
So I guess it has something to do with the way windows controls the refresh rate or prevents other apps to do so.

Maybe someone can give more prof input here.
Reply
#5
Quote:Maybe someone can give more prof input here.

without a debug log nothing further will be offered from the devs, but thanks for the input, something that didn't come to mind at the time of my post.

P.S. I still have my Amiga 3000 sitting next to me, did you see the Raspberry Pi will run Amiga o/s! I'm tempted; RetroPlayer might offer a spark https://forum.kodi.tv/forumdisplay.php?fid=194
Reply
#6
Thanks for the feedback. I'll try to create a log later.

P.S. I owned an Amiga 1000 and sold it 10 years ago - I regret it now. Good idea to try out the Rasberry Pi. Thanks Smile
Reply
#7
Please find the log file here:
https://paste.ubuntu.com/25788035/

Thanks for your time and the great software!
Reply
#8
I have been encountering an issue with image distortion after the fall update. My issue occurs when I have the adjust refresh rate option on. I usually have it set to always. After the update leaving this option on will result in video playing back with distorted colors mainly appearing green. If I leave this option off the video plays in normal video quality. This issue is occurring on my Intel NUC. It is the core i3 7100 with HD 620 graphics. The graphics driver is the latest version. Below is my debug log. Thank you.

https://pastebin.com/XJNahJ7A
Reply
#9
Hi, I also have issues with refresh rate changes after fall update 1709. I'm using Kodi with DSplayer but I don't think it's related. Even if I disable DSplayer as default I don't get any picture as soon as a movie requires a refresh rate change. 50fps material works.
If I disable refresh rate change everything works as expected. Also did a fresh install of latest NVidia driver.
Logs here, but I couldn't spot anything obvious.
https://pastebin.com/igiAT19t
Kodi 17.x running on Nvidia Shield, 1x KODIbuntu
mySQL hosted on WHS 2011
Reply
#10
The fall update interferes heavily with installed drivers. Some people report that the video driver is deleted and another one is installed by Windows update. Driver settings are reset etc.
In my case (AMD) all settings were reset, all my custom resolutions were deleted, my audio driver was killed. So I manually had to reinstall all these things.
Many settings in the OS were affected. I didn´t realize that an OS "update" does things like a "clean install". The fall update was a heavy one - took some time for "preparation", some download time, some install time and many reboots. After it I had a Windows.old folder in C:\ 30GB large...

So: Check your drivers and system settings!
Reply
#11
As said: In my case latest driver reinstalled and checked. No obvious findings.
Kodi 17.x running on Nvidia Shield, 1x KODIbuntu
mySQL hosted on WHS 2011
Reply
#12
Same problem with me Kodi 17.4 after upgrade to Windows 10 1709.   I turned off DXVA and changed to software rendering and it worked but quality was terrible. I have gone back to Win 10 1703 until this one is sorted. I will have play with drivers to to see if I can sort this one out.
Reply
#13
Here's my log file:

https://paste.ubuntu.com/25793773/

Cheers.
Reply
#14
Same prb here. I have intel hd 4000 graphic. 
I'll try to reinstall latest version of drivers
Reply
#15
(2017-10-22, 16:39)mambro Wrote: Same prb here. I have intel hd 4000 graphic. 
I'll try to reinstall latest version of drivers

No... same problem after driver update

Sad
Reply
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 15
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Problem with video after Windows 10 Fall Creators 2017 Update52