Solved Kodi 17.6 Failing to play some FLAC files
#1
Since upgrading to Kodi 17.6 (2:17.6+git20171114.2125-final-0xenial) I've noticed that a number of FLAC audio files are failing to play when they have previously played just fine.  When one of the affected files is selected from the library the player pauses for a number of seconds and then eventually throws an error and moves on to the next song in the list.

If I try to play the affected songs via the Files list rather than the library then they play perfectly ok.

Having looked at the logs it seems as though the player is incorrectly identifying the affected FLAC files as MP3s.  I have some debug logs showing good and bad files but the highlights look to be:

DEBUG: Loading settings for musicdb://artists/837/387/4887.flac?albumartistsonly=false&albumid=387&artistid=837
DEBUG: CPlayerCoreFactory::GetPlayers(musicdb://artists/837/387/4887.flac?albumartistsonly=false&albumid=387&artistid=837)
DEBUG: Open - probing detected format [mp3]
DEBUG: Open - setting usetoc to 0 for accurate VBR MP3 seek
DEBUG: Open - avformat_find_stream_info starting
ERROR: ffmpeg[7F073F629980]: [mp3] Header missing
ERROR: Previous line repeats 788 times.
DEBUG: ffmpeg[7F073F629980]: [mp3] Stream #1: not enough frames to estimate rate; consider increasing probesize
DEBUG: ffmpeg[7F073F629980]: [mp3] Could not find codec parameters for stream 0 (Audio: mp3, 0 channels, s16p): unspecified frame size
DEBUG: ffmpeg[7F073F629980]: [mp3] Consider increasing the value for the 'analyzeduration' and 'probesize' options
DEBUG: FactoryCodec - Audio: passthrough - Opening
DEBUG: FactoryCodec - Audio: passthrough - Failed
Reply
#2
Hello Graham68

Could you please post your full debug log at a pastebin type site...
  1. Locate a Pastebin type site. Two examples are https://pastebin.com/ or https://paste.ubuntu.com/
  2. Paste the contents of the kodi.log file
  3. Press Paste or Generate or Create New Paste
  4. When the screen refreshes with your paste, copy the entire address in the address bar and paste it into a new message in your thread
Note: Full logs only. No partial or redacted logs

Can you also scan your one of your problem FLAC files with MediaInfo and also post that result... 1707519 (post)

Thanks
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#3
This sounds like a player issue, and the player devs will not look at partial logs. They may also want a sample file to test with if you could upload the smallest one somewhere.  Also what version of Kodi did you upgrade from that was playing these files ok?
Reply
#4
Could you do a full debug as requested but first of all play one of the files using the Files view so we can see the logging for successful playback, then immediately after play the file again from Library view. Once that is done could you remove one of the albums containing the problem files from the Library and then scan the Album back in to the Library again then try playing the album again, as I've seen it before where removing and rescanning an album cures playback problem, not sure if maybe in some instances something in the databases/Library gets corrupt.
Reply
#5
(2017-12-08, 02:34)Graham68 Wrote: If I try to play the affected songs via the Files list rather than the library then they play perfectly ok.
Just noted that it plays from file view, hence discount what I said before - not going to be a player or file issue. Hence a library issue somehow.

So please get the full logs as @jjd-uk suggests, but could you wait before dropping the album and rescanning as I would like to be able to investiagate the causes a little rather than simply solve the problem.
Reply
#6
I have possibly the same issue (but I didn't check the log). I have a full CD album, ripped as FLAC files, that was played fine by Kodi until some day when it refused to do so.

Since then Kodi doesn't want to play this FLAC folder if it's selected from the Library, although it does when it's chosen from the File view.

For this reason I suspected the problem is related to metadata, and I created a new album with same FLAC content but completely different metadata: cover/album title/artist/track titles etc. It still doesn't play from the Library !

What is really weird is that this album was ripped to FLAC by Exact Audio Copy, using the very same settings than for many other albums that just play fine.

I even tried to delete the music Library completely, and to rebuild it from scratch. Same issue.
Reply
#7
Well @Geeeronimo provide debug log please of both playback from file view, and failure from within library.

Also if you can upload say the first song from such an album to somewhere I can see and PM me a link that would be useful too.

I would like to get to the bottom of this odd behaviour if I can
Reply
#8
OK ! Which debug item should I activate ?
Reply
#9
Simply enable debug logging, no component specific settings needed at this point. Try play in the two different ways, then post to pastebin or equivalent. Thanks
Reply
#10
Pastebin of debug log attached:  https://pastebin.com/ayD7GYyZ

Pastebin of media info for track '4887':  https://pastebin.com/sZt3vEiT


Notes:

  musicdb://artists/837/387/4885.flac  &  musicdb://artists/837/387/4889.flac  are songs that play ok.
  
  musicdb://artists/837/387/4887.flac  &  musicdb://artists/837/387/4888.flac  are songs that exhibit the issue.
Reply
#11
(2017-12-08, 13:08)jjd-uk Wrote: Could you do a full debug as requested but first of all play one of the files using the Files view so we can see the logging for successful playback, then immediately after play the file again from Library view. Once that is done could you remove one of the albums containing the problem files from the Library and then scan the Album back in to the Library again then try playing the album again, as I've seen it before where removing and rescanning an album cures playback problem, not sure if maybe in some instances something in the databases/Library gets corrupt.

I have now posted debug logs, but for library playing only. If you still want logs for File play vs Library play then let me know.

I have already removed and rescanned and even deleted the database files altogether and then rescanned from scratch.

I do updates as they come along so I *assume* I was previously running Kodi 17.5 ??
Reply
#12
Graham I'm not sure you have done quite what jjd_uk suggested. Do the songs that don't play from the library, play from file view?

If they do then can I have a debug log of that happening
Reply
#13
(2017-12-08, 17:34)DaveBlake Wrote: Graham I'm not sure you have done quite what jjd_uk suggested. Do the songs that don't play from the library, play from file view?

If they do then can I have a debug log of that happening


Hi Dave,  as noted in my initial post the affected files do indeed play from file view.  I'll try and grab a comparative log later today and post that. Cheers.
Reply
#14
Smile 
(2017-12-08, 04:04)Karellen Wrote: Hello Graham68

Could you please post your full debug log at a pastebin type site...
  1. Locate a Pastebin type site. Two examples are https://pastebin.com/ or https://paste.ubuntu.com/
  2. Paste the contents of the kodi.log file
  3. Press Paste or Generate or Create New Paste
  4. When the screen refreshes with your paste, copy the entire address in the address bar and paste it into a new message in your thread
Note: Full logs only. No partial or redacted logs

Can you also scan your one of your problem FLAC files with MediaInfo and also post that result... 1707519 (post)

Thanks 
 Thanks for the pointers Karellen, that was a very helpful post. :-)
Reply
#15
On my side I have done both actions, playing from Library then playing from Files, in the same sequence. From Library it doesn't play, and the interface freezes during ~30s. From Files no problem.

My full kodi.log is here
https://pastebin.com/xCHVyQ86

Graham you're right, it seems that the FLAC file is erroneously interpreted as MP3. See the error messages:

DEBUG: Open - probing detected format [mp3]
ERROR: Open - Error, could not open file 
[from Library]

and 
DEBUG: Open - probing detected format [flac]
[from Files]

Dave, I PM you a cloud link to this FLAC sample file. Very good music Wink

I'm very curious to understand this weird bug ! Thanks a lot.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi 17.6 Failing to play some FLAC files00