Dosbox on RPi3 - Blank screen
#1
Whenever I launch a dosbox game from IARL the screen goes blank.  If I open the OSD, I can then see a faded out dos screen in the background but not the game.  Not sure where to even begin with this, but I have uploaded the kodi.log file of when this occurs: http://ix.io/VA7
Reply
#2
Still occurring with Dosbox.. 
Logs using the most recent available release, LibreELEC (community): devel-20180817210318-#0817-geef941c (RPi2.arm) available at http://ix.io/1kEx.
I launch IARL, goto best of Sierra, and then launch Quest for Glory I VGA, the screen goes completely black from there, however, if I pause or open the OCD the game appears faded in the background.

Because images help when detailing an issue.. here is what it looks like

Image
Reply
#3
Got the same issue with dosbox, also with stella emulator for Atari 2600.
Reply
#4
I also have the same issue with the newest LibreElec 8.95.001 build, so Kodi v18 RC3. I tried to tinker with a dosbox conf file but I couldn't figure out where to put it.
Reply
#5
Try changing the emulated_machine setting in the dosbox settings.  svga_s3 seems to work well for me.
Reply
#6
I have tried several of those, doesn't help. (The resolution and colors of the interface visible in the background of the menu do change however, so the change to the emulated machine seems to work in principle..)
Reply
#7
(2018-12-31, 15:29)rock_city Wrote: I have tried several of those, doesn't help. (The resolution and colors of the interface visible in the background of the menu do change however, so the change to the emulated machine seems to work in principle..)
 Does this happen with all games (if not it could be the game/files/game config file)?  What happens if you just start the dosbox addon from Kodi?
Reply
#8
Thanks for your replies, appreciate it. I have in fact mainly tested the dosbox as an addon standalone because I also suspected a problem with game configurations, so yes, the problem also persists there. (I also tried multiple different games, also both from the Internet Archive ROM Launcher and standalone ROMs..)
Reply
#9
Same issue here on LibreELEC/Milhouse build. There's no crash or whatsoever in the log, just a black screen with DOSBox itself. When exitting (via typing exit), it returns to Kodi perfectly without any notice of problems in the log....
Reply
#10
Same here

Hardware: (Raspberry Pi3 B+)
Software: (LibreELEC-RPi2.arm-9.0.0 (fresh installed)
Log-Files: http://ix.io/1AC8
               http://ix.io/1AC9

- When I try to start any game or the plain Dos-Box AddOn I get a black screen
- I can hear Sound, if the Game has any
- If I open the Menu via F4, the screen appears in the Background. When I close the menu the black screen reapers again

Changing the emulated_machine or output setting has no effect

Any Ideas!?
Reply
#11
Same problem here, too. Also Libreelec 9.0.0 on rpi3 and dosbox configured by iagl.
Reply
#12
You are delusional if you think MS-DOS is somehow “better” than Raspbian Linux. Anyways, you cannot run MS-DOS on an ARM-based architecture.
Reply
#13
Hi head4587451

I'm sorry but Dosbox is a MS-DOS Emulator and run's on a lot of Operating Systems and Processor Architectures including Linux and ARM on which Libreelec is based on.

If you want, you can look it up here:  https://www.dosbox.com

The mentioned problem here is that the games run (you can hear sound, but you can only see a black screen unless you enter a Menu)
Reply
#14
Same problem for me, Libreelec 9.0.1 on rpi2 and dosbox addon.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Dosbox on RPi3 - Blank screen00