Solved Kodi 17.6 upgrade remote app fail.
#1
Bug 
I have a iPhone X and using a Google Player device with Kodi installed. I just updated to Kodi 17.6. The problem is with the older version Kodi I was able to use the official Kodi Remote APP iOS with no issues. Now with the upgrade the APP will not recognize the Google Player. It states I have to announce these services with Zeroconf. When I go to the google player and go to Kodi APP, service settings, there is no menu for Zeroconf. I have seen posts with window 10 that people change ports and configure to allow sharing, but I have no idea how to make changes on the Google Player so that my iPhone can work again with the remote app. Any help would be appreciated!
Reply
#2
You should find the zeroconf switch in settings > services > general and the remote control ones in settings > services > control .

You may need to change the menu level (lower left corner of the settings screens) to advance or expert to see all the available options.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#3
Google player doesn’t even sound related to kodi imo ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#4
Thank you for your response. I have done what you have suggested, but am still unable to find a place where to “announce my device/services so that my iPhone APP remote will work again. I uploaded a clip on YouTube so that anyone can see what is happening.
Reply
#5
I'll move this to Android rather than iOS as the device is Android based.

I think we need a debug log (wiki) to see what's going on here. The zeroconf setting is absent, but you have the remote control active on port 8080 with username kodi and no password.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#6
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#7
As you suggested, I found my old LG Nexus 5. Downloaded the Kodi Remote APP. The APP would not automatically find the Google Player, so I manually input all information, and bam Kodi tag came up top right corner found new device. So, it is working on an Android device. But what sucks is, before the upgrade I was able to use my IPhone. Hopefully I am not the only one with this issue, and maybe a fix can be found. Hopefully it’s not user error, lol. Thank you for your time and advise.
Reply
#8
Just to eliminate the basics, can you double check the settings in the iOS app match those on the box (same user name, password, port and the correct IP address)?
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#9
im Going to upload another clip
Reply
#10
I uploaded another clip for you to view. If you see something I am doing wrong, please let me know. Thank you.
Reply
#11
Try removing the Mac address from the iPhone settings.

On my setup I just use the IP address and port (Pi3 as server and iPhone 7 as remote) and it works fine.

If that fails, as a test try changing the port on both from 8080 to 80.

The only differences I see from yours to mine is the port (which shouldn't matter as long as they match) and the Mac address entry. But also my Pi is running LibreElec and has zeroconf, which may be key.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#12
Removing the MAC worked! That’s crazy. Before the upgrade to 17.6 on the older version I did not put in MAC, my iPhone Kodi Remote APP could not find the Google Player device, until I put in the MAC and announced the device.
With the upgrade I assumed I had to put all same information in. Just as I put in the MAC for my Android phone to work when you had me try Android device. So, now I know the difference is no MAC on the iPhone, and no menu for announce device. There always quirks/tweeks that always seems to happen with upgrades. Thankful for this forum. And thank you for your responses and time. Really appreciate it. Have a good night.
Reply
#13
Thread marked solved.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi 17.6 upgrade remote app fail.00