•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 13
  •   
Important -  Skinners: Please test PR13754
#16
@ksooo  and @Hitcher it seems that my OSD issue is related having debug log enabled. With debug on the OSD just shows the artist fanart, no controls etc., and<m> or <i> does not toggle the overlay.

When debug disabled I can see the OSD controls overlay, but Next track is blank (@jjd-uk spotted that, and reproduced the other stuff).

I notice @Hitcher mentioned Confluence widgets. The odd thing is that although initially missing from the Confluence home screen, the widgets finally appeared for me, never had that long delay before. The submenus below the music main menu is missing in master too, so not related to this PR.

Also the debug log has lots of
ERROR: CGUIInfoManager::GetMultiInfoLabel - unable to get item for listitem label 35182!
ERROR: CGUIInfoManager::GetMultiInfoLabel - unable to get item for listitem label 35117!
that does not happen in master.

Hope that is helpful
Reply
#17
Not Confluence but my fTV skin.
Reply
#18
This PR breaks another PR : "container referencing without explicitly specifying an id"

Forum: http://forum.kodi.tv/showthread.php?tid=...pid2471756
PR: https://github.com/xbmc/xbmc/pull/10883

All widget infolabels which depend on this PR don't show up anymore. On a side note: I'm happy to report that the "<variables>" and "<listitem properties>" limits are gone for now, everything seems to be working fine with ~2k variables and more than 500 listitem properties.

Thanks!
Reply
#19
(2018-04-10, 19:00)bkury Wrote: This PR breaks another PR : "container referencing without explicitly specifying an id"

Forum: http://forum.kodi.tv/showthread.php?tid=...pid2471756
PR: https://github.com/xbmc/xbmc/pull/10883

All widget infolabels which depend on this PR don't show up anymore.
 Can you please give me step by step instructions, so that I can reproduce and fix the problem.
Reply
#20
@ksooo the 'missing widget infolabels' can be reproduced with Estuary.
just focus one of the movies on the home screen.

Master:

Image




PR13754:

Image
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#21
Using KodiSetup-20180410-a7a146e0-guiinfo-interface-x64

not getting anything in music containers for ListItem.Property(Artist_*) and at least some of ListItem.Property(Album_*)

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Krypton
Leia
Reply
#22
(2018-04-10, 23:25)scott967 Wrote: Using KodiSetup-20180410-a7a146e0-guiinfo-interface-x64

not getting anything in music containers for ListItem.Property(Artist_*) and at least some of ListItem.Property(Album_*)

scott s.
.


How can I reproduce that, step by step? I'm not a skinner and need more information. Otherwise I cannot do anything about it.
Reply
#23
With 20180410-a7a146e0-guiinfo-interface using Estuary songs node, duration of song shown on side panel is wrong, while list is OK

Image

Both durations shown correctly on master
Reply
#24
(2018-04-11, 09:27)DaveBlake Wrote: With 20180410-a7a146e0-guiinfo-interface using Estuary songs node, duration of song shown on side panel is wrong, while list is OK

Both durations shown correctly on master
 Which labels do not work? How do you identify that it "does not work"? What is a song node. How do I navigate to a song note?

 EDIT: nvm, found it. will take a look.
Reply
#25
(2018-04-11, 06:58)ksooo Wrote:
(2018-04-10, 23:25)scott967 Wrote: Using KodiSetup-20180410-a7a146e0-guiinfo-interface-x64

not getting anything in music containers for ListItem.Property(Artist_*) and at least some of ListItem.Property(Album_*)

scott s.
.


How can I reproduce that, step by step? I'm not a skinner and need more information. Otherwise I cannot do anything about it. 

In the music window, create a container (eg list container) for the default library artist or album view nodes.  a label control to display $INFO[ListItem.Property(artist_description)] when Container.Content(artists) is true, or a label control to display $INFO[ListItem.Property(album_description)] when Container.Content(albums) is true is always empty (when the required data does exist in the database).
scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Krypton
Leia
Reply
#26
(2018-04-11, 11:18)scott967 Wrote: In the music window, create a container (eg list container) for the default library artist or album view nodes.  a label control to display $INFO[ListItem.Property(artist_description)] when Container.Content(artists) is true, or a label control to display $INFO[ListItem.Property(album_description)] when Container.Content(albums) is true is always empty (when the required data does exist in the database).
Scott, I'm seeing these OK on Confluence (when looking at Media Info view of either artists or albums nodes) can you test again.

Image
Reply
#27
(2018-04-11, 06:58)ksooo Wrote:
(2018-04-10, 23:25)scott967 Wrote: Using KodiSetup-20180410-a7a146e0-guiinfo-interface-x64

not getting anything in music containers for ListItem.Property(Artist_*) and at least some of ListItem.Property(Album_*)

scott s.
.


How can I reproduce that, step by step? I'm not a skinner and need more information. Otherwise I cannot do anything about it. 
I have to retract that.  I should have inspected my music database before I started testing.  have to start over now.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Krypton
Leia
Reply
#28
Thanks for the feedback, guys. New test builds available:

Windows:
http://mirrors.xbmc.org/test-builds/wind...ce-x64.exe

OSX:
http://mirrors.xbmc.org/test-builds/osx/...x86_64.dmg

Following issues should be fixed:
* missing fanart/posters in info dialogs
* Confluence: music fullscreen OSD not working when debug logging is activated
* Confluence: next song information missing in fullscreen music OSD
* wrong song duration (format, hh:mm instead of mmConfuseds) displayed in music node side panel
* missing widget info labels for audio/video items (example: video/audio channels etc. in lower right of Estuary home screen)

Would be nice if the issue reporters could retest and report back. Thanks.

Are there any other open issues?
Reply
#29
@ksooo what nightly would you like any new issues (if any occur) checked against? In otherwords have you rebased your test build, or is it still against 20180409-9f206f47 master?
Reply
#30
@ksooo missing art is working perfectly; home widgets are almost working - the first item in my lists are empty which seems to be a problem when using list item position (0).

ie 
Container(2001).ListItemPosition(0).Icon

EDIT: Confluence Movies, TV shows, and music submenus are visible now but disappear when focused.
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 13
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Skinners: Please test PR1375400