20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 14
  •   
Solved SONY AF9 w/ AndroidTV Oreo - Installation via Play Store fails with Error Code -506
#16
(2018-10-27, 12:16)Rossi40 Wrote: Thank you.
Now its working but only 1080p.
Is yours the same

Thanks

It’s not working for me, I can see the splashscreen but it closes after that.

Do you activate an option ?
Reply
#17
Could someone build these altered versions for newest beta 32 & 64 bit please?
Reply
#18
I finally found a solution
I noticed that Kodi only opens when audio output is set to "audio system". By the way, playback stop if I switch the audio output to "TV speakers"

Play / stop controls of the remote are not working
Reply
#19
(2018-10-27, 07:48)chrisyu Wrote:
(2018-10-26, 19:42)Rossi40 Wrote:
(2018-10-25, 09:00)chrisyu Wrote: I think Sony blocked Kodi's package id.
Me and some users tested, both Kodi 18 64bit and 32bit cannot be installed.

I compiled Kodo 32bit, changed it's package id to com.amazon.aiv.eu .
Kodi get installed and runs just fine.

Can you upload your Kodi please.
I try to change the id but not working.

Thanks   
I uploaded it here, you can give it a try. 
Good luck.

https://mega.nz/#!wNUyzSDa!N3ZhqXysKprPp...X4a_alHdj0 
 Could you please build latest beta for Sony AF9 TV(don't know if is it 32 or 64 bit)
Reply
#20
Smile 
Hello,

You can find below the apk for KODI 18 BETA 4 compiled with the same package id provided by chrisyu.

https://mega.nz/#!SC5FgCSR!JaC8Zd7Cwyoqc...UcLIMezixc

Only the ARM-32bit works cause even if the CPU is an ARM AArch64, the firmware is based on Linux 32-bit :

16:31:08.360 T:18446744072925837680  NOTICE: Running on Sony BRAVIA 4K UR1 with Android 8.0.0 API level 26, kernel: Linux ARM 32-bit version 4.9.51
16:31:08.360 T:18446744072925837680  NOTICE: Host CPU: AArch64 Processor rev 2 (aarch64), 4 cores available

As nycom said, it's working only if the TV speakers are disabled.

Thx chrisyu and nycom !!!
Reply
#21
(2018-11-01, 11:13)supertoto1977 Wrote: You can find below the apk for KODI 18 BETA 4 compiled with the same package id provided by chrisyu.

https://mega.nz/#!SC5FgCSR!JaC8Zd7Cwyoqc...UcLIMezixc

Although you seem to be clearly trying to help it would be remiss of me not to point out to users that this is your first post and that downloading something from someone who is new should be treated with caution. Please understand this is not meant as any slight to you, however we now live in world where people do all sorts of malicious things. Could any users who decide to try this please provide feedback.
Reply
#22
I am building it myself. Does anybody know what else except APP_PACKAGE in version.txt has to be changed please?
I don't have problem even TV speakers is enabled, but I am using it on new ZF9 set though.
Reply
#23
(2018-11-01, 12:28)jjd-uk Wrote: Please understand this is not meant as any slight to you, however we now live in world where people do all sorts of malicious things. Could any users who decide to try this please provide feedback. 
 No problem, I understand than you can be suspicious, because it's my first post...
I can only swear that it's built from the Kodi source code without any change.
I use to read this forum since for years now, and it's the first time i think i can help cause.
That's why i decided to create an account and to post the apk.

But if people prefer to wait a "trustable" source, there's no offense.
Reply
#24
(2018-11-01, 12:47)tchabada Wrote: I am building it myself. Does anybody know what else except APP_PACKAGE in version.txt has to be changed please?
I don't have problem even TV speakers is enabled, but I am using it on new ZF9 set though.
 I use only the command below in the root directory of Kodi sources to replace all org.xbmc.kodi by com.amazon.aiv.eu before compiling.
It's usefull for the java source to update the package name.
 
Quote:find ./ -type f -readable -writable -exec sed -i "s/org.xbmc.kodi/com.amazon.aiv.eu/g" {} \;
Reply
#25
(2018-11-01, 13:04)supertoto1977 Wrote:
(2018-11-01, 12:47)tchabada Wrote: I am building it myself. Does anybody know what else except APP_PACKAGE in version.txt has to be changed please?
I don't have problem even TV speakers is enabled, but I am using it on new ZF9 set though.
 I use only the command below in the root directory of Kodi sources to replace all org.xbmc.kodi by com.amazon.aiv.eu before compiling.
It's usefull for the java source to update the package name.
 
Quote:find ./ -type f -readable -writable -exec sed -i "s/org.xbmc.kodi/com.amazon.aiv.eu/g" {} \;
Thank you.
Reply
#26
I am building it based on this https://github.com/xbmc/xbmc/blob/master...Android.md tutorial, but the output is always debug even if I configure it with --disable-debug parameter.
Reply
#27
(2018-10-31, 13:30)tchabada Wrote:
(2018-10-27, 07:48)chrisyu Wrote:
(2018-10-26, 19:42)Rossi40 Wrote: Can you upload your Kodi please.
I try to change the id but not working.

Thanks   
I uploaded it here, you can give it a try. 
Good luck.

https://mega.nz/#!wNUyzSDa!N3ZhqXysKprPp...X4a_alHdj0  
 Could you please build latest beta for Sony AF9 TV(don't know if is it 32 or 64 bit) 
 I cannot build 64bit version following the build guide, it failed with errors.

And I have trouble to get latest 32bit version running too.
Since beta4, binary addons were removed.
Official nightly builds are usually 60M in file size, but I still get 90M.
It built fine, but crashes after start.

So the apk at 13# is the latest working version I could compile for now.
Reply
#28
(2018-11-01, 12:47)tchabada Wrote: I am building it myself. Does anybody know what else except APP_PACKAGE in version.txt has to be changed please?
I don't have problem even TV speakers is enabled, but I am using it on new ZF9 set though.
 I think change APP_PACKAGE in version.txt is enough.

You could find more package ids from this post : https://community.sony.co.uk/t5/android-...773/page/3 

Some of them are Apps(Video), like com.amazon.aiv.us and com.amazon.aiv.eu .
Some are Game, like com.gaikai.client .
Reply
#29
export Configuration=Release
./configure --disable-debug --with-tarballs=$HOME/android-tools/xbmc-tarballs --host=arm-linux-androideabi --with-sdk-path=$HOME/android-tools/android-sdk-linux --with-ndk-path=$HOME/android-tools/android-ndk-r18b --with-toolchain=$HOME/android-tools/arm-linux-androideabi-vanilla/android-21 --prefix=$HOME/android-tools/xbmc-depends

anyway the application has 94M and seems like debug kodiapp-armeabi-v7a-debug.apk
Reply
#30
Debug mode seems to be the default.
To compile the Beta4 source in release mode, i did some change in tools/depends/configure.ac
Modify the line 29 from [use_debug=yes] to [use_debug=no]
Quote:AC_ARG_ENABLE([debug],
  [AS_HELP_STRING([--enable-debug],
  [enable debugging information (default is yes)])],
  [use_debug=$enableval],
  [use_debug=no])

then you can execute :
/configure --with-tarballs=$HOME/android-tools/xbmc-tarballs --host=arm-linux-androideabi --with-sdk-path=$HOME/android-tools/android-sdk-linux --with-ndk-path=$HOME/android-tools/android-ndk-r18 --with-toolchain=$HOME/android-tools/arm-linux-androideabi-vanilla/android-21 --prefix=$HOME/android-tools/xbmc-depends

I had some error with gradel when building the apk, but the package named debug is built.
This package is installed successfully.

For information, the first beta4 apk provided by me is compiled in debug mode.
I can provide the same in release mode if there's a request.
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 14
  •   
 
Thread Rating:
  • 3 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
SONY AF9 w/ AndroidTV Oreo - Installation via Play Store fails with Error Code -50653