v18 Player hang or GUI freeze upon stopping video since RC4
#1
High level summary:  either the GUI freezes or player hangs when I stop playback.

Detailed summary:  hitting stop on the remote causes video play back to stop, but the Kodi GUI does not return. All I see on the screen is the frozen frame of the video as if I paused playback (of course without the Kodi GUI that is displayed when video playback is paused).  Kodi does not respond to subsequent buttons on my remote or to physical key presses on the attached keyboard.  I can only recover by restarting kodi.  This happened 3 times in 6 days (since I built RC4) so it is rather infrequent and difficult to reproduce.

Link to regular kodi.log.  Note that I did not have debug level enabled when it occurred so all you see here is a non-debug log for now.  I have since enabled debug level and will update the thread when/if I get more to go one.  All I see in the log right now is WARNING: ActiveAE - large audio sync error: -89387.982607 ... I did not notice any audio/video disconnect on the screen despite this warning.

I am interested to hear any thoughts and thank you.
Need help programming a Streamzap remote?
Reply
#2
Please attach with gdb and see where it hangs.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2019-01-06, 17:59)fritsch Wrote: Please attach with gdb and see where it hangs.

I am pretty unfamiliar with gdb but from googling, it seems that I need debugging options compiled into kodi... I am building kodi like this.  Do I need to add anything?  Further, I am using a systemd service unit to start kodi.  Simply appending `/usr/bin/gdb ...` to the `ExecStart=` doesn't work.  Recommendations on how to incorporate it would be helpful.  Thanks.

Code:
[Unit]
Description=Kodi standalone
After=systemd-user-sessions.service network-online.target sound.target mysqld.service
Requires=network-online.target
[email protected]

[Service]
User=kodi
Group=kodi
PAMName=login
TTYPath=/dev/tty1
ExecStart=/usr/bin/xinit /usr/bin/kodi-standalone -- :0 -nolisten tcp vt1
Restart=on-abort
StandardInput=tty

[Install]
WantedBy=graphical.target
Need help programming a Streamzap remote?
Reply
#4
Just stop the service, X &
export DISPLAY=:0
gdb /whatever/kodi-x11
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
@fritsch - I can't get that to work... the systemd service initiates the X-session for the kodi user.

Code:
% sudo su - kodi -c 'export DISPLAY=:0 && /usr/bin/gdb /usr/lib/kodi/kodi-x11'             
GNU gdb (GDB) 8.2.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib/kodi/kodi-x11...(no debugging symbols found)...done.
(gdb) 
Need help programming a Streamzap remote?
Reply
#6
Okay, then I cannot help you further ... stopping works here nicely.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#7
I will post back if/when I get a debug log with this error.  Maybe something to go on from there?  Failing that, I can probably install a DE on this box and have the kodi user logged in to get the debug output... doing it through that systemd option is going to be tough I think.
Need help programming a Streamzap remote?
Reply
#8
Got it... here is a debug log with the freeze (it happened on the list item viewed "Skiplist_S01E06...").  Anything useful in the log?
Need help programming a Streamzap remote?
Reply
#9
No. Nothing I see on first look -> gdb please and make sure it's not some "half libraries not newly build properly" issue.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#10
(2019-01-07, 08:05)fritsch Wrote: No. Nothing I see on first look -> gdb please and make sure it's not some "half libraries not newly build properly" issue.

EDIT: OK... starting it under a DE now via this command:
Code:
gdb -ex run /usr/lib/kodi/kodi-x11 | tee $(date "+%Y%m%d_%H%M%S").trace.log
Need help programming a Streamzap remote?
Reply
#11
@fritsch - No crash yet, but is the output of gdb consistent with your expectations?

Code:
$ tail -n20 20190107_113852.trace.log 
[New Thread 0x7fff857ca700 (LWP 1258)]
[New Thread 0x7fff85fcb700 (LWP 1259)]
[New Thread 0x7fff867cc700 (LWP 1260)]
[New Thread 0x7fff847cc700 (LWP 1261)]
[Thread 0x7fff847cc700 (LWP 1261) exited]
[Thread 0x7fff867cc700 (LWP 1260) exited]
[Thread 0x7fff85fcb700 (LWP 1259) exited]
[Thread 0x7fff857ca700 (LWP 1258) exited]
[New Thread 0x7fff847cc700 (LWP 1262)]
[New Thread 0x7fff867cc700 (LWP 1263)]
[New Thread 0x7fff85fcb700 (LWP 1264)]
[New Thread 0x7fff857ca700 (LWP 1265)]
[Thread 0x7fff857ca700 (LWP 1265) exited]
[Thread 0x7fff85fcb700 (LWP 1264) exited]
[Thread 0x7fff867cc700 (LWP 1263) exited]
[Thread 0x7fff847cc700 (LWP 1262) exited]
[Thread 0x7fffa97fa700 (LWP 1103) exited]
[Thread 0x7fffd9c1b700 (LWP 1058) exited]
[Thread 0x7fffda41c700 (LWP 1057) exited]
[Thread 0x7fffdb02d700 (LWP 1050) exited]
Need help programming a Streamzap remote?
Reply
#12
Yes. Wait until it hangs, then type: ctl c

Afterwards: thread apply all bt

and paste entire terminal including kodi.log please
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#13
(2019-01-07, 18:47)fritsch Wrote: Yes. Wait until it hangs, then type: ctl c

Afterwards: thread apply all bt

and paste entire terminal including kodi.log please

@fritsch - I managed to get the freeze to occur and thanks to your help, I captured the gdb trace.

Link to gdb trace.
Link to kodi log.

Really interested in your thoughts and thanks again!
Need help programming a Streamzap remote?
Reply
#14
Thanks. Now we have all information. Please open a github issue, use the template and link the two logfiles there!

From a first look it seems some some script's monitor blocks on exit for a long time.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#15
Wink 
(2019-01-08, 08:07)fritsch Wrote: Thanks. Now we have all information. Please open a github issue, use the template and link the two logfiles there!

From a first look it seems some some script's monitor blocks on exit for a long time.
 Done, #15220.  Thanks again for your help!
Need help programming a Streamzap remote?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Player hang or GUI freeze upon stopping video since RC400
This forum uses Lukasz Tkacz MyBB addons.