•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 13
  •   
Important Windows Store v18 update resets my settings
#61
(2019-01-30, 02:36)robross0606 Wrote:
(2019-01-30, 01:51)YaYaTurre Wrote: It worked! I copied all of the files from the Local Cache\Roaming\Kodi to the Local State folder, and everything is back to normal. All repositories and addons are restored.

Thanks so much!
Are you actually able to access any of your local data if you have any?  As far as I can tell, v18 has no access to any hard drive paths.

This might be another UWP limitation, if you are trying to access locally stored media files then something in the back of my mind is whispering it might be due to file system restrictions imposed by Microsoft.
Reply
#62
(2019-01-30, 03:18)jjd-uk Wrote:
(2019-01-30, 02:36)robross0606 Wrote:
(2019-01-30, 01:51)YaYaTurre Wrote: It worked! I copied all of the files from the Local Cache\Roaming\Kodi to the Local State folder, and everything is back to normal. All repositories and addons are restored.

Thanks so much!
Are you actually able to access any of your local data if you have any?  As far as I can tell, v18 has no access to any hard drive paths. 

This might be another UWP limitation, if you are trying to access locally stored media files then something in the back of my mind is whispering it might be due to file system restrictions imposed by Microsoft. 
I've installed the EXE version and have been trying to migrate everything over.  There's just a huge amount of data that was completely lost.  All custom cover settings.  All collection settings.  Across hundreds of movies and shows.
Reply
#63
(2019-01-30, 03:36)robross0606 Wrote: I've installed the EXE version and have been trying to migrate everything over.  There's just a huge amount of data that was completely lost.  All custom cover settings.  All collection settings.  Across hundreds of movies and shows. 
Shouldn't be if you copy the user-data folder across, unless you've copied the 'newly' installed userdata without your customization's.
Reply
#64
If you go to the exe version, in addition to copying userdata, you also have to copy addons. Then within Kodi, go to settings/addons/my addons/all and look for addons with an X next to them. These need to be updated. After they're updated, they will appear in your add-ons.
Reply
#65
(2019-01-30, 03:03)jjd-uk Wrote: After enabling try closing Kodi and then starting Kodi again if you haven’t already tried this.

Thanks, but I did try that as well and still locks up.
Reply
#66
First post of this thread has been updated.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#67
@Bilbo430

It is to that point where we now need a Debug Log.

  1. Enable Debugging mode.
    a. Go to Settings>System Settings>Logging and it should be the first option or
    b. press ctrl-shift-d on a keyboard
  2. Restart Kodi. Do not skip this step or you may be asked to do it again.
  3. Replicate the problem. Now that debug mode is enabled, repeat the steps that cause the problem.
  4. Upload the log using either the:
    a. Manual method to Kodi Paste Site. Log location is detailed here... Log_file/Advanced#Location (wiki) (see next section for more details), or
    b. Add-on method using the Kodi Logfile Uploader. (wiki)
    With either method post the address link in the address bar in a new post in your thread.
Note: Full logs only. No partial or redacted logs
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#68
Much the same with my Kodi update. No local drives etc
Now attempting to copy over from localcache to localstate  and recover.
If that doesn't work, I'll copy the appropriate folders and files from my latest backup.
Will be going to bed soon, to await the howls of anguish telephone calls in the morning, from the Kodi users I support.
Not a happy bunny.
Reply
#69
(2019-01-30, 04:20)Karellen Wrote: @Bilbo430

It is to that point where we now need a Debug Log.

ilopetiken (paste)
Reply
#70
Deep gloom. Everything restored but when attempting to access Movies or TV Shows, Remote Share path not found or invalid caption pops up.
Folders and Files are on a seperate local drive.
Deeply disappointed Surbiton
Reply
#71
Wow this is pretty messed up.

I'm trying to do fix #2, keeping the UWP v18. I have copied and pasted all the data as instructed. But in Kodi all of my libraries are still empty.

FYI my media is on an attached USB 3.1 drive. I can play media from the Files folder, but none of the Media Sources that I had created can access my media, I see an error "Path Not Found or Invalid".

I see there are 2 options to fix this, using the exe or the UWP version. Which option should make it easiest to get back up and running. I'm very confused now.
Kodi 18.0 on Windows 10 Home, version 1803. Intel NUC7 i5 BNKP, 16GB RAM.
Reply
#72
I'm running into lots of errors when trying to copy the Kodi sub-directory out of the LocalCache/Roaming directory. This occurs both with the GUI and also using robocopy ("The file cannot be accessed by the system"). I've tried using robocopy both as myself and as an Administrator (which is to say: I invoked the Command Prompt as Administrator; I'm assuming that carries over to any commands I run, too). Seems like some sort of permissions issue? On Linux I'd know how to solve this, but I don't use Windows for anything other than gaming and Kodi so I don't have a clue.

Anyone else running into this or have suggestions? Looks like all the data I need is still there, I just can't access it which prevents me from being successful with either of the proposed solutions...
Reply
#73
Have you exited Kodi before trying to move system files?
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#74
(2019-01-30, 06:25)Karellen Wrote: Have you exited Kodi before trying to move system files?
 Yes. Verified with Task Manager that nothing Kodi-related seems to be running. The message I get from the GUI is: "Error 0x80070780: The file cannot be access by the system."
Reply
#75
(2019-01-28, 07:46)Karellen Wrote: Solution No.1
You may choose to install using the downloadable .exe version. The main benefit is that there are no UWP restrictions and you have control over the update of Kodi. You may choose to uninstall the Store Version.
  1. Go to the Download page
  2. Select either INSTALLER (64BIT) OR INSTALLER (32BIT)
  3. Run the installer
  4. After Kodi has been installed, do not start it.
  5. Go to C:\Users\<yourusername>\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalCache\Roaming\ and copy the \Kodi\ folder
  6. Go to C:\Users\<yourusername>\AppData\Roaming\ and paste the \Kodi\ folder
  7. Start Kodi
Following these steps I uninstalled the UWP Leia 18 (store version) after upgrading from 17.6, and installed Kodi 64 bit EXE version. Got to step 5 and there was no XMBCFoundation folder under C:\Users\<yourusername>\AppData\Local\Packages. Am I out of luck?
It's not a huge deal to have to add my library folders again since I didn't have much customization apart from having to mark everything already "watched" one by one, but I'd rather avoid it if I can.
Thanks.
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 13
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Windows Store v18 update resets my settings00