Switching channels taking 5+ seconds
#1
Anyone having an issue with changing channels in Kodi v18?  Using NPVR, changing channels is less than a second.  

Is there some setting I need to disable? Sometime it takes so long that the channel is time shifted a few seconds.
Reply
#2
Although you still won't get NextPVR client speed optimization, if your goal is fast changing configure real time mode.

Martin
Reply
#3
(2019-07-01, 05:27)emveepee Wrote: Although you still won't get NextPVR client speed optimization, if your goal is fast changing configure real time mode.

Martin

Thanks for the response. I did make it real time and I'm still having this issue. Also nextpvr and kodi are on the same box.  I think this is happening because of the newest version of Kodi but I can't confirm that.

Ben
Reply
#4
If you post both your Kodi debug logs and the compressed NextPVR logs here or on the NextPVR support forum we can have a look.  It would be good to include a test showing tuning in Kodi and in NextPVR itself.

Martin
Reply
#5
(2019-07-02, 14:44)emveepee Wrote: If you post both your Kodi debug logs and the compressed NextPVR logs here or on the NextPVR support forum we can have a look.  It would be good to include a test showing tuning in Kodi and in NextPVR itself.

Martin
Kodi Logs: uyucovavif.kodi (paste)
NPVR: ocodezixes.kodi (paste)


Thanks for taking a look!

-Ben
Reply
#6
Although that is not the debug Kodi log, it looks there is a difference in the tuning process when changing channels on the windows client.  The first tune is the same time as Kodi but there looks like optimization on the graph changes that the web server doesn't use.  sub would need to explain any backend difference to see if improvement is possible.

Martin
Reply
#7
(2019-07-07, 05:18)emveepee Wrote: Although that is not the debug Kodi log, it looks there is a difference in the tuning process when changing channels on the windows client.  The first tune is the same time as Kodi but there looks like optimization on the graph changes that the web server doesn't use.  sub would need to explain any backend difference to see if improvement is possible.

Martin

Thanks for analyzing! How do we ask Sub?  Also where are the kodi debug logs located?  I could send you that if you think it's helpful.
Reply
#8
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#9
(2019-07-08, 01:43)Karellen Wrote: The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
I believe the add-on is Ares? Although this one is Ares Wizard.  Not sure why it's banned but I tried that application to fix this issue.  I removed it. Here are the new logs.

fuzerexomu.kodi (paste)
Reply
#10
You've still got multiple banned addons (wiki) and repos in there (anything in the addon/repo part that's in orange is banned).

They are all banned basically as they supply or enable direct access to illegally sourced media in violation of our piracy policy (wiki). That's part of the forum rules (wiki) that you accepted and agreed to abide by when you signed up here.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#11
(2019-07-08, 16:42)DarrenHill Wrote: You've still got multiple banned addons (wiki) and repos in there (anything in the addon/repo part that's in orange is banned).

They are all banned basically as they supply or enable direct access to illegally sourced media in violation of our piracy policy (wiki). That's part of the forum rules (wiki) that you accepted and agreed to abide by when you signed up here.

Thank for the quick reply.  This is probably a good exercise anyway since I have add-ons I don't use.

I went through Kodi and deleted a ton of things. egukeganit.kodi (paste)

Does it look clean now?

Thanks!
Reply
#12
You've missed a couple:

2019-07-08 10:55:21.526 T:14288 NOTICE: ADDON: plugin.program.indigo v2.0.2 installed
2019-07-08 10:55:21.527 T:14288 NOTICE: ADDON: script.tvaddons.debug.log v1.0.7 installed

The former you can maybe get rid of by uninstall, but the latter will probably need to be removed manually (it's one of those orphaned scripts that stays behind even when you uninstall the main add-on, another reason why we "love" these things so much...).

To do that, close down Kodi, and open the folder C:\Users\flyin\AppData\Roaming\Kodi\addons in file manager (or your file app of choice). In there you should find sub-folders for each addon installed on your system. Just delete the one for script.tvaddons.debug.log and if you haven't removed it elsewhere also for plugin.program.indigo . You should then be good to go on the next boot of Kodi.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#13
(2019-07-08, 17:07)DarrenHill Wrote: You've missed a couple:

2019-07-08 10:55:21.526 T:14288 NOTICE: ADDON: plugin.program.indigo v2.0.2 installed
2019-07-08 10:55:21.527 T:14288 NOTICE: ADDON: script.tvaddons.debug.log v1.0.7 installed

The former you can maybe get rid of by uninstall, but the latter will probably need to be removed manually (it's one of those orphaned scripts that stays behind even when you uninstall the main add-on, another reason why we "love" these things so much...).

To do that, close down Kodi, and open the folder C:\Users\flyin\AppData\Roaming\Kodi\addons in file manager (or your file app of choice). In there you should find sub-folders for each addon installed on your system. Just delete the one for script.tvaddons.debug.log and if you haven't removed it elsewhere also for plugin.program.indigo . You should then be good to go on the next boot of Kodi.

I think I got them! I don't see anymore Orange. egukeganit.kodi (paste)

Thanks!
Reply
#14
Yup, all clean now, although depending on the issue it may also need debug logging enabled (Settings > System Settings > Logging) and perhaps some of the component logging as well (same screen).

But let's see if things as they are is enough for someone more knowing in this area to help (not me I'm afraid).
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#15
"sub3"  Are you able to shed some light on this? Thanks!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Switching channels taking 5+ seconds00