•   
  • 1
  • 50
  • 51
  • 52
  • 53(current)
  • 54
  •   
Release plugin.video.themoviedb.helper - Access to TheMovieDb API for Skinners
(2021-11-16, 18:22)cool0007 Wrote: Hello! I am getting an error in addon version 4.4.22. The version KODI 19.3 is used for the add-on settings and KODI in Russian. How can this error be corrected? Thanks!

@cool0007 - Please try latest version from github (v4.4.23) - it should fix the error.

Commit: https://github.com/jurialmunkey/plugin.v...4cdfd21aba
Reply
@jurialmunkey
Hello! Thanks for your feedback and quick response! I installed the updated version of the plugin on Android 11, it works correctly with the Russian language! There are no more mistakes. This is a great job and thank you for your kind attitude towards Kodi users! Laugh

Image

Log file https://paste.kodi.tv/ifadatimev
Reply
@jurialmunkey When using:-

Code:
plugin://plugin.video.themoviedb.helper/?info=cast

Is there a way to get cast for an episode? The wiki only list movie, tv or person as the type. At the moment I'm having to fallback to embuary helper to get the episode cast and I'd rather try to use the same add-on for all info.

Thanks

Edit:-

Sorry my bad.... If I'd scrolled down the wiki a little bit further I would have found

Code:
plugin://plugin.video.themoviedb.helper/?info=episode_cast

I feel like an idiot now, sorry Sad
Reply
Umm.... I can't seem to get info=episode_cast to work. Looking at the following image my plugin path seem to be fine but all I get returned  in my cast widget is a list of the parent items from the add-on. Any ideas? Thanks

watch gallery
Reply
Probably you need to use & in place of all those &, as it's shown on the wiki (and because it's an XML document Wink).
Reply
@drinfernoo Yep, I already am using & amp; Kodi just converts them when printing the label control.

Code:
<control type="label">
  <label>& amp;</label>
</control>

Actually outputs a single & and not & amp; 

Sorry for the spaces but this forum does the exact same thing, converts & amp; in to a single &, how did you get them to display in your post?

These are the variables generating the query, again ignore the space in & amp;
Code:
<variable name="Info_Param_Episode_Cast_Query">
    <value condition="!String.IsEmpty(ListItem.Year)">query=$INFO[ListItem.TvShowTitle]& amp;year=$INFO[ListItem.Year]</value>
    <value>query=$INFO[ListItem.TvShowTitle]</value>
</variable>

<variable name="Info_Episode_Cast_Members">
    <value>plugin://plugin.video.themoviedb.helper/?info=episode_cast& amp;type=tv& amp;$VAR[Info_Param_Episode_Cast_Query]& amp;season=$INFO[ListItem.Season]& amp;episode=$INFO[ListItem.Episode]</value>
</variable>

Anyway, unfortunately that's not the problem Sad
Reply
Ok, fixed it. It looks like the wiki is wrong to get the episode cast you just call the standard cast with a season and episode value

Code:
plugin://plugin.video.themoviedb.helper/?info=cast&type=tv&$VAR[Info_Param_Episode_Cast_Query]&season=$INFO[ListItem.Season]&episode=$INFO[ListItem.Episode]
Reply
Ok, new problem with episode cast Big Grin

<variable name="Info_Param_Episode_Cast_Query">
    <value condition="!String.IsEmpty(ListItem.Year)">query=$INFO[ListItem.TvShowTitle]&year=$INFO[ListItem.Year]</value>
    <value>query=$INFO[ListItem.TvShowTitle]</value>
</variable>

<variable name="Info_Episode_Cast_Members">
    <value>plugin://plugin.video.themoviedb.helper/?info=episode_cast&type=tv&$VAR[Info_Param_Episode_Cast_Query]&season=$INFO[ListItem.Season]&episode=$INFO[ListItem.Episode]</value>
</variable>

When generating the query I use the ListItem.Year to ensure the correct show is fetched, however take the example of the show Beyond from 2017

Beyond Season 1 2017
Beyond Season 2 2018

I can query episodes from season 1 fine as the year is correct for searching but when querying season 2 the search year is wrong and nothing is found.

​​​​​​​Any ideas on how to solve this problem?
Reply
Don't pass the year?
Reply
Unfortunately that's not really an option. As I said you need to pass the year to ensure the correct result is returned. If in my example of the 2017 series Beyond you don't pass the year then the add-on returns the 2021 Disney+ series 'Just Beyond'. This can be tested by just searching for 'Beyond' on tmdb site, the correct result is actually fourth in the list of results.
Reply
A quick look on IMDb shows that the first episode of season 2 was actually in 2017... maybe try 2017 for both seasons?
Reply
Thanks for the help, but the problems are:-

1. While imdb has s02e01 listed as 2017 the rest of season 2 is listed as 2018 and they wont look up with that year.
2. I'm using themoviedb add-on so have no access to imdb dates anyway.

The problem is that at the episode level in Kodi, where I'm doing the cast lookup, Kodi returns ListItem.Year as the year for the episode, what I really need is a way to get the year for the base TV Show at the episode level, much like ListItem.TVShowTitle returns the base TV Show title at the episode level.

It's probably going to be easier to just use embuary helper for episode cast lookups, Thanks anyway.
Reply
@jurialmunkey Hi, I'm trying to use plugin.video.themoviedb.helper to replace Extended Info using this wiki page as a guide.

https://github.com/jurialmunkey/plugin.v...ended-Info

I've got it mostly working, with one issue when browsing into TV Shows. I can't browser back out of the TV Show, I just end up at the root of the plugin.

Please see this video for a demonstration, turn on subtitles for a description of the issue.



Any help would be appreciated, thanks.
Reply
Nobody has any ideas what the problem could be? Sad
Reply
(2021-11-22, 11:53)roidy Wrote: When generating the query I use the ListItem.Year to ensure the correct show is fetched, however take the example of the show Beyond from 2017

I can query episodes from season 1 fine as the year is correct for searching but when querying season 2 the search year is wrong and nothing is found.

Sorry for the late reply. Tapatalk is not refreshing my forum feeds for some reason, so I didn't even realise there were comments here! If you can't get me here, usually I'm pretty good at responding to issues posted on the github: https://github.com/jurialmunkey/plugin.v...per/issues

You're right about the 'episode_cast' now just being the 'cast' call (I'm bad at remembering to update documentation).

For the episode year search with a query, use the "episode_year=" param instead -- e.g.
Code:
plugin://plugin.video.themoviedb.helper/?query=Beyond&episode_year=2018&tmdb_type=tv&info=cast&season=2&episode=2

The year param is a strict match (must match year), whereas episode_year param tells query to look for the most recent show with a first air date on or before the episode_year specified. I probably didn't document this function! I'm trying to be better with documentation these days so I'll update it now! Wink


(2021-11-26, 16:56)roidy Wrote: @jurialmunkey Hi, I'm trying to use plugin.video.themoviedb.helper to replace Extended Info using this wiki page as a guide.

https://github.com/jurialmunkey/plugin.v...ended-Info

I've got it mostly working, with one issue when browsing into TV Shows. I can't browser back out of the TV Show, I just end up at the root of the plugin.

Hmm, this might be a tricky one. Is this just using the built-in button from the info dialog? Or do you use a specific browse command?

I don't think reopening the info dialog is possible after navigating in MyVideoNav (too hard to determine what the user is intending to do). However, there are a couple of options. The first is to create a custom dialog to act as a fake browsing window that sits on top of the video info dialog (which you hide with a conditional animation). It's pretty hacky but would allow for returning to the video info since you never close it.

The other option is what I do in Arctic Horizon, which is a custom browse button with the following onclick actions (I also display it when a movie is part of a set by checking ListItem.IsCollection so that the user can browse the set). The reason there's two sets of commands (one for MyVideoNav and one for elsewhere) is because if MyVideoNav is open I do a container update (call_update=) instead of activatewindow (call_path=)


<onclick condition="Window.IsVisible(MyVideoNav.xml) + String.IsEmpty(ListItem.DBID)">RunScript(plugin.video.themoviedb.helper,close_dialog=1190,call_update=$INFO[ListItem.FolderPath])</onclick>
<onclick condition="Window.IsVisible(MyVideoNav.xml) + !String.IsEmpty(ListItem.DBID) + String.IsEqual(ListItem.DBType,tvshow)">RunScript(plugin.video.themoviedb.helper,close_dialog=1190,call_update=$INFO[ListItem.DBID,videodb://tvshows/titles/,/])</onclick>
<onclick condition="Window.IsVisible(MyVideoNav.xml) + !String.IsEmpty(ListItem.DBID) + ListItem.IsCollection">RunScript(plugin.video.themoviedb.helper,close_dialog=1190,call_update=$INFO[ListItem.DBID,videodb://movies/sets/,/])</onclick>

<onclick condition="!Window.IsVisible(MyVideoNav.xml) + String.IsEmpty(ListItem.DBID)">RunScript(plugin.video.themoviedb.helper,close_dialog=1190,call_path=$INFO[ListItem.FolderPath])</onclick>
<onclick condition="!Window.IsVisible(MyVideoNav.xml) + !String.IsEmpty(ListItem.DBID) + String.IsEqual(ListItem.DBType,tvshow)">RunScript(plugin.video.themoviedb.helper,close_dialog=1190,call_path=$INFO[ListItem.DBID,videodb://tvshows/titles/,/])</onclick>
<onclick condition="!Window.IsVisible(MyVideoNav.xml) + !String.IsEmpty(ListItem.DBID) + ListItem.IsCollection">RunScript(plugin.video.themoviedb.helper,close_dialog=1190,call_path=$INFO[ListItem.DBID,videodb://movies/sets/,/])</onclick>
Reply
  •   
  • 1
  • 50
  • 51
  • 52
  • 53(current)
  • 54
  •   



Logout Mark Read Team Forum Stats Members Help
plugin.video.themoviedb.helper - Access to TheMovieDb API for Skinners2
This forum uses Lukasz Tkacz MyBB addons.