Solved Kodi crashes on Startup
#1
Hi.
I got a Nvidia Shield and my Kodi still crashes at startup. It is set to start scarping using tvdb from startup Sad
The folders containing the addons are empty :o

My kodi log:
---
2019-08-09 16:10:40.289 T:20024  NOTICE: -----------------------------------------------------------------------
2019-08-09 16:10:40.289 T:20024  NOTICE: Starting Kodi (18.3 Git:20190619-89472b7d69). Platform: Android ARM 64-bit
2019-08-09 16:10:40.289 T:20024  NOTICE: Using Release Kodi x64 build
2019-08-09 16:10:40.289 T:20024  NOTICE: Kodi compiled 2019-06-28 by Clang 7.0.2 (https://android.googlesource.com/toolchain/clang 003100370607242ddd5815e4a043907ea9004281) (https://android.googlesource.com/toolchain/llvm 1d739ffb0366421d383e04ff80ec2ee591315116) for Android ARM 64-bit API level 21 (API level 21)
2019-08-09 16:10:40.290 T:20024  NOTICE: Running on NVIDIA SHIELD Android TV with Android 9.0.0 API level 28, kernel: Linux ARM 64-bit version 4.9.140-tegra-g8e6798163e77
2019-08-09 16:10:40.293 T:20024  NOTICE: FFmpeg version/source: 4.0.3-Kodi
2019-08-09 16:10:40.293 T:20024  NOTICE: Host CPU: ARMv8 Processor rev 1 (v8l), 4 cores available
2019-08-09 16:10:40.293 T:20024  NOTICE: Product: foster_e, Device: foster, Board: foster_e - Manufacturer: NVIDIA, Brand: NVIDIA, Model: SHIELD Android TV, Hardware: foster_e
2019-08-09 16:10:40.295 T:20024  NOTICE: External storage path = /storage/emulated/0; status = ok
2019-08-09 16:10:40.295 T:20024  NOTICE: ARM Features: Neon disabled
2019-08-09 16:10:40.295 T:20024  NOTICE: special://xbmc/ is mapped to: /mnt/expand/14a780e6-7b45-4a97-a9b0-d048dec4b347/user/0/org.xbmc.kodi/cache/apk/assets
2019-08-09 16:10:40.295 T:20024  NOTICE: special://xbmcbin/ is mapped to: /mnt/expand/14a780e6-7b45-4a97-a9b0-d048dec4b347/user/0/org.xbmc.kodi/cache/apk/assets
2019-08-09 16:10:40.295 T:20024  NOTICE: special://xbmcbinaddons/ is mapped to: /mnt/expand/14a780e6-7b45-4a97-a9b0-d048dec4b347/user/0/org.xbmc.kodi/cache/apk/assets/addons
2019-08-09 16:10:40.295 T:20024  NOTICE: special://masterprofile/ is mapped to: /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/userdata
2019-08-09 16:10:40.295 T:20024  NOTICE: special://envhome/ is mapped to: /storage/emulated/0/Android/data/org.xbmc.kodi/files
2019-08-09 16:10:40.295 T:20024  NOTICE: special://home/ is mapped to: /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi
2019-08-09 16:10:40.295 T:20024  NOTICE: special://temp/ is mapped to: /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/temp
2019-08-09 16:10:40.295 T:20024  NOTICE: special://logpath/ is mapped to: /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/temp
2019-08-09 16:10:40.295 T:20024  NOTICE: The executable running is: /mnt/expand/14a780e6-7b45-4a97-a9b0-d048dec4b347/app/org.xbmc.kodi-MwPRID3v3BdkRAX8jAOpuA==/lib/arm64/libkodi.so
2019-08-09 16:10:40.295 T:20024  NOTICE: Local hostname: [unknown]
2019-08-09 16:10:40.295 T:20024  NOTICE: Log File is located: /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/temp/kodi.log
2019-08-09 16:10:40.299 T:20024  NOTICE: -----------------------------------------------------------------------
2019-08-09 16:10:40.313 T:20024    INFO: loading settings
2019-08-09 16:10:40.314 T:20024  NOTICE: special://profile/ is mapped to: special://masterprofile/
2019-08-09 16:10:40.314 T:20024   ERROR: CSettings: unable to load settings from special://masterprofile/guisettings.xml, creating new default settings
2019-08-09 16:10:40.314 T:20024 WARNING: Failed to save the default settings to special://masterprofile/guisettings.xml
2019-08-09 16:10:40.314 T:20024   FATAL: unable to load settings

---

Sorry but I tried to use paste.kodi.tv but couldn't find out how to use it :I(

What to do?

DB
Peter
Reply
#2
@PPlys

I don't think that is a TVDB problem. Looks like you have a corrupt install. I will split your post and move it to Android forum and others may be able to help you fix the problem.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#3
Hi

Did you get this fixed? I've got the exact same problem. It started after the tvdb issue and after trying all the fixes for that with nothing working I did a fresh install and my log file looks identical to yours.

nvidia shield with experience 8.0, kodi 18.3
Reply
#4
Fixed by doing a full factory reset of the shield and starting again! Strange but there you go...
Reply
#5
(2019-08-09, 16:43)PPlys Wrote: My kodi log:
Next time, kindly use a pastebin website for logs and other text snippets. Smile
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#6
Thread marked solved.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi crashes on Startup00