Error: Operation not permitted
#1
Yesterday I allowed Microsoft to apply a feature update to Win10 release 1903 on one of the PC's on my local network.  Now, when I try to access a media source on that PC from Kodi installed on another device on the same local network, i get the "Error: Operation not permitted" message.  Curiously, other PC's in the network can still access that computer via Windows Explorer - Network, and Plex installed on the same device as Kodi can also access the same media sources that Kodi now cannot.  I'm pulling my hair out.  I've checked all the Share permissions, SMBv1 enabled, network discovery turned on at all levels, etc., but haven't been able to find the solution.  BTW, the computer in question just uses the User account with no login password, and it is also running VPN, which has never been a problem in the past.  I even added a Registry Key to disable User Account Control remote restrictions and rebooted, but nothing has worked.  Any ideas?
Reply
#2
SMBv2 requires a user account with a password, it also no longer supports network browsing. So the "Error: Operation not permitted" may be a clue.
Enabling SMBv1 is upholding the Swiss cheese "protection" that SMBv1 is. (Google for 'WannaCry'). Disable the VPN, it has nothing to do with Kodi anyway (see our VPN policy (wiki)).

Hacking your Windows registry is really outside the scope of this forum.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#3
(2019-08-13, 18:26)Klojum Wrote: SMBv2 requires a user account with a password, it also no longer supports network browsing. So the "Error: Operation not permitted" may be a clue.
Enabling SMBv1 is upholding the Swiss cheese "protection" that SMBv1 is. (Google for 'WannaCry'). Disable the VPN, it has nothing to do with Kodi anyway (see our VPN policy (wiki)).

Hacking your Windows registry is really outside the scope of this forum.

Please understand I am not running VPN on the device where Kodi is installed (an Amazon Firestick 4K).  It just happens to be running (for other non-Kodi purposes) on the PC where some of my media sources are located.  And, I have no real wish to hack the Windows Registry anyway - it was just a suggestion I saw elsewhere, but it didn't make any difference.  Does Kodi use SMBv2?  How can I tell?  (I'm running Kodi Leia 18.3)  And, if it does, how do I make sure that is enabled on the media sources PC?

The strange thing is I have the NextPVR addon loaded in Kodi, and that can communicate with NextPVR on the PC just fine - it loads the channels, EPG, etc. all from NextPVR on the PC.  But, then when I try to access a media source, that's when I get the error.  Why would Kodi be able to communicate with the PC for some things but not others?
Reply
#4
It's okay, I was just informing you of this forum's view on certain topics.

Override SMB settings for Kodi itself via System / Settings / Services / SMB Client / Minimum protocol version, and maybe enable the "Use legacy security", although that is not really recommended.

PVR stuff is 'not my department', but I can imagine that it uses its own network connections.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
SOLVED!  I found that in 'Network and Sharing Center' / 'Advanced Sharing Settings', under 'All Networks' there is a category called 'Media Streaming', with a link called 'Choose media streaming options'.  Is this new?  I haven't seen it before.  When I click the link, it says "Media streaming is not turned on", and there is a button to "Turn on media streaming".  I clicked that, and then 'OK'

Also at the bottom, there is a category called 'Password protected sharing'.  The default was 'Turn on password protected sharing.'  I changed it to 'Turn off password protected sharing' and then clicked 'Save Changes' at the bottom.

Kodi was then able to access the media sources on the PC again, perfectly OK as before the Microsoft update.

I'm still at a loss to understand why Plex was able to access those media sources when Kodi couldn't, but the problem is resolved now.  Thanks for your time, and I hope this helps someone else.
Reply
#6
(2019-08-13, 18:20)Galaxy266 Wrote: Yesterday I allowed Microsoft to apply a feature update to Win10 release 1903 on one of the PC's on my local network.  Now, when I try to access a media source on that PC from Kodi installed on another device on the same local network, i get the "Error: Operation not permitted" message.  Curiously, other PC's in the network can still access that computer via Windows Explorer - Network, and Plex installed on the same device as Kodi can also access the same media sources that Kodi now cannot.  I'm pulling my hair out.  I've checked all the Share permissions, SMBv1 enabled, network discovery turned on at all levels, etc., but haven't been able to find the solution.  BTW, the computer in question just uses the User account with no login password, and it is also running VPN, which has never been a problem in the past.  I even added a Registry Key to disable User Account Control remote restrictions and rebooted, but nothing has worked.  Any ideas?
It might not have the right to read the files or change permissions on the files. Theerror clearly indicates that syncthing is not allowed to do something. You might want to check ignore permissions flag on the folder. Yes, it's because the file has a different owner than the user running syncthing.
This may help you : https://docsbay.net/operation-not-permit...ion-failed
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Error: Operation not permitted00