v17 How to have .srt language specific selected by default ?
#1
Hi, v17.6 here

I have videos with inside their directory subtitles with two different languages:

Code:
name.el.srt
name.en.srt

Now when i play the video always it displays the .en.srt or the just .srt subtitle as default. What i want is to FIRST have display the .el.srt and if it not there/available then fall back to the .srt file.

I have change the settings=>media=>subtitles as default the "Greek" but i think this applies to the DVD player and not video files.

Any help ?

Kind regards,
Vassilis
Image
Reply
#2
One way would be correct naming. Maybe this will help... 2865465 (post) and 2861861 (post)

Other members may advise of other methods.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#3
(2019-08-16, 10:51)Karellen Wrote: One way would be correct naming. Maybe this will help... 2865465 (post) and 2861861 (post)

Other members may advise of other methods.

hhmmmm.....i didn't know about the .forced suffix. I will try that i think it will work!
many thanks!!!
Image
Reply
#4
Ok! This is not working and i'm stumped .

My settings are correct on the media

Image

And my files are (tried all combinations).

Code:
video name.mp4
video name.en.srt
video name.gr.forced.srt
video name.el.forced.srt

But every single time the English own is played by default. I tried the option "make default" in subtitles after i select the Greek one but nothing is happening on the next video.
I am now in Kodi 18.3 in MacOS 10.14.6

Any help will be greatly appreciated.

Regards,
Vassilis
Image
Reply
#5
In the name of me i cannot make this work!
 
Tried this as well

Code:
Video Name.avi
Video Name.el.default.srt
Video Name.el.srt
Video Name.en.srt
Video Name.gr.default.srt

Always the English displayed as first

Please anyone.... Sad
Image
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
How to have .srt language specific selected by default ?00