Linux Issue with display off after 10 min
#1
Hi!

I have my kodi running on Ubuntu 16.04 with open box but since some months the screen goes black after some minutes of inactivity. I tried to turn off dpms but for some reason it doesn't work.
Here my xset q output:

Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
XKB indicators:
00: Caps Lock: off 01: Num Lock: off 02: Scroll Lock: off
03: Compose: off 04: Kana: off 05: Sleep: off
06: Suspend: off 07: Mute: off 08: Misc: off
09: Mail: off 10: Charging: off 11: Shift Lock: off
12: Group 2: off 13: Mouse Keys: off
auto repeat delay: 660 repeat rate: 25
auto repeating keys: 00ffffffdffffbbf
fadfffefffedffff
9fffffffffffffff
fff7ffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 0
Colors:
default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
Font Path:
/usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
Standby: 0 Suspend: 0 Off: 0
DPMS is Enabled
Monitor is On


I use the autostart file of openbox to set the dpms with different options but none of them worked :

echo "Prevent display from going to sleep" >> /tmp/xxxxxx
gsettings set org.gnome.desktop.session idle-delay 0 >> /tmp/xxxxxx
# Prevent session from locking if the display does go to sleep
gsettings set org.gnome.desktop.screensaver lock-enabled false >> /tmp/xxxxxx
echo "Disable screen saver" >> /tmp/xxxxxx
xset s off >> /tmp/xxxxxx
echo "Disable screen blanking" >> /tmp/xxxxxx
xset s noblank >> /tmp/xxxxxx
echo "xset 0 0" >> /tmp/xxxxxx
xset s 0 0 >> /tmp/xxxxxx
# Disable "Display Power Management Signaling"
xset -dpms >> /tmp/xxxxxx
xset dpms 0 0 0 >> /tmp/xxxxxx
xset s 0 s blank
xset q >> /tmp/xxxxxx

Any other ideas?
Reply
#2
See: 231955 (thread) <- if this does not work. No idea.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2019-12-27, 18:12)fritsch Wrote: See: 231955 (thread) <- if this does not work. No idea.

Which step do you mean that should fix my issue?
Reply
#4
Take a look at the openbox startup script. There is one xset command that worked of the 500000+ guys that used the howto.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
(2019-12-28, 13:38)fritsch Wrote: Take a look at the openbox startup script. There is one xset command that worked of the 500000+ guys that used the howto.

I changed it to the following but still have the issue (also upgraded to ubuntu 18.04) when I playback a movie and pause it using Plex for Kodi:

#
# These things are run when an Openbox X Session is started.
# You may place a similar script in $HOME/.config/openbox/autostart
# to run user-specific things.
#
OUTPUT=`xrandr -display :0 -q | sed '/ connected/!d;s/ .*//;q'`
xrandr -display :0 --output $OUTPUT --set "Broadcast RGB" "Full"
xsetroot #000000
xset s off -dpms
xset q >  /tmp/xxxxxx

# If you want to use GNOME config tools...
#
#if test -x /usr/lib/x86_64-linux-gnu/gnome-settings-daemon >/dev/null; then
#  /usr/lib/x86_64-linux-gnu/gnome-settings-daemon &
#elif which gnome-settings-daemon >/dev/null 2>&1; then
#  gnome-settings-daemon &
#fi

# If you want to use XFCE config tools...
#
#xfce-mcs-manager &
hsetroot -solid black
Reply
#6
(2019-12-30, 23:49)arnold.maderthaner Wrote:
(2019-12-28, 13:38)fritsch Wrote: Take a look at the openbox startup script. There is one xset command that worked of the 500000+ guys that used the howto.

I changed it to the following but still have the issue (also upgraded to ubuntu 18.04) when I playback a movie and pause it using Plex for Kodi:

#
# These things are run when an Openbox X Session is started.
# You may place a similar script in $HOME/.config/openbox/autostart
# to run user-specific things.
#
OUTPUT=`xrandr -display :0 -q | sed '/ connected/!d;s/ .*//;q'`
xrandr -display :0 --output $OUTPUT --set "Broadcast RGB" "Full"
xsetroot #000000
xset s off -dpms
xset q >  /tmp/xxxxxx

# If you want to use GNOME config tools...
#
#if test -x /usr/lib/x86_64-linux-gnu/gnome-settings-daemon >/dev/null; then
#  /usr/lib/x86_64-linux-gnu/gnome-settings-daemon &
#elif which gnome-settings-daemon >/dev/null 2>&1; then
#  gnome-settings-daemon &
#fi

# If you want to use XFCE config tools...
#
#xfce-mcs-manager &
hsetroot -solid black 

also happens if I'm outside of the plex add-on and only have kodi running. Pressing a key on the keyboard reactivates kodi and I can continue using it (but normally I don't have a keyboard connected).
any other ideas how I can get this sorted out ?
here the current output of xset q:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Disabled
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Issue with display off after 10 min00