Release script.skinvariables - Construct multiple skin variables from a template.
#31
Just as an update for anyone that wants to use this in Matrix, I've updated the repository so that there is a separate Matrix branch. You'll need to install the repository.jurialmunkey-1.4-matrix.zip package from the repository source.

Anyone with the repository installed in Leia should be able to continue as usual.
Reply
#32
@jurialmunkey

I am receiving an error with skin variables. I've attached my logfile hoping you may be able to tell me what's going on with it.

Logfile: https://paste.kodi.tv/epekagiwag.kodi

Thanks in advance.

Shedrock
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#33
(2020-07-10, 19:36)shedrock Wrote: @jurialmunkey

I am receiving an error with skin variables. I've attached my logfile hoping you may be able to tell me what's going on with it.

Logfile: https://paste.kodi.tv/epekagiwag.kodi

Thanks in advance.

Shedrock

Indicates a missing or incorrectly configured skinvariables file when attempting to run the variable constructor.

Is this stock Amber or your own version? Because I can't see anything in stock Amber which would run the variable constructor. It only uses the view builder as far as I can tell and that's a separate module that doesn't run this code.
Reply
#34
(2020-07-11, 05:29)jurialmunkey Wrote:
(2020-07-10, 19:36)shedrock Wrote: @jurialmunkey

I am receiving an error with skin variables. I've attached my logfile hoping you may be able to tell me what's going on with it.

Logfile: https://paste.kodi.tv/epekagiwag.kodi

Thanks in advance.

Shedrock

Indicates a missing or incorrectly configured skinvariables file when attempting to run the variable constructor.

Is this stock Amber or your own version? Because I can't see anything in stock Amber which would run the variable constructor. It only uses the view builder as far as I can tell and that's a separate module that doesn't run this code.
This is stock Amber from @bsoriano. I think this happened probably after I created a new user profile, switched to the new profile using Aeon Nox SiLVO, and that's when I noticed the error. I also deleted the other profiles to see if it would resolves the issue, but it didn't. I could be wrong, but I am 100% certain I never got that error before creating another profile. I am going to check it tomorrow morning on my other LE setup and report back.

I did a fresh installation of LibreELEC 9.2.3, as well as on Windows. I still get this error whenever I go to programs and hit the "Run" button. I know it does work though because the Amber feature "New media views selector" definitely works. The problem is that, if I create a new user profile and then switch users, that's the first error message that pops up "Skin Variables Error - Check the log for more information".

Regards,

Shedrock
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#35
(2020-07-11, 05:45)shedrock Wrote:
(2020-07-11, 05:29)jurialmunkey Wrote:
(2020-07-10, 19:36)shedrock Wrote: @jurialmunkey

I am receiving an error with skin variables. I've attached my logfile hoping you may be able to tell me what's going on with it.

Logfile: https://paste.kodi.tv/epekagiwag.kodi

Thanks in advance.

Shedrock

Indicates a missing or incorrectly configured skinvariables file when attempting to run the variable constructor.

Is this stock Amber or your own version? Because I can't see anything in stock Amber which would run the variable constructor. It only uses the view builder as far as I can tell and that's a separate module that doesn't run this code.
This is stock Amber from @bsoriano. I think this happened probably after I created a new user profile, switched to the new profile using Aeon Nox SiLVO, and that's when I noticed the error. I also deleted the other profiles to see if it would resolves the issue, but it didn't. I could be wrong, but I am 100% certain I never got that error before creating another profile. I am going to check it tomorrow morning on my other LE setup and report back.

I did a fresh installation of LibreELEC 9.2.3, as well as on Windows. I still get this error whenever I go to programs and hit the "Run" button. I know it does work though because the Amber feature "New media views selector" definitely works. The problem is that, if I create a new user profile and then switch users, that's the first error message that pops up "Skin Variables Error - Check the log for more information".

Regards,

Shedrock
Running from programs is going to error because that's essentially the same as running the variable constructor and there's no variable to make.

Interesting about profiles. Profiles always seem to cause problems so I never use them - I'll have a look and see if I can recreate because I think I might have an inkling of why it would happen for a profile.
Reply
#36
Quote:Running from programs is going to error because that's essentially the same as running the variable constructor and there's no variable to make.

I realized that afterwards. Big Grin
Quote:Interesting about profiles. Profiles always seem to cause problems so I never use them - I'll have a look and see if I can recreate because I think I might have an inkling of why it would happen for a profile.

Thank you @jurialmunkey. Much appreciated.

Regards,

Shedrock
Reply



Logout Mark Read Team Forum Stats Members Help
script.skinvariables - Construct multiple skin variables from a template.0
This forum uses Lukasz Tkacz MyBB addons.