Android Movie / TV Show scrapping - "Cannot connect to remote server"
#1
Hi guys,

For two months, I am getting an error when I am trying to update my movie/tv show library. I have tried already re-installing kodi and resetting all settings/library. I have updated all Add-Ons with no effect. There are also no special characters in my movies as it looked like this was an issue in another thread. Internet seems to work for kodi as I was able to update Add-Ons and also to upload the log.

In case it is relevant, I have installed kodi on a Fire 4k TV stick (latest firmware installed, stick is rooted). Here is the log:

https://paste.kodi.tv/hiqozikuqa

Does anyone has an idea what is going wrong and what else to try?
Reply
#2
@Aldaris

The log does not have Debug Mode enabled in Settings>System>Logging.

Also you grabbed the log before Kodi finished writing to it, so I barely have anything in there. Make sure you Exit Kodi before grabbing the log. Either that or you edited the log, which makes it useless.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
@Karellen: Thanks for your feedback! I have enabled debugging and closed kodi once. Hope this log here is more helpful now:

Reply
#4
Almost there. You did not replicate the problem, so there was nothing for me to see. Either that or you sent me the wrong log.

Read the difference between kodi.log and kodi.old.log ... https://kodi.wiki/view/Log_file#kodi.log...di.old.log
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
@Karellen : Thank you for the explanations.

So here is the "current" log (error shown in line 859):

https://paste.kodi.tv/owupulifor

And here the "old" log:
https://paste.kodi.tv/ozokaxopuz
Reply
#6
Thanks @Aldaris that is what I need.

Hmm, I can see the errors, but not what is causing them. Yep, you are going to hate me, but can I get another set of logs the same as above.

This time also enable libcURL in component logging... https://kodi.wiki/view/Log_file/Easy#Ena...ic_logging

What country are you in? Are you using a VPN? Can you access the internet from your Android box- try installing any addon.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#7
@Karellen : Here is the updated log file with the libcURL debug activated:

https://paste.kodi.tv/hixocapuja

I live in China and do not use a VPN. Installing an Add-On through kodi works, the Add-Ons are also updated.
Reply
#8
Thanks @Aldaris

I do recall someone recently also having problems with TMDB from China. Strange that the IP address the scraper is trying to connect to belongs to Facebook. I need to delve into this a bit more with a developer or TMDB themselves.

Could you please change scraper to this one... https://kodi.wiki/view/Add-on:The_Movie_Database_Python and see if it solves the issue. If not, a Debug Log with libcURL will help also.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#9
@Karellen: Thank you! I have installed the Python-Version. With this one, the searching does not lead to any result. It looks like the Add-On is stuck with the first entry and nothing happens, not even an error. On the top I can see that even after a couple of minutes, it is still the first movie entry that is analyzed. Here is the log:

https://paste.kodi.tv/efezabocif
Reply



Logout Mark Read Team Forum Stats Members Help
Movie / TV Show scrapping - "Cannot connect to remote server"0
This forum uses Lukasz Tkacz MyBB addons.