•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 19
  •   
[Win][v19+] Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
#16
@belmore 
Hi
it is ou'r first 3d install ?
sorry for my english, here are some tips


intel driver :
resolution 1920x1080  / 16:9
standard color correction : off
noise reduction on 
film mode off
skin tone off
color correction off
etc... (all off or a minima)

open windows display settings , search and activate 3d 

In windows setup : activate 3d  (inside monitor setup) => verify 3d is running.

launch  kodi
setup : mode expert
player / video -> adjust display refresh rate  : on start / stop  // sync playbak : no
player / video  -> mode 3d  : preferred mode   // disable 3d at the end  // enable 3d mvc  //  3d suport level
 : 20 (you must test it, see previus tread)

setup / system / display mode : full screen    // 1920x1080p    // use full screen windows : on  // blank others display : off
whilte list : 1920x180p (all supported)    // strereoscopic mode / current : disable (if it is)   //  preferred mode => MATERIAL 
(or hardware)  if material does not appear, the configuration is not good.

setup audio => wasabi 7.1 // pathtrought etc...

good luck
Windows 10 + MariaDB base + Matrix | Kodi Build for intel Kodi-Native 3D MVC Playback (as possible)
Skin Titan Mod | Link: Color themes for Titan Mod | Link: Littles mods
For Intel Nuc : Kit Mpc-HC/BE : Config External player with 3D and Pathrought
Reply
#17
hi
see this post :
https://forum.kodi.tv/showthread.php?tid...pid2308882
Windows 10 + MariaDB base + Matrix | Kodi Build for intel Kodi-Native 3D MVC Playback (as possible)
Skin Titan Mod | Link: Color themes for Titan Mod | Link: Littles mods
For Intel Nuc : Kit Mpc-HC/BE : Config External player with 3D and Pathrought
Reply
#18
Flashed latest BIOS. Increased 3D Support Level to 20 (verified as the correct value using Intel's Media SDK analyzer) and re-checked graphics configuration settings. Results are pretty much the same. Playing back a 3D MKV causes my projector to switch to 1080p 24 FP as it should. But the 3D image is not correct. The left eye is almost completely dark with only a very faint image of the video. Again, Kodi's video controls are shown both in the middle and the bottom, but the video itself not displayed as top/bottom. It displayed as full frame. Switching the 3D mode to side by side incorrectly displays the top half of the video on the left and the bottom half of the video on the right. Very weird.

I don't not see "Material" as option in Preferred Mode. I do see "Same as movie" (which is what I have it set to). Is this just a language difference? If not, I'm sure what configuration option is not set properly. Thanks again for trying to help!
Reply
#19
Quote:Settings/System/Use a fullscreen window rather than true fullscreen = Unchecked

I missed doing this, but when I disable this option, my projector no longer switches to FP when I start playback and I only see a black image (with sound).
Reply
#20
I just noticed that MPC-HC + madVR is exhibiting similar issues (left eye black/image not in 3D, but not the problem of the video controls being duplicated). I'm pretty sure at one point, madVR was displaying 3D. It just had a horrible frame rate because it was not h/w accelerated. Along the way, I updated Windows 10 to the latest version. Now, I'm starting to wonder if that wasn't a big mistake and that I'll have to scrape everything and start over with an older Windows 10 build Sad
Reply
#21
(2021-11-17, 16:54)belmore Wrote: . The left eye is almost completely dark with only a very faint image of the video.

This is probably the known issue also written in the release notes... Possible workaround is to force top/bottom 3D and enable top/bottom manually in the display. This will decrease the quality to by half, but some dont even notice it as the display rescale it back to full with slight blurring. I have been working on a fix for at least a month, currently without progress.
Reply
#22
Quote:This is probably the known issue also written in the release notes... Possible workaround is to force top/bottom 3D and enable top/bottom manually in the display. This will decrease the quality to by half, but some dont even notice it as the display rescale it back to full with slight blurring. I have been working on a fix for at least a month, currently without progress.

I started from scratch and re-installed Windows 10 1903. madVR is again able to playback in 3D, but without h/w acceleration, it's unusable. Bizarrely, now switching the 3D display mode in the driver settings does NOT switch my projector into FP mode as it did with Windows 10 20H1 (not sure anymore of build??). And as a result, I can't get Kodi to trigger this mode either. I'm not sure how madVR is able to do it.

No wonder the Kodi developer's are struggling to get this to work. Windows support of 3D is apparently dogsh*t! Thank for your efforts!
Reply
#23
Tried downgrading Windows 10 (again) to 1803, but the results were (from what I could tell) identical to 1903. Enabling the 3D mode from the Display Settings did not cause my projector to go into FP mode.
Reply
#24
@belmore 
May be intel driver version ?
Here is mine :

Image

Image
Windows 10 + MariaDB base + Matrix | Kodi Build for intel Kodi-Native 3D MVC Playback (as possible)
Skin Titan Mod | Link: Color themes for Titan Mod | Link: Littles mods
For Intel Nuc : Kit Mpc-HC/BE : Config External player with 3D and Pathrought
Reply
#25
I finally found a combination which works with my Intel P630 graphics.

- Windows 1803
- Intel driver 27.20.100.9466
- Self baked Kodi with Damagedsplines patch "Control 3D display flag on demand" reverted (sources here: https://github.com/boeschy/xbmc)
- Windows display settings 3D switched on

With this combination I get HW accelerated MVC output and 3D is perfectly switched on an off automatically when starting or stopping a movie. I'm totally happy now.
Reply
#26
Hi
Here is one tips.
I help a friend today and i have same problem in my installation.
Av receiver switch between tv ( not 3d) and beamer ( 3d)
Nuc ( windows) -> av receiver (pioneer) -> tv (samsung) OR beamer epson)
If tv is not ac deconnected, windows doesn't detect 3d from the beamer.
Windows 10 + MariaDB base + Matrix | Kodi Build for intel Kodi-Native 3D MVC Playback (as possible)
Skin Titan Mod | Link: Color themes for Titan Mod | Link: Littles mods
For Intel Nuc : Kit Mpc-HC/BE : Config External player with 3D and Pathrought
Reply
#27
(2021-11-20, 00:02)udobroemme Wrote: I finally found a combination which works with my Intel P630 graphics.

- Windows 1803
- Intel driver 27.20.100.9466
- Self baked Kodi with Damagedsplines patch "Control 3D display flag on demand" reverted (sources here: https://github.com/boeschy/xbmc)
- Windows display settings 3D switched on

With this combination I get HW accelerated MVC output and 3D is perfectly switched on an off automatically when starting or stopping a movie. I'm totally happy now.

I will add a new flag to control whether to auto switch display to 3D (current state) or not (like in the v18 days)... I thought whether to add such flag as my dev host is also serving as the HT playback system so once disabled I could at least watch 3D in half res until I find the full res drawing issue.

(This will allow you to disable auto 3d so you can enable it manually via windows display settings just like you did)
Reply
#28
Updated first post with v19.3 - build 2, which contains the new flag to match the scenario described by @udobroemme 

I think I finally have a lead on the full frame rendering issue which plagues some folks. During test of this new build I started kodi on my HT system via remote desktop (and did not close it) and then when I started my projector and logged in locally while kodi was still running the darn 3D full frame rendered fine... can anyone else with the full frame 3D rendering issue verify this?

Reproduce flow:
1) close kodi on the host where it is installed
2) login via remote desktop to the host which has kodi installed and run kodi remotely
3) close remote desktop while kodi is running
4) login locally to the host with the installed  kodi - where it is still running form the remote session
5) play 3d with full frame

if this checks out - kodi is broken at load time and that is where i need to search for the issue.
Reply
#29
It works (almost).

I had to remove
<requirement>HAS_MVC</requirement>
from the settings.xml due to a hen-and-egg problem. Otherwise the new setting isn't available because Kodi deactivates the Windows 3D setting on startup.
Reply
#30
@udobroemme Yeah, this issue only occurs during the current run in which you modified the value. I should have added that modifying it requires restart to take full effect...
i will change that as you said
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 19
  •   



Logout Mark Read Team Forum Stats Members Help
[Win][v19+] Intel HTPCs/NUCs & Kodi-native 3D MVC Playback0
This forum uses Lukasz Tkacz MyBB addons.