Apple TV 4k (1st Gen) Remote Issue only in Kodi
#1
So I have the Apple TV 4K (First gen) that I recently had to reinstall Kodi (I'm an amateur) because of the tvOS update. 
Before this the Siri remote worked fine.  Now after the install the Siri remote is almost unusable because it is so sensitive. I have to use an older aluminum app to navigate.  And this is only in Kodi.
I tried changing settings in the tvOS and in the Kodi app itself and am not having any changes

I am the only one that has come across this?

Probably
TYIA
Reply
#2
Which Kodi version did you install on your Apple TV?
Trying to keep Kodi working on tvOS on free time — Former developer of Catch-up TV & More video add-on (GitHub repoWebsite)
Reply
#3
This is happening to me with kodi 20 nightlies.
I started having this issue of the sensitivity of the siri remote control on my ATV4k 1st gen with the kodi-20211026-1c287f93-master-tvos but I managed adjusting the settings to 500 for the horizontal sensitivity and 700 for the vertical.
Recently I updated to a more recent version on February 2022 and those settings are not working anymore. The horizontal sensitivity is too high even if I put it at the minimum number.
The only way I can move around it is if I use the tv remote control.
I hope it can be fixed.
Reply
#4
I have the same Problem!
Reply
#5
Only way all Nexus versions to work is by disabling controller support in system settings/ input.
Reply
#6
@sy6sy2 

remote navigation issue still persists with Kodi 20 RC1 + RC2 unfortunately, very frustrating, hopefully it will get fixed eventually

Seems an issue that effects new Apple TV 4K remote, if you disable touch setting in remote settings it will work with just click enabled, hopefully this bug gets resolved eventually so both click and touch both work with the navigation

Thanks
Reply
#7
Hi, sorry for the delay.
I just tested the latest commit of Nexus branch and I cannot reproduce the issue.
I compiled it from Xcode and run it from Xcode.

Can you tell me which Kodi deb file or commit you use? Also, what's your install method? Is your device jailbroken?

I only tested with the 2th gen siri remote version. But if needed I can test with the 1st gen (the black one with no D-pad).

Thanks
Trying to keep Kodi working on tvOS on free time — Former developer of Catch-up TV & More video add-on (GitHub repoWebsite)
Reply
#8
I dont face this issue anymore with the 20 RC2, by disabling the ENABLE CONTROLLER SUPPORT in the Input settings.
Reply
#9
Thank you sasagr for the confirmation, I was finally able to reproduce the issue with a deb file generated by Jenkins with all binary add-ons.
The bug is a conflict between the original (an legacy) Siri remote handler and the Game controller handler, both detect the Siri remote input and handle the button action so you obtain "double" actions...

The bug needs to be fixed, during this time you can disable controller support like sasagr suggests or using a customed customcontroller.SiriRemote.xml file with noop for duplicates actions.
Trying to keep Kodi working on tvOS on free time — Former developer of Catch-up TV & More video add-on (GitHub repoWebsite)
Reply
#10
Thanks for your support.
Possibly kindly let us know in this thread when the bug has been fixed so I can follow it up on the "fixed" release.

Thanks again
Reply
#11
I created an account just to say that this bug has not been fixed. Even with the release of Nexus to the public.
Reply
#12
(2023-02-20, 01:38)zoeegrace Wrote: I created an account just to say that this bug has not been fixed. Even with the release of Nexus to the public.

see workaround here: https://forum.kodi.tv/showthread.php?tid...pid3138415
Reply
#13
I downloaded Kodi from here: https://kodi.tv/download/tvos

But I don't see "ENABLE CONTROLLER SUPPORT in the Input settings" on my Apple TV 4 HD on tvOS 14.7 jailbroken with unc0ver. I went to Kodi -> Settings -> System -> Input

Am I in the wrong section?
Reply

Logout Mark Read Team Forum Stats Members Help
Apple TV 4k (1st Gen) Remote Issue only in Kodi0
This forum uses Lukasz Tkacz MyBB addons.