Thread Rating:
  • 0 Vote(s) - 0 Average
[APPLE TV] Adding source to library (bug?)?
#1
Question 
It seems like if you add more than one source to your library at once, it will corrupt the library and rename movies whatever the first source was.

So If you add an action folder, adventure folder, comedy folder... Youll have movies named "action" and so on. It also causes duplicates. I think i found a way around it (ill have to check when i get home). It looks like if you add them individually, they work fine.
Reply
#2
Doesn't sound like a bug. It sounds as if you setup the scanner incorrectly (any "bug" may be in a non-intuitive way you have to setup the scanner).

1. How are your files layed out?
2. How did you setup the scanner?

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#3
basically it is a terabyte NAS drive with a file structure basically like:


adventure
-movie.avi
comedy
-movie.avi


sooooometimes there will be a split movie which will be in its own folder, ie:

adventure
-movie folder
--movie1.avi
--movie2.avi
Reply
#4
So there is no toplevel folder you set content on?
Jonathan also asked for your set content options
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#5
no, the root of the drive is the genres, its dedicated.

the content settings are set accordingly depending on movie or tvshow.. unless i misunderstood your question.
Reply
#6
so i came home from work to find that while it was parsing my drama folder, it renamed all my movies in the drama category to "confessions of a teenage drama queen" ... greeeeeeat...
Reply
#7
I'm filling in blanks, as you are still leaving us guessing, but your layout appears to be as follows:

Code:
Movies/
  Action/
    Lethal Weapon/
       some_file_name.avi
    Die Hard/
       some_file_name.avi
  Drama
    Atonement/
       some_file_name.avi

I'm assuming that you don't have any video files in the "Drama" folder that are NOT in their own subfolder?

In this case, Set Content on the Movies folder. Set "Use foldernames to lookups to true", make sure "This folder contains a single movie" is not set, and make sure "Scan recursively" is enabled.

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#8
I'm filling in blanks, as you are still leaving us guessing, but your layout appears to be as follows:

Code:
Movies/
  Action/
    Lethal Weapon/
       some_file_name.avi
    Die Hard/
       some_file_name.avi
  Drama/
    Atonement/
       some_file_name.avi

I'm assuming that you don't have any video files in the "Drama" folder that are NOT in their own subfolder?

In this case, Set Content on the Movies folder. Set "Use foldernames to lookups to true", make sure "This folder contains a single movie" is not set, and make sure "Scan recursively" is enabled.

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#9
some movies are in subfolders, it depends on if its a split file. could i just avoid this and take my database from my devkit xbmc and ssh it to my apple tv?
Reply
#10
hey guys im new to this i recently downloaded xbmc on both pc and xbox. on xbox i cant get my movie info when i refresh i get a bunch of letters and numbers in the movie title and i cant delete or back space my pc works great also my ninja video plugin keeps shutting down after 4 min of playing is there a update i need please help me out
Reply
#11
Assuming the paths are the same, yes that should work.

Mixed folders/files are only somewhat working to be honest - it is very unlikely to be a successful combination. I strongly suggest you stick to one or the other.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply



[APPLE TV] Adding source to library (bug?)?00