So you think you have a MCE remote?
#1
Are you sure? Huh Because in my case its not an official Microsoft remote, but a Philips... And using Eventghost there is no single button press that gets logged no matter which plugin I try...

Strange thing is that in VMC the remote works flawlessly, and in XBMC some of the functionality is also there (mainly the directional buttons and the ok button) but the rest of the buttons have no effect at all...

So who can tell me how to get this Philips MCE remote workingHuh? Its driving me crazy!

This is the remote: RC1534522/00
Alternate Remote Control for Windows Vista

(its the fourth one (the black one) on this page:
http://www.remotecontrol.philips.com/index.cfm?id=1336

Any light in the darkness is greatly appreciated!

Regards,
Maassie
Reply
#2
Launch EventGhost and point ANY remote control at your IR receiver - if you still don't see anything on screen, then it's not the remote. It could be the plugin for the IR receiver (try one called something like Generic HID device).
Reply
#3
Thanks for you reply, indeed no remote gives any 'reaction'... I tried the Generic HID device as well... but no results...Huh
Reply
#4
Ok, on the plus side, it doesn't seem to be your remote that's playing up, but it's something within the EventGhost configuration.

I've only been using EG for a couple of days so I'm far from an expert! Maybe post in this thread:

http://forum.xbmc.org/showthread.php?tid=38579

It might depend on whether your receiver is USB or built-in...though my built-in receiver works fine when selecting the MCE plug-in. Or perhaps, if it's USB, Windows hasn't recognised the device at all - I'd unplug and re-plug it in to see if Windows reacts, then check under device manager to see if it's installed properly...
Reply
#5
Just an "FYI", the Philips remote is an official Microsoft remote. All the Microsoft remotes are OEM'd by companies like Philips.
Reply
#6
You might be one of the lucky guys who own a MCE v1 remote -> http://www.byremote.com.au/Hip/mce_remot...you%20need
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#7
WiSo Wrote:You might be one of the lucky guys who own a MCE v1 remote -> http://www.byremote.com.au/Hip/mce_remot...you%20need

I dont think so, its this one:
http://www.remotecontrol.philips.com/index.cfm?id=1336 ... (the fourth one)
Reply
#8
My remote which is a Pinnacle VMC remote did exactly the same thing. There are some new instructions for setting up EG in this thread: http://forum.xbmc.org/showthread.php?tid=38585 (scroll to the end).

You can also try some of the other solutions suggested in the first post of the same thread. Most any of them should work for you.

I *believe* the majority of users here are using either EG or IRSS but I could be wrong about that...it's not like I've taken a poll or anything. LOL
The XBMC team, plug-in devs, skinners, etc. do this for us for FREE in their spare time because they want to. Think about that for a second before you start bitching...
Reply
#9
Dear Maassie,

I use the first Philips on the website and it works fine with IRSuite, there is a manual around the forum for it.

Good luck,

Marco
XBMC Equipment:
Nvidia Ion + Atom 330, HDMI out
Panasonic TH-42PX80FV
Windows Server 2008 R2
Reply
#10
Thanks for all the help and suggestions!

Last night I tried to use the HID plugin with Eventghost and I noticed that there where four 'Philips MCE USB IR Reciever - Spinel plus ' available... So I tried one and that made one or two buttons work! So I decided to add them all and yes! All buttons were logged (accept for the Ok and directional ones, but they were already working since the start)!

So together with the XBMC plugin I was able to map most of the buttons and now everything works fine!

Well... almost that is! Confused I notices that some of the buttons (the red/freen/yellow/blue ones and the menu and record button do not log a single button press like: HID.07 but generate a multi numbered code, like: HID.125.4.23 or something, and repeating this twice or three times!

(I have to say that I use a Harmony remote that I learned the MCE remote)

I mapped the record button to an Execute XBMC event and that resulted in XBMC loading twice or even more times... Funnt thing is that the MCE remote logs something like HID.05 when I press record, and the harmony logs HID.125.4.23 or something, while the harmony remote has learned the MCR remote codes!!

Strange isn't it?
Reply
#11
Glad it's all working.

Seems you have to go back to your Harmony config - either re-learn the commands or, preferably, just use the Media Center entry from Logitech's database.

I use a Harmony 525 (configured using only Logitech's defaults for MCE) and those buttons worked just as well as any others.
Reply
#12
Thanks again Calvinf for your quick response! I did just that: use the Media Center entry from Logitech's database! Thats whats so strange! Did you change your MCE drivers? Maybe I should try learning the Harmony the commands straight from the MCE Remote... I will check...! I will get there!!! ;-)
Reply



Logout Mark Read Team Forum Stats Members Help
So you think you have a MCE remote?0
This forum uses Lukasz Tkacz MyBB addons.