Thread Rating:
  • 0 Vote(s) - 0 Average
[RELEASE] G4TV (Video) Plugin
#1
Thumbs Up 
Image

Image

Image


Downloads & Updates are available via XBMC Addons Manager

Post any questions or comments here. Wink
Reply
#2
Thanks for all your work.
Reply
#3
Nice one thanks. I usually use Navi X for my G4 fix, but this is way better.Big Grin
Reply
#4
Excellent job! Everything works great man Smile. Can a download option be added?
Reply
#5
XBMCG33K Wrote:Excellent job! Everything works great man Smile. Can a download option be added?

There is a download option Big Grin, it's in the plugin settings menu.
Reply
#6
Damn didn't look sorry, bout' that.
Reply
#7
Very nice content!
Thanks a lot!
Image
_____________________________

Repositories Installer: select and install unofficial repositories / TAC.TV: watch videos on TAC.TV
Installer Passion-XBMC: Download and Install Add-ons (pre-Dharma only)

Image
Reply
#8
The podcasts are no longer working. I'm on an xbox using the jan 25, 2009 build and this was working a few days ago. The TV Shows section appears to be intact.

I'm getting the error:
sys:1: DeprecationWarning: Non-ASCII character '\xe2' in file Q:\plugins\video\G4TV\default.py on line 150, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details

here's the full xbmc.log file: http://pastebin.ca/1332355
Reply
#9
nicoli_k Wrote:The podcasts are no longer working. I'm on an xbox using the jan 25, 2009 build and this was working a few days ago. The TV Shows section appears to be intact.

I'm getting the error:
sys:1: DeprecationWarning: Non-ASCII character '\xe2' in file Q:\plugins\video\G4TV\default.py on line 150, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details

here's the full xbmc.log file: http://pastebin.ca/1332355

Thanks for notifying me.

[Update]
-fixed: the G4 Podcast directory wasn't listing videos
Reply
#10
I found that the newest xbox build from march 3rd is having issues playing Around the Net without resorting to buffering a lot. I'm able to watch an entire episode using the January 25 build with no buffering.
Here's the march 3 build's debug: http://pastebin.ca/1353278
Here's the jan 25 build's debug: http://pastebin.ca/1353279

I exited both of them prematurely at around the same time in the podcast. I tried several times using the march build just to make sure that it wasn't a random occurrence and it was replicated every time.

I'm not sure if it's a problem with the xbmc build, the plugin, or how they're interacting with each other but I wanted to give you a heads up that there's something going on with it. I haven't run into any other errors with the most recent t3ch build though, so hopefully it's an easy fix.
Reply
#11
I've been using this plugin for some time now but never noticed the thread. So , just a quick thank you for making this, I use it all the time Smile
Reply
#12
Jeroen Wrote:I've been using this plugin for some time now but never noticed the thread. So , just a quick thank you for making this, I use it all the time Smile

Thanks Wink
Reply
#13
I'm having the exact same constant bufferring symptoms previously mentioned here:

nicoli_k Wrote:I found that the newest xbox build from march 3rd is having issues playing Around the Net without resorting to buffering a lot. I'm able to watch an entire episode using the January 25 build with no buffering.
Here's the march 3 build's debug: http://pastebin.ca/1353278
Here's the jan 25 build's debug: http://pastebin.ca/1353279

I exited both of them prematurely at around the same time in the podcast. I tried several times using the march build just to make sure that it wasn't a random occurrence and it was replicated every time.

I'm not sure if it's a problem with the xbmc build, the plugin, or how they're interacting with each other but I wanted to give you a heads up that there's something going on with it. I haven't run into any other errors with the most recent t3ch build though, so hopefully it's an easy fix.

If it makes a difference, my Xbox is softmodded with the T3ch 03-04-09 SVN release of XBMC.
Also, as a side-note/request, any hope of adding the Ninja Warriors streams to this plugin?
Wii's and PS3's get a decent page by and maintained by G4TV:
Wii: http://g4tv.com/wii/index.html
PS3: http://g4tv.com/ps3/index.html
(Sorry if this looks like too much scope creep!)
-JB
Reply
#14
Since the plug-in works flawlessly with the january 25 build, I think that the problem is with the 3-04-09 T3CH build. In the channelsurfing.net thread Waffa pointed me towards a thread showing the problems with the build including memory issues.

Waffa Wrote:Script is probaly not broken, march 4 t3ch has problems. And also the february build got that problem.
See this tread.http://forum.xbmc.org/showthread.php?tid=46490

I always maintain the last working t3ch along with the newest t3ch build. I'm currently using the 1-25 build as my main build and I have the 3-4 build as my second build to run the programs requiring the special:// format.

thanks again stacked. I use this on at least an every-other-day basis.
Reply
#15
jbagnulo Wrote:Also, as a side-note/request, any hope of adding the Ninja Warriors streams to this plugin?

There is a Ninja Warriors video podcast under "G4 Podcasts"
Reply



[RELEASE] G4TV (Video) Plugin00