[LIVE] Questions aon xorg.conf / XF86Config
#1
Hi All,

I've seen some people mention problems with specific resolutions in 9.11 beta. I have experimented several hours now with this and just need to ask some questions. I have looked around and found some tips, but nothing that solves this.

I'm now running Live 9.11 beta 2 installed on a Usb memory. I'm running on an Nvidia ION platform.

I've read all the guides regarding the resolution settings using xorg.conf and do need to state some things, and ask some questions.
  • As several here have said. There isn't any xorg.conf in the 9.11 Beta2. In the /etc/X11/ directory there is only the XF86Config file

  • If running "sudo nvidia-xconfig" it will not make a xorg.conf file. But it does make a new version of the XF86Config file.

  • If I make changes in the file. Adding what needs to be added and then restart the computer, the XF86Config will revert back to the original content.

  • I then tried to make the changes off-line by downloading the XF86Config file to my computer, and made the changes there. But then I was not allowed to sftp that file back again, not enough permissions.

  • I tried to change the permissions with "chmod 333 XF86Config", but I was not allowed to.

  • Is there any way at all to SFTP the files back to the folder?

  • OK, and the actually important question here. What might be wrong? And how should I go about to be able to edit the XF86Config file? And is it really that file that I should be making the changes in?

Just when I was writing this I saw that the 9.11 RC1 Live version just arrived for downloading. I will install that one and see if there are any changes.

It would be very nice if someone had any answers to this. It's kind of the last thing I would like to have working in my HTPC before I can consider it the perfect solution.

/PerM...
Reply
#2
+1

I have an asrock ION 330 hooked up via HDMI to a pioneer vsx-1018 receiver, which is hooked up to a samsung LN46A530 LCD.

I am getting constant hdmi video drops, sometimes it seems stable but then will all of a sudden start dropping like crazy and coming back. I am using the RC1 with the same issue.

XBMC keeps reporting my resolution as [email protected] Full Screen - 60hz

My tv is 60hz and does 24, not sure what the 50hz is all about but if I try to change it in xbmc settings it drops the resolution down after 55hz.
Reply
#3
Sometimes sudo drives me crazy and I just want to do a number of tasks as root. Run "sudo bash" to get a root shell and you shouldn't run into these permission problems.

Remove the /etc/X11/XF86Config file. Create a /etc/X11/xorg.conf file by running "cat >/etc/X11/xorg.conf" and pasting in the contents from this wiki page. Type CTRL-D to close the file after pasting over an SSH session. Using "nvidia-xconfig" IMHO is a crappy way to setup xorg.conf. XF86Config is the old configuration filename and although it may be currently recognized, it shouldn't be used anymore.

I don't know what you were attempting to do with chmod 333, but "chmod 644 /etc/X11/xorg.conf" will make the file writable by root and readable by all. There isn't any security risk in making it readable by all.

As for sftp, unless you setup a password for your root account and sftp in as that, you're limited to whatever you're logging in as. You can transfer files into the home directory of the user account, then "sudo mv (source file) (destination)" to move them to the proper location.
Reply
#4
In a terminal type in the following to create a password for root:

Quote:sudo passwd root

Then you can log into a sftp client as root
Reply
#5
renaming xf86config and creating that xorg.conf resulted in xbmc not starting, it just booted to the login prompt. Why would the old format of xf86config be in there if it is a fresh install of RC1?
Reply
#6
I will try this tonight.

But the last question above I think is very valid.

Why is there a XF86Config there if it is the old way, and this is the latest release? Is this something just for the beta / Rc versions or is 9.11 based on some older core.

Would be nice to know.

/PerM...
Reply
#7
http://en.wikipedia.org/wiki/XF86Config

Erm I may be missing something Ill have to check on a karmic install but this XF86config seems out of use, deprecated Read away at the link.
Reply
#8
MrStarhouse Wrote:Why is there a XF86Config there if it is the old way, and this is the latest release? Is this something just for the beta / Rc versions or is 9.11 based on some older core.
.

XF86Config has nothing to do with XBMC. It used to be the configuration file for Linux X back in the long ago before time. I think nvidia-xconfig is still barfing it out instead of the proper xorg.conf.
Reply
#9
It appears that even in "9.11 Stable" an edited XF86config file will be overwritten with the defaut. Interestingly it seems to not get overwritten when running:

Code:
X -verbose 6 > ~/xlog.txt 2>&1

but does after a reboot.

Has anyone found a solution?

------------
I am using:

Xbmc Live 9.11
Acer Revo 1600
Samsung 40B554 40" 1080p TV
Reply
#10
I have the exactly same problem, firstly yesterday i decided to upgrade from beta1 to the latest svn build from the official PPA, 1:9.11+svn26540-karmic1 i think it was.

However when everything was done, VDPAU was totally borked, and after trying to fix it with different nvidia builds, i gave up.

So now today i downloaded the stable 9.11 release (xbmc-9.11-live-repack.zip) backed up my database, and formated the drive.

Everything went smooth until i was about to edit my TV's custom ModeLine's in xorg.conf

There was no xorg.conf at all.....
Tried to generate a new
Code:
nvidia-xconfig
didn't work..

googled it for abit and came up with this problem of some old config file called XF86Config.. aigt, so i opened it up
Code:
sudo nano /etc/X11/XF86Config
finally there it is, so i edited in my ModeLine's and saved the file..
Code:
sudo reboot
and tried to watch a movie, however it did not switch from default 60hz to 24 as it did with the beta1..

I've tried ALOT of things including removing XF86Config and only have a xorg.conf etc..etc nothing is working.

I don't dare to try and update nvidia again, just to see vdpau is no longer working...

Is there a solution?
Reply
#11
Has anyone figured this out yet? A friend has also an ASrock ion 330. We did the same install (current Live download). Linux version & XBMC version are the same.
He has got a 1080p panasonic plasma and I have a 1080i panasonic plasma.
He has got the xorg.conf which he can edit, I have the XF86Config wich I CAN'T edit after a boot the XF86Config is set to default. its driving me crazy !
Reply
#12
Same problem here Sad
Reply
#13
I'm going to have to bump this thread too.

Very strange things have happened to my 9.11 Live install, so I had to re-install using the same USB flash drive I always use. However, this time I have no xorg.conf. I can't thing how this happened as I always use the same USB drive to install from!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LIVE] Questions aon xorg.conf / XF86Config00
This forum uses Lukasz Tkacz MyBB addons.