New install xbmc live dharma
#1
Hi guys

I downloaded latest version dharma live and installed it from DVD all worked well, my problem is I had win 7 on this previous with four internal 1tb hdd which where easy to add as a source, how do I do this with the live version?? When I go to add source I used to see my drives eg e, f etc but in live I don't seem to be able to do this, any help would be appreciated. First time using live

Paul Smile
Reply
#2
You will need to mount them. I haven't read this in detail, but it looks like what you need to do from a brief skim read (i.e. determine which /dev/sda they are and then edit fstab to mount them). http://www.smorgasbord.net/how-to-instal...ntu-linux/

You will then need to add them via add sources to wherever you have mounted the drives.
Reply
#3
Hey
You have to change the /etc/fstab file and mount the disks.

When XBMC ist startet hold down STRG+ALT+F1 for 5 seconds to start the command promt or login from another machine using a SSH client (like putty).
Login with your username and password you set during the installation.

Than you will see something like this:

Code:
login as: xbmc
[email protected]'s password:
Linux XBMCLive 2.6.32-26-generic #48-Ubuntu SMP Wed Nov 24 09:00:03 UTC 2010 i686 GNU/Linux
Ubuntu 10.04.1 LTS - XBMCLive Dharma

Welcome to Ubuntu!

now type:

Code:
sudo fdisk -l

you have to reenter your password again.

this shows you your hdds.

now edit the fstab to automount the harddrives you want.

Code:
sudo nano /etc/fstab

there add the drives you want with the choosen mountpoints.
For example:

Code:
/dev/sdb2       /media/data2    ntfs    default 0       0

Close the editor with STRG+X and override the file.

Now type

Code:
sudo mount -a

to mount them.

P.S. Don't forget to creat the directory where you want to mount the disk before you try to mount them.
Reply
#4
Thanks for prompt reply,I will try this but I'm new to live hopefully it will work Smile
Reply
#5
Hi Steve

Afraid I'm totally lost first time with Linux I get as far Sudo fdisk -1
After that all I get Is fsdisk -1 invalid option. Coming from windows where it's very easy to mount the drives I find this very hard hope you can shed some light for a numpty

Paul
Reply
#6
Paulkai Wrote:Hi Steve

Afraid I'm totally lost first time with Linux I get as far Sudo fdisk -1
After that all I get Is fsdisk -1 invalid option. Coming from windows where it's very easy to mount the drives I find this very hard hope you can shed some light for a numpty

Paul

it's not a "1" it's an"l" (lowercase "L) Wink
Reply
#7
Re install given up tonight. I have no glue how to mount the disks in xbmc live it's very different from windows, a few points what is STRG and also you say Don't forget to creat the directory where you want to mount the disk before you try to mount it, can I just name it movies?? Paul
Reply
#8
Oh sorry for the STRG, I think ist must be CTRL in english. ;p

You can chose the directory name for your own for sure.
Reply
#9
Steve122 Wrote:Hey
You have to change the /etc/fstab file and mount the disks.

Thanks for that, works great for me.
Reply
#10
as he installed XBMC live, wouldn't it be easier (if also somewhat a little insecure) to just remove nodiskmount from GRUB line?

http://boshdirect.com/blogs/tech/set-xbm...rives.html

of course it's much more "cleaner" to do this via fstab, particularly if the mounting problems from lucid (as mentioned in the linked blog article) are still there.
OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sony 55" X85C Android TV (also with Kodi!)
Asus Chromebox EZ Script
Kodi on Sony Bravia Android TVs
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
New install xbmc live dharma00
This forum uses Lukasz Tkacz MyBB addons.