Kodi Community Forum

Full Version: Dolby digital plus and TrueHD no passthrough on Nvidia Shield TV
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9
Hi,

I just purchased a nvidia shield tv to use as a mediacenter with kodi.
I chose this box because it was supposed to be the only one who were compatible with every audio codec.

It is actually not, it doesnt work with 2 audio codec : 
- Dolby digital plus (EAC3)
- Dolby TrueHD

It works with DTS, DTSHD and Dolby (AC3)

My receiver (Yamaha HTR-2071) is compatible with EAC3.
I tried with the shield and SPMC -> Dolby digial plus works. It also works with Netflix.

So it really is an issue with Kodi.

Thanks in advance for your suggestion
Be assured: the Shield does handle DD+ and TrueHD. The Netflix and the Amazon-Addon are sending these codecs to my Denon X3400 (KODI 18).

Maybe it's something wrong with your Setup or your cables. More informations are welcome.
Thanks for your answer.
I know the shield decode it because i managed to make it work with the netflix app and the SPMC app.
But in Kodi 17.6 it doesnt work.
I'll try with kodi 18 this evening and let you know
Ok it doesnt work either. it's even worse, it doesnt pass PCM so i have no sound at all
So then it's SPMC for you
Yes but it's not maintained anymore.... and I actually would prefer that it's fixed... i cant be alone in this situation, with nvidia shield + kodi

And actually, it was working on my sony android tv, the DD+ was working but not the DTS
those codecs work fine on my shield with it directly into onkyo 7.2 amp then to lg tv most tv do not support over dd5.1 and dts over arc.
You need to make sure the surround option is set to auto in the Shield's audio settings.
My TV does support dts and ac3 over ARC because it works with other application than Kodi.
And yes the surround option is set to auto

What kind of logs can i provide to help debugging ? I dont see anything related to audio codec inside the basic kodi.log
Please post your sound settings in Kodi, as my Shield TV, connected to a Denon receiver has no issues and I'm running Kodi 17.6, and testing Beta 2 of Kodi 18.

My settings...
=12.0pt- Change Audio output device to Android, RAW Passthrough (should be default).
- The number of channels can be left to 2 (which is Stereo, but read below the Enable pass-through part).
- Output configuration change to Best Match (If you notice sound issues, change to Optimized).

=12.0pt- Stereo upmix should be OFF
-           However, you can enable Stereo upmix, it just outputs stereo sound to all speakers instead of the front. May be useful if you have to crank the volume to hear people talking. However, if you have a Receiver, don’t enable this feature.
- Maintain original volume on downmix should be ON
- Keep audio device alive can be set to 10.

  1. =12pt- Enable audio DSP processing should be OFF
    - Enable pass-through should be ON if you have a Receiver.
    - If you are connected to a Receiver? Then change the settings to use Pass-through. Also, the recommended “number of channels” settings is 2.0, even if you have 5.1 or a 7.1 surround sound setup. Because not all Receivers will accept pass-through if it’s set to 5. Even then, because Kodi is using a “hacked” method for passing audio over HDMI, pass-through doesn’t always work or work correctly with certain Receivers. The only reason to set it to 5.1 is if Kodi is doing the decoding and you are sending LPCM to your Receiver (this means that Kodi is doing the decoding and sending the decoded audio to your Receiver).

(2018-09-13, 17:30)Powerhouse Wrote: [ -> ]Please post your sound settings in Kodi, as my Shield TV, connected to a Denon receiver has no issues and I'm running Kodi 17.6, and testing Beta 2 of Kodi 18.

My settings...
=12.0pt- Change Audio output device to Android, RAW Passthrough (should be default).
- The number of channels can be left to 2 (which is Stereo, but read below the Enable pass-through part).
- Output configuration change to Best Match (If you notice sound issues, change to Optimized).

=12.0pt- Stereo upmix should be OFF
-           However, you can enable Stereo upmix, it just outputs stereo sound to all speakers instead of the front. May be useful if you have to crank the volume to hear people talking. However, if you have a Receiver, don’t enable this feature.
- Maintain original volume on downmix should be ON
- Keep audio device alive can be set to 10.

  1. =12pt- Enable audio DSP processing should be OFF
    - Enable pass-through should be ON if you have a Receiver.
    - If you are connected to a Receiver? Then change the settings to use Pass-through. Also, the recommended “number of channels” settings is 2.0, even if you have 5.1 or a 7.1 surround sound setup. Because not all Receivers will accept pass-through if it’s set to 5. Even then, because Kodi is using a “hacked” method for passing audio over HDMI, pass-through doesn’t always work or work correctly with certain Receivers. The only reason to set it to 5.1 is if Kodi is doing the decoding and you are sending LPCM to your Receiver (this means that Kodi is doing the decoding and sending the decoded audio to your Receiver).

 
Thanks for your help !
I tried with your settings and its the same (actually worse, it doesnt even transmit DD+ to my receiver as PCM , so no sound at all)
The only settings i didnt have is the RAW passthrought, I have audiotrack instead, and cant change it
- Output configuration change to Best Match (If you notice sound issues, change to Optimized).

So if you had Best Match, did you try changing it to Optimized (restart Kodi after the change before testing)?
Might want to look at this thread in the Shield TV forum...

https://forums.geforce.com/default/topic...e-solved-/
Yes I tried that too
Shield connected straight to receiver?
Pages: 1 2 3 4 5 6 7 8 9