•   
  • 1
  • 172
  • 173
  • 174(current)
  • 175
  • 176
  • 271
  •   
Release skin helper service
(2016-12-02, 01:33)marcelveldt Wrote:
(2016-12-01, 17:40)VikkiXavier Wrote: How to display MPAA rating without the words "Rated"? plz help

Use a VAR in your skin for that is the most common option. Offcouse I can also strip off the "Rated" part but don't know how others feel about that ?

Well, the "Rated" word can be easily added as a prefix, like: Rated $INFO[Window(Home).Property(SkinHelper.ListItem.MPAA)]
Reply
(2016-12-01, 18:36)Angelinas Wrote: quote='VikkiXavier' pid='2467648' dateline='1480609137']
Is it possible to see the cast icons (just the icons/ images of actors will be enough) in the views? like showcasse view, posterlist view, etc etc ..?

Yes Smile
Mod AoenMQ6 Krypton
Image

Which view is this?
Reply
Hey Marcel, I've noticed that in PVR recordings, images no longer display at the group folder level. Is this intentional? Thanks.
Reply
(2016-12-02, 02:29)marcelveldt Wrote:
(2016-12-01, 19:11)Mike_Doc Wrote: Hi Marcel.

Similiar movies is coming up as 'Select busy spinner' in widget selection and widget label, looks like label 32006 might be incorrect?

Also still no music lisitems, i.e. tracks. Got all latest scripts and have bool set to true but no luck. Anything else to try or look into?

Edit: saw these in the log, are they connected to skin helper or something else?

1) Do you have the labels hardcoded in your skin ? Are you not using the widgetselector in skinshortcuts ?
If you have them hardcoded you will have to use the labels defined in the new widgets addon or define them in your skin's language file.

2) You are aware that the tracks property is only provided for library items, right ? Also, you have installed all my scripts from my repo and not by hand (to make sure you're on latest version) ? AND you have cleared the cache db before trying ?

3) They shouldn't be from skinhelper but I will take a look

Hi,

1) I checked my template.xml and overides.xml and also the built includes, they have label 32006 in all and in the overides it like this:

Code:
<shortcut label="$ADDON[script.skin.helper.service 32006]" condition="System.HasAddon(script.skin.helper.service)" icon="logos/shs-logo.png" widget="library" widgetType="movies" widgetTarget="video">plugin://script.skin.helper.service/?action=similarmovies&amp;reload=$INFO[Window(Home).Property(widgetreload)]</shortcut>

2) I only have library items in my install, I've go to 'marcels repo' and downloaded everything in there except icons and sounds, then also got the tvdb module as that's not in your repo so I believe I have the very latest version of everything, I've then update home.xml to have an onload the setbool the music one as per the wiki and can confirm in my settings.xml it is 'true'. I've deleted the simplecache.db and started kodi and still nothing, no logo, no tracklist no music listitems at all it seems which would make me think the setbool is not right but my settings say it is ok?

3) Thanks, I wasn't sure as that's all those warning say, nothing really helpful.

Mike.
SKIN: Aeon Madnox
RIP Schimi2k, we miss you.
When I grow up I want to be a skilled skinner
Thank me by ⬇ adding to my + reputation
Reply
Marcel,

I know it's not your scripts, but I'm on a recent nightly on Win 10 and most of the time updates fail to install, just now on startup all your scripts failed to auto-update, they generally work when done manually but the lastest cache on is just 'update failed'

Any ideas why this is happening? as I said I know it's not your scripts but maybe you have some insight into the install process?

Mike
SKIN: Aeon Madnox
RIP Schimi2k, we miss you.
When I grow up I want to be a skilled skinner
Thank me by ⬇ adding to my + reputation
Reply
Hi,
SkinHelper does not collect information for all music artists in my library.
SkinHelper takes only SkinHelper.ListItem.Art.Thumb and SkinHelper.ListItem.Art.FanArt.
Musical artists (for example, AC / DC, Alicia Keys, Ariana Grande, Avril Lavigne, Britney Spears, DEV ..........) have in their catalogs files banner.jpg, fanart.jpg, folder.jpg , logo.png and extrafanart folder with files xxxxxxxxx.jpg, but SkinHelper takes only SkinHelper.ListItem.Art.Thumb and SkinHelper.ListItem.Art.FanArt.

My settings for SkinHelper Music Artwork (EnableMusicArt, EnableExtendedArt, EnableExtraFanart) :
Enable online scraper (musicbrainz/audiodb/fanart/last.fm) - off
Lookup artwork in my music folders (library) - on
Lookup artwork in a custom folder (e.g. recordings folder) - off

I used the "Refresh (auto looup)" - but nothing changes
Maybe someone can help? What am I doing wrong?Sad
Reply
(2016-12-02, 05:59)VikkiXavier Wrote: @Marcel - thnx for ur helpful reply. mate, any progress on the critics reviews from RT thing?

Rotten Tomatoes changed their terms so it's now only possible with a paid subscription to get that info from their API's.
I've asked them if they can have a personal API key so users can subscripbe theirselves, fill in the key in skinhelper settings and only then will receive those reviews.
Reply
(2016-11-27, 13:34)marcelveldt Wrote:
(2016-11-27, 06:08)echo Wrote: One request: is it possible to have a parameter to tell the widget to only display 1 episode if multiple exist for the same TV show?
2) As for your request: In the addon settings for the Skin helper Widgets you'll notice a setting "group episodes" which is what you need.

Hi Marcel, I think there is a bug with this ... even though in settings the toggle for grouping is on, I see multiple episodes for a show.
No errors in log except for:

Code:
22:39:34.245 T:1400 WARNING: CUtil::SplitParams(TVshowPath,"S:\Media\TV Shows - Local Only\Arrow\") - end of string while searching for ) or "
22:39:36.556 T:4424 WARNING: Previous line repeats 2 times.

That show for example IS showing multiple eps so I think those warnings are related to the problem.
Reply
All Pvr problem for channel info and Art:

1-stil same problem about movies -always find tvshow(if excist)
2-SkinHelper.PvrBackground not working for channel
3-When clik manual lookup open search dialog(I complitly delete string for searching,and no meter what to chose from top panel Movie or tvshow alwys is same.Same is when leave Title in serch dialog).
4-Info that I have in library dosent collect info labels for that Title, Art working.(only for TVshow not working, for movies all ok)
5-for simular name(no in library) only collect for first Title info and art, for rest info is blank and for art working only thumb.

With turn on "download Artwork to my custom folder"
Spiderman-3 is first (have all info and art), see info dialogPVRInfo (script save all images in custom folder)
Image
Spiderman, , ill try to set from manual lookup,top panel-movies...resultats same (no new folder in custom folder with name "spiderman")
Image
Back to Spiderman-3 ,now is same info with some missing art
Image
XBoxMediaCenter (Kodi Leia) 18.0 , LibreElec RasPi3 Libreelec-Leia Skin AeonMQ6
Reply
(2016-12-02, 06:05)VikkiXavier Wrote: Well, the "Rated" word can be easily added as a prefix, like: Rated $INFO[Window(Home).Property(SkinHelper.ListItem.MPAA)]

OK, I'll strip off the Rated part for results from OMDB but be aware that the value in Kodi db has preference so you'll have to make sure that items in your kodi library also have no Rated included.
Reply
(2016-12-02, 09:15)wheatfield Wrote: Hey Marcel, I've noticed that in PVR recordings, images no longer display at the group folder level. Is this intentional? Thanks.

Should still work at the grouped level. Are the groupfolders named like the recordings ?
Reply
(2016-12-02, 10:04)Mike_Doc Wrote: 1) I checked my template.xml and overides.xml and also the built includes, they have label 32006 in all and in the overides it like this:

Code:
<shortcut label="$ADDON[script.skin.helper.service 32006]" condition="System.HasAddon(script.skin.helper.service)" icon="logos/shs-logo.png" widget="library" widgetType="movies" widgetTarget="video">plugin://script.skin.helper.service/?action=similarmovies&amp;reload=$INFO[Window(Home).Property(widgetreload)]</shortcut>

2) I only have library items in my install, I've go to 'marcels repo' and downloaded everything in there except icons and sounds, then also got the tvdb module as that's not in your repo so I believe I have the very latest version of everything, I've then update home.xml to have an onload the setbool the music one as per the wiki and can confirm in my settings.xml it is 'true'. I've deleted the simplecache.db and started kodi and still nothing, no logo, no tracklist no music listitems at all it seems which would make me think the setbool is not right but my settings say it is ok?

3) Thanks, I wasn't sure as that's all those warning say, nothing really helpful.

1) Those labels do no longer exist. You will have to define the labels yourself or look up the new values in the language file of script.skinhelper.widgets.
But, why code all the widgets yourself ? you can use the widgets selector, in that case you'll only need to define 1 line of code in shortcuts.xml

2a) the modules are invisible on the repo. You will have to make dependencies on your skin to install them. In this case a dependency to script.skin.helper.service will be enough to also install the modules.
If you're also using the widgets you'll also need script.skin.helper.widgets
If you're also using skinbackup --> script.skin.helper.skinbackup
If you need the colorpicker --> script.skin.helper.colorpicker
If you need the random backgrounds --> script.skin.helper.backgrounds

Offcourse you can also choose to not make them dependencies in your skin but create buttons in your skin to install them them with InstallAddon so users have the choice theirselves to install them. I used that approach for Titan (except for the helper service).

2b) As something is clearly still wrong, can you provide me your kodi logfile after browsing the music library (where the labels don't show up).
You did notice that all window properties have changed now ?
https://github.com/marcelveldt/script.sk...usic-items
Reply
(2016-12-02, 10:11)Mike_Doc Wrote: I know it's not your scripts, but I'm on a recent nightly on Win 10 and most of the time updates fail to install, just now on startup all your scripts failed to auto-update, they generally work when done manually but the lastest cache on is just 'update failed'
Any ideas why this is happening? as I said I know it's not your scripts but maybe you have some insight into the install process?

I think this happens because I'm pushing updates very frequently atm. In some cases I have just uploaded a new version on the repo and it's still syncing on the servers.
Kodi in that case grabs an incomplete file on the server. It's a timing issue if you ask me.

I think it will work correctly if you try to install again at a later time.
Reply
(2016-12-02, 11:46)JohnyBee Wrote: Hi,
SkinHelper does not collect information for all music artists in my library.
SkinHelper takes only SkinHelper.ListItem.Art.Thumb and SkinHelper.ListItem.Art.FanArt.
Musical artists (for example, AC / DC, Alicia Keys, Ariana Grande, Avril Lavigne, Britney Spears, DEV ..........) have in their catalogs files banner.jpg, fanart.jpg, folder.jpg , logo.png and extrafanart folder with files xxxxxxxxx.jpg, but SkinHelper takes only SkinHelper.ListItem.Art.Thumb and SkinHelper.ListItem.Art.FanArt.

My settings for SkinHelper Music Artwork (EnableMusicArt, EnableExtendedArt, EnableExtraFanart) :
Enable online scraper (musicbrainz/audiodb/fanart/last.fm) - off
Lookup artwork in my music folders (library) - on
Lookup artwork in a custom folder (e.g. recordings folder) - off

I used the "Refresh (auto looup)" - but nothing changes
Maybe someone can help? What am I doing wrong?Sad

It's working correctly on my setup with those exact same settings.
Do you have this folder structure for your music:

Artistname
-------------- artwork files
-------------- album name folder
---------------------------------------- album artwork (disc.png or folder.jpg)
---------------------------------------- songs

Also supported is an additional "disc" subfolder in the album.

Any errors in the logfile ?
Reply
(2016-12-02, 13:49)echo Wrote: Hi Marcel, I think there is a bug with this ... even though in settings the toggle for grouping is on, I see multiple episodes for a show.
No errors in log except for:

Code:
22:39:34.245 T:1400 WARNING: CUtil::SplitParams(TVshowPath,"S:\Media\TV Shows - Local Only\Arrow\") - end of string while searching for ) or "
22:39:36.556 T:4424 WARNING: Previous line repeats 2 times.

That show for example IS showing multiple eps so I think those warnings are related to the problem.

Not related to skinhelper, sounds more like an issue with your PVR addon.
Also the second error is spit out by the Kodi scraper, not skinhelper.
Reply
  •   
  • 1
  • 172
  • 173
  • 174(current)
  • 175
  • 176
  • 271
  •   
 
Thread Rating:
  • 18 Vote(s) - 4.56 Average



Logout Mark Read Team Forum Stats Members Help
skin helper service4.5618