•   
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 93
  •   
KOver : Customizable [Kodi 16]
(2015-11-05, 22:24)Jayz2K Wrote: Made a debug log on my system (windows) and I'm completely free of errors from KOver. Could you please give the complete log with KODI Log uploader ? I doubt what you gave is where it comes from. Container 9300 has nothing to do with view building. It's the one for editing an existing one.

EDIT : please use this

http://kodi.wiki/view/Log_file/Easy

I was tailing the log while doing it and that error is the only thing occuring when selecting that.... heres a full log..

http://xbmclogs.com/pbpwuz66c

All i did was enable debug log, reboot and go directly to skin settings and tried to make a new view. Noting happended... i navigated back up and back down to the views and tried a second time.. that error i posted has to be it cause it occured on each select.
Reply
Honestly, I've checked the log, I've checked my code again and pressing enter or right when an empty view is hilighted only goes to Container 9500, which one sets the parameters for a new view. Never it goes to 9300. I don't understand why there's a Container 9300 entry. It only goes to 9300 when a view is not empty but in this case, Container 9500 is not visible so you can't hilight the "apply default vertical" or horizontal. The log doesn't make sens. I'm stuck right now with this. I also have a nexus player, does it need to be rooted for installing Jarvis or can I load it with "unknown source" activated ?
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-11-06, 00:50)Jayz2K Wrote: Honestly, I've checked the log, I've checked my code again and pressing enter or right when an empty view is hilighted only goes to Container 9500, which one sets the parameters for a new view. Never it goes to 9300. I don't understand why there's a Container 9300 entry. It only goes to 9300 when a view is not empty but in this case, Container 9500 is not visible so you can't hilight the "apply default vertical" or horizontal. The log doesn't make sens. I'm stuck right now with this. I also have a nexus player, does it need to be rooted for installing Jarvis or can I load it with "unknown source" activated ?
Loads fine on stock with unknown source... If you look a bit earlier in the log there are a few other skin helper and skin errors...
Reply
Thanks, will give it a try on mine tomorrow. For other errors, you can ignore them.
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-11-06, 01:16)Jayz2K Wrote: Thanks, will give it a try on mine tomorrow. For other errors, you can ignore them.
Thanks for your attentiveness. Really enjoying this skin look forward to figuring this out.
Reply
Further info in case it helps.. While I can modify view 1 I cannot rename it or copy to a template.
Reply
(2015-11-06, 01:59)tmaru Wrote: Further info in case it helps.. While I can modify view 1 I cannot rename it or copy to a template.

Yes, This helps. Not sure ATM but it may be a KODI bug on android devices. The only thing those have in common and different from modifying existing viewtype is the way the parameters are set with the Skin.SetString() function. Editing existing viewtypes set the value as plain text but templates and new viewtypes use floating infolabels (retrieved from other containers).

That could explain this since for things to display correctly in the designer, the viewtype requires a name. Startup write the value "View1" but creating new view writes "$INFO[Container(9100).ListItem.Property(ViewName)]", same for templates. But even if it doesn't display, it doesn't mean the other values are not correctly set. This is where I need you again (sorry) but can you check on your system (you have to find it on android because I don't know where the folder is on those) to find the settings.xml. On Windows it is in :

C:/users/YOUR_NAME/AppData/Roaming/KODI/userdata/addon_data/skin.kover

In there, can you copy and share the settings.xml file please ? This way, if I'm right, every settings for the new viewtypes you tried to create should be there except their name.

Thx in advance,
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
@tmaru :

Forget my request, I made some changes in the code so please update KOver with the latest Github version.
If I'm right, now building new viewtypes should work when applying Horizontal or Vertical. But I can't apply this to templates so they still won't work, same for renaming them. Can you please confirm ?

Moreover, I added the missing control(s) to the Addon Browser. You have now a "Options" button available at the bottom to check for updates and more. And fact all built in controls where missing, my bad. Thanks for reporting this.
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-11-06, 14:14)Jayz2K Wrote: @tmaru :

Forget my request, I made some changes in the code so please update KOver with the latest Github version.
If I'm right, now building new viewtypes should work when applying Horizontal or Vertical. But I can't apply this to templates so they still won't work, same for renaming them. Can you please confirm ?

Moreover, I added the missing control(s) to the Addon Browser. You have now a "Options" button available at the bottom to check for updates and more. And fact all built in controls where missing, my bad. Thanks for reporting this.

Good news... Thanks for the quick fix.. can make and edit new views now.. Addon options working as expected..
Only thing i noticed was previously i could "install from zip" the skin. This time around it failed and i had to manually extract/install it..
Reply
(2015-11-06, 15:20)tmaru Wrote: Good news... Thanks for the quick fix.. can make and edit new views now.. Addon options working as expected..
Only thing i noticed was previously i could "install from zip" the skin. This time around it failed and i had to manually extract/install it..

Fine, that was not an easy one to locate since nothing is in the log.
Can you just also confirm templates and renaming still not working, this is important for me to launch a bug report to KODI team.
For the installation I think I know why, will check the dependencies for the addons. Seems that happened when upgraded skinshortcuts version.
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-11-06, 15:31)Jayz2K Wrote:
(2015-11-06, 15:20)tmaru Wrote: Good news... Thanks for the quick fix.. can make and edit new views now.. Addon options working as expected..
Only thing i noticed was previously i could "install from zip" the skin. This time around it failed and i had to manually extract/install it..

Fine, can you just also confirm templates and renaming still not working, this is important for me to launch a bug report to KODI team.
For the installation I think I know why, will check the dependencies for the addons. Seems that happened when upgraded skinshortcuts version.

Whats the best way to get a fresh install now.. should i install the older version and let it pull the dependencies and then extract the new one over?
In the middle of a fresh install will check the template etc soon as i get back up.
Reply
(2015-11-06, 15:33)tmaru Wrote: Whats the best way to get a fresh install now.. should i install the older version and let it pull the dependencies and then extract the new one over?
In the middle of a fresh install will check the template etc soon as i get back up.

No need to reinstall, you should be fine. You just have to check skinshortcut script is 0.6.5 in addons and skin.helper is at least 1.0.0.
Skinshortcut 0.6.5 seems to cause this, I had the same problem, will downgrade to 0.6.0.
In any case, a new install won't make things to work better for templates since it has nothing to do with it.
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-11-06, 15:38)Jayz2K Wrote:
(2015-11-06, 15:33)tmaru Wrote: Whats the best way to get a fresh install now.. should i install the older version and let it pull the dependencies and then extract the new one over?
In the middle of a fresh install will check the template etc soon as i get back up.

No need to reinstall, you should be fine. You just have to check skinshortcut script is 0.6.5 in addons and skin.helper is at least 1.0.0.
Skinshortcut 0.6.5 seems to cause this, I had the same problem, will downgrade to 0.6.0.
In any case, a new install won't make things to work better for templates since it has nothing to do with it.

Im trying a fresh install cause it kept throwing skin shortcut errors when rebuilding the menu....
Its still doing it on a fresh install.. im going to double check the versions..
Reply
(2015-11-06, 15:49)tmaru Wrote: Im trying a fresh install cause it kept throwing skin shortcut errors when rebuilding the menu....
Its still doing it on a fresh install.. im going to double check the versions..

I downgraded the version dependency on git.
You can download it again and try with this one for a fresh new install.
Cheers
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
(2015-11-06, 16:14)Jayz2K Wrote:
(2015-11-06, 15:49)tmaru Wrote: Im trying a fresh install cause it kept throwing skin shortcut errors when rebuilding the menu....
Its still doing it on a fresh install.. im going to double check the versions..

I downgraded the version dependency on git.
You can download it again and try with this one for a fresh new install.
Cheers

Excellent.. All my previous bugs seem resolved now including templates/view create-edit
Definitely usable at this point.. thanks so much.
Reply
  •   
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 93
  •   



Logout Mark Read Team Forum Stats Members Help
KOver : Customizable [Kodi 16]18
This forum uses Lukasz Tkacz MyBB addons.