•   
  • 1
  • 138
  • 139
  • 140(current)
  • 141
  • 142
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-09-09, 11:00)polo_joe Wrote:
(2016-09-02, 20:40)polo_joe Wrote: I get dropouts when playing local audio file from sd card and then opening tv guide or addon browser.
http://sprunge.us/GdLQ
Anything I can do to prevent this behaviour?

anyone else having this issue?

You can adjust "Audio output latency" in system/audio settings. It defaults to 50ms. Does 100ms or 200ms help?
(2016-09-09, 12:57)popcornmix Wrote: [quote='gendo' pid='2411502' dateline='1473407290']

This is a long standing issue with omxplayer and some live tv add-ons. I really need to be able to reproduce this, but so far no one has been able to provoke this from a recording - which doesn't make a lot of sense - omxplayer has no idea about the source of the video. It suggests the live tv backend does something different with timestamps in the live vs recorded cases.

Ideally find a recording that demonstrates the problem. If not then using mmal or improving TV signal strength is the best option.

Using mmal at the moment so working fine.. backend is tvheadend, let me try some recordings and see if it is reproduceable..
(2016-08-27, 04:29)MONSTA Wrote:
(2016-08-26, 19:40)popcornmix Wrote: Possibly the atempo bug. Looks to be writing beyond edge of a malloc buffer.
Can you set atempo like the suggestion here.

Threshold 100 seems like ok.
Thank you

(2016-08-25, 11:58)esco Wrote: gpu resampling, threshold 0 NG
gpu resampling, threshold 100 OK
medium resampling, threshold 0 NG
medium resampling, threshold 100 OK

Sync playback to display disabled:
gpu resampling, threshold 0 OK
medium resampling, threshold 0 OK

MONSTA, esco. The atempo bug should be fixed. Can you disable any workarounds (e.g. set threshold back to 2) and check that crash is resolved?
(2016-09-09, 12:58)popcornmix Wrote:
(2016-09-09, 11:00)polo_joe Wrote:
(2016-09-02, 20:40)polo_joe Wrote: I get dropouts when playing local audio file from sd card and then opening tv guide or addon browser.
http://sprunge.us/GdLQ
Anything I can do to prevent this behaviour?

anyone else having this issue?

You can adjust "Audio output latency" in system/audio settings. It defaults to 50ms. Does 100ms or 200ms help?
I tried 100, 200 and 300ms, no improvement.
(2016-09-09, 17:16)polo_joe Wrote: I tried 100, 200 and 300ms, no improvement.

Any change with resample method set to "medium" (rather than "gpu").
Can you identify in the log file where the drop occurred?
(One good way is pressing a key with no function when the audio drops - e.g. shift key on keyboard, or an unmapped button on remote)
Resample method middle solves the problem. No more dropouts.

@popcornmix
(2016-09-09, 13:02)popcornmix Wrote: The atempo bug should be fixed. Can you disable any workarounds (e.g. set threshold back to 2) and check that crash is resolved?

The issue is still there.
(2016-09-09, 17:40)MONSTA Wrote:
(2016-09-09, 13:02)popcornmix Wrote: The atempo bug should be fixed. Can you disable any workarounds (e.g. set threshold back to 2) and check that crash is resolved?

The issue is still there.

Can you post a crashlog?
No. I get a freeze without crash. RPi hangs untill power off. So i cant get a new log.
If you restart, the old log should be $KODIDIR/temp/kodi.old.log
(2016-09-07, 08:32)Milhouse Wrote: Debug-enabled build #0906x: RPi / RPi2

Unfortunately kill -SEGV <pid of kodi> still gives me a corrupt stack:
http://sprunge.us/GFMJ

I got something slightly better with #0905 but still no cigar
http://sprunge.us/YWbU

Will go back through previous builds to see if I can find one which works...
Q: Is this a valid way to get a crash dump on kodi? (It's not something i've used before but looks like it should work...)

... edit...
Tried back as far as LibreElec 7.0.1, still the trace ends with 'corrupt stack'??
http://sprunge.us/AibS

I don't get this on my gentoo box when I kill kodi in the same way...
http://sprunge.us/XQLQ

Went back to Openelec - but that doesn't include gdb, so no backtrace at all...
Other than an actual crash, "kill -SIGSEGV" is about the only way (that I know of) to force a crash dump.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
This is my first post and I want to say thank you to all the developers for their great work and for making this fantastik software happen.

Ive used kodi for a year on different plattforms. Actualy with the testbuilds on the raspi 3 I have the problem, that from time to time the playback of my tvheadend recordings stop and the system starts buffering for a second or two. The debug log is her

https://paste.ubuntu.com/23156305/

I tried a few things (deinterlacing MMAL Bob half; overclocking ram) but nothing helps. This problem never went away since I used the test builds on the raspi 3. With the same setup on the server side and Kodi on an MXQ box (AMLogic 805) Ive never had this buffering issue.

Any advice?

Alexander
Then again, sometimes it obviously does work:
http://sprunge.us/ZNAJ

One deadlock on entering EPG view while 'loading channels from client was in progress.
Something introduced with ksooo's otherwise excellent EPG enhancements I think.

Import is a bit slower than it used to be so i guess it's trying to match up EPG entries with recordings in the background. I have a lot of recordings and a lot of channels and I guess something isn't 100% thread safe.
New LibreELEC.tv Krypton build #0909: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.3 #1 Sat Sep 10 01:59:27 BST 2016 armv6l GNU/Linux

# vcgencmd version
Sep  7 2016 14:50:28
Copyright (c) 2012 Broadcom
version 1f1070f16206004c8f2172144ec8f167db6c742f (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160910015626-#0909-g4ee8c5d [Build #0909]

# vcdbg log msg 2>&1 | grep DTOK
002391.078: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (4ee8c5d0, changelog) and tip of XBMC master (968d8894, changelog) with the following modifications: Build Highlights:
  1. CMake fixes
  2. Estuary skin fixes
Build Details:
  1. LibreELEC.tv:
    • spotify-connect-web: handle PCM specified as a:CARD=c,DEV=d (PR:714, 1 commit, 3 files changed)
    • llvm: update to 3.9.0 (PR:689, 2 commits, 5 files changed)
    • vdr: fix NULL pointer segfault (PR:698, 1 commit, 1 file changed)
    • vdr-addon: update plugins (PR:639, 1 commit, 5 files changed)
    • system-tools: add inotify-tools, mc (PR:700, 3 commits, 6 files changed)
  2. XBMC:
    • [cmake] Add uninstall target for linux (PR:10398, 2 commits, 3 files changed)
    • [gui] use CVariant on SetVisualisation(...) (PR:10406, 1 commit, 1 file changed)
    • AE: fix eac3 parser, correct parsing of channels (PR:10440, 2 commits, 2 files changed)
    • [Estuary][PVR] PVR home screen widgets: Misc fixes and improvements (PR:10438, 8 commits, 23 files changed)
    • [cpack/deb] Force GIT_HASH update on DEB package generation (PR:10424, 1 commit, 3 files changed)
  3. newclock5:
    • Commits no longer in build:
      • Revert "AE: change usage of swr_set_compensation" (5ac51ad3)
  4. kernel 4.7.y:
    • New commits in this build:
      • config: Enabled SENSORS_INA2XX module (cb03c80f)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: xf86-video-amdgpu: bump to latest master 6a1ba04, updated Polaris 10 & 11 support
    • Added: [env] PR:696: build system cleanup
    • Added: [env] PR:716: init: make sure /storage is owned by root
    • Added: [pkg] PR:10442: [Estuary] bugfixes
    • Added: [pkg] PR:10444: [AddonInstaller] - 1 year and 8 month after the last recursion fix fr¦
    • Added: [pkg] PR:10445: require click action to activate slider controls
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 138
  • 139
  • 140(current)
  • 141
  • 142
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319