•   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 62
  •   
[RELEASE] Twitch.tv
Until it is updated on the official repository I packaged the current github + PR that includes the fix for the change today. This may not be the final 1.4.2, and is tagged as ~alpha1 and will update when 1.4.2 is released on the official repo

If you've already updated to the github version of 1.4.2 you will have to uninstall the add-on to install this zip

plugin.video.twitch-1.4.2.alpha1.zip

http://kodi.wiki/view/HOW-TO:Install_add..._zip_files

* edit: removed links (1.4.3 on official repo)
Debug Log (wiki) | Troubleshooting (wiki)Add-ons
Reply
(2016-09-16, 05:38)anxdpanic Wrote: Until it is updated on the official repository I packaged the current github + PR that includes the fix for the change today. This may not be the final 1.4.2, and is tagged as ~alpha1 and will update when 1.4.2 is released on the official repo

If you've already updated to the github version of 1.4.2 you will have to uninstall the add-on to install this zip

plugin.video.twitch-1.4.2.alpha1.zip

http://kodi.wiki/view/HOW-TO:Install_add..._zip_files


Thank you so much!
Reply
(2016-09-16, 05:38)anxdpanic Wrote: Until it is updated on the official repository I packaged the current github + PR that includes the fix for the change today. This may not be the final 1.4.2, and is tagged as ~alpha1 and will update when 1.4.2 is released on the official repo

If you've already updated to the github version of 1.4.2 you will have to uninstall the add-on to install this zip

plugin.video.twitch-1.4.2.alpha1.zip

http://kodi.wiki/view/HOW-TO:Install_add..._zip_files

Orale holmes. Thanks.
Reply
Hello,

I have installed plugin.video.twitch-1.4.2.alpha1.zip and follow the instructions to configure the plugin
  1. I visited www.twitch.tv/settings/connections and Register the application
  2. I wrote the Client-ID in the tab API
  3. I visited www.twitchapps.com/tmi to generate an OAuth token
  4. I wrote the token in the tab GENERAL > OAuth Token
But when I choose a stream that I want to watch, a window appears with openning stream then I get the error message : Playback failed

Is the plugin properly configured ?

Thanks to help Smile
Reply
Sounds like it, and I just checked with my live and test installs and they are both working.

Without a log the rest would be guessing.

Though in the points you mentioned;
1 and 2 are optional (unless the add-on gets rate limited from many users etc.)
3 and 4 only affect Vods and Chat at the moment

So you could also try with default settings in a Featured Stream and see if that is working for you. If that works add the oauth token and try a vod. If those are working add your client-id.

If you post a log with the issue I will take a look when I get a chance
Debug Log (wiki) | Troubleshooting (wiki)Add-ons
Reply
Hello,

I tried this new version but it seems like I still have the same problem Winjet's having:
I get the error : Playback failed whenever trying to launch any stream
(It also failed on 1.4.1 and .2 but for some reason everything worked fine with 1.4.0 - well.. until a week or so when Twitch apparently made changes -)

so here is my log hoping it can help solve the mystery
Reply
(2016-09-17, 00:34)Seeneast Wrote: Hello,

I tried this new version but it seems like I still have the same problem Winjet's having:
I get the error : Playback failed whenever trying to launch any stream
(It also failed on 1.4.1 and .2 but for some reason everything worked fine with 1.4.0 - well.. until a week or so when Twitch apparently made changes -)

so here is my log hoping it can help solve the mystery

There is a https problem with system library.

Code:
00:18:49 T:1656746992   ERROR: /recalbox/share/system/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:791: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.org/en/latest/security.html
                                              InsecureRequestWarning)
Reply
That error happens even under working circumstances. The method isn't fully tested by myself as it was implemented by someone else, though K17alpha&beta and 16.1 so far have been working fine for me (showing same error/warning). Seeneast/Winjet can you confirm which version of Kodi you are on and what device type please?
Debug Log (wiki) | Troubleshooting (wiki)Add-ons
Reply
I'm using the Recalbox OS (latest 4.0.0-beta5) on a RaspberryPi 2
It's still running Kodi 15.2 atm so it might be kind of a specific situation :/
However as I said earlier TwitchTv 1.4.0 was working fine a week ago

Thanks for taking the time to answer Smile
Reply
Okay, so I dropped back to 15.2 to test and everything seems to still be working as expected.

Comparing my logs with the one provided via github issue, Seeneast's log and some Recalbox OS full logs, the only common difference from the working tests(Kodi 15-17, rpi2 osmc, windows) is ffmepg, "NOTICE: WARNING: unsupported ffmpeg version detected" which appears at the very top of the log for Recalbox OS logs I looked at and the github issue.

That coupled with the fact that the no playback you are seeing is happening @ ffmpeg I'm not sure this is something that can be resolved from the add-on, and may be related to ffmpeg versions. (I'll keep looking but at the moment this is the only hint I can see)
Debug Log (wiki) | Troubleshooting (wiki)Add-ons
Reply
(2016-09-17, 01:28)anxdpanic Wrote: That error happens even under working circumstances. The method isn't fully tested by myself as it was implemented by someone else, though K17alpha&beta and 16.1 so far have been working fine for me (showing same error/warning). Seeneast/Winjet can you confirm which version of Kodi you are on and what device type please?

I'm using the Recalbox OS (version : 4.0.0-beta5) with Kodi 15.2 on a RaspberryPi 3 Model B.

I'm try with multiple settings :
  1. With default settings (OAuth Token and OAuth Client ID empty)
  2. I wrote OAuth Token only, OAuth Client ID empty
  3. I wrote OAuth Client ID only, OAuth Token empy
  4. I wrote OAuth Token and OAuth Client ID

It does'nt work at all, impossible to open any stream.
Reply
More information since my previous message :

The stream starts now but only once after I get the error : Playback failed. I must reboot the raspberry that I can again look at a stream.
Reply
1.4.3 Submitted to Kodi Addons Team and is awaiting pull request merge.

This should fix several of the issues experienced due to the evolution of the Twitch API.

Sprig
Reply
I installed version 1.4.3 but I still get the same error messages :
http://pastebin.com/L6Wwc1LE

In addition, I have the following error (Unverified HTTPS request) :
http://pastebin.com/0AAsW4Sd

RaspberryPI 3 Model B with Recalbox OS (version : 4.0.0-beta5) and Kodi 15.2

Thanks
Reply
(2016-09-18, 10:34)Winjet Wrote: I installed version 1.4.3 but I still get the same error messages :
http://pastebin.com/L6Wwc1LE

In addition, I have the following error (Unverified HTTPS request) :
http://pastebin.com/0AAsW4Sd

RaspberryPI 3 Model B with Recalbox OS (version : 4.0.0-beta5) and Kodi 15.2

Thanks

Ok the Unverified HTTPS request log entry is not relevant to your issue and is fine to ignore as it doesn't affect functionality of the addon and the data we are sending across https is not sensitive.

As for your playback issue, it seems the cause is not within the scope of this add-on and may be related to changes Twitch have made to their encoding which has possibly resulted in an incompatibility with your specific setup..

To rule out a localised issue, are you able to try a different OS on the Raspberry Pi with the latest stable version of Kodi and report back your results?

Thanks

Sprig
Reply
  •   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 62
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Twitch.tv8
This forum uses Lukasz Tkacz MyBB addons.