•   
  • 1
  • 77
  • 78
  • 79(current)
  • 80
  • 81
  • 134
  •   
WeTek Core (24p HD Netflix / HD Audio / Lollipop / OpenELEC / 4K / HEVC)
(2016-02-04, 03:11)wesk05 Wrote:
(2016-02-03, 17:20)droidelec Wrote: We are happy to announce that we finally fix HD Audio passthrough for both S8xx and S9xx Platforms in Kodi, so from now on all owners of WeTek Core and other devices powered either by S8xx or S9xx can enjoy in HD Audio passthrough.
Tested:
DTS-HD Master
Dolby TrueHD
Tested on both WeTek Core (S812-H) and WeTek Play+ (S905-H Rev. C) with Android Lollipop 5.1.1.
Very Nice! I tested it on Minix U1 (S905) and Minix X8-H (S802-H). It worked fine on the U1, but didn't work on the X8-H. I will have to get the X8-H Plus (S812) back from my friend for testing (hate to ask for something back after giving it away).

Apart from Dolby TrueHD and DTS-HD Master Audio, Dolby Digital Plus 7.1 and Dolby Atmos (TrueHD/Digital Plus) is also working.

IEC for the win ... if now the rest of this android party would also use those frames ... we would have never had to rewrite core parts of audio engine ... but yeah for "default android" I don't see a solution for such extended atmos bits in the near future.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Yes I have included that, the first time it worked, then I cleaned the kodi-depends folder and did not work anymore Big Grin

Yes, for S8 you need LP and the code has to be modified including some bits from S905.

BTW, I have noticed that on S9 it still uses the "old" resolution names when refresh rate switch is enabled (but also when you start Kodi if you are with 1080p60hz resolution, 1080p is written to /sys/class/display/mode file), and I have added the 50/60hz 4k resolutions for S9.

If this is an acceptable way of handling it I will do a pull request on the master branch: http://pastebin.com/raw/MJMS64PS
Reply
We don't have an Android maintainer anymore - therefore the job is to be offered. From looking at it, you don't want to name the var s9, cause most likely the s10 will also support it.

In the resolution code you have some whitespace issues and you use the 10 bit decision to set specific video resolutions, which are platform specific and not hevc-10 bit specific. If you need to know that you are running on an S9, then you should find that out in a different way. hevc-10 bit caps and being an s9 are different things. For future maintainance.

Edit: One can also argue if the int needs to be static or rather a member, as the method calling it is not static.

Besides that: PR welcome.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
The problem is that only S9 (and future) devices will make use of those new resolution names and the only way to detect it is checking the presence of HEVC 10-bit decoding since cpuinfo is not very helpful on S9 (at least yet).
You can't check the resolution values from the hdmi driver because it's not guaranteed that one of the new resolutions is listed, it's unlikely but might happen (in case of a bad EDID probably)

Code:
Processor       : AArch64 Processor rev 4 (aarch64)
processor       : 0
processor       : 2
processor       : 3
Features        : fp asimd crc32 wp half thumb fastmult vfp edsp neon vfpv3 tlsi vfpv4 idiva idivt
CPU implementer : 0x41
CPU architecture: 8
CPU variant     : 0x0
CPU part        : 0xd03
CPU revision    : 4

Hardware        : Amlogic

I can set it as a method and call it like "needsNewResolutions", or anything else Smile
Reply
If there will never be a device _not_ supporting hevc-10 bit and needing that resolutions ... then fine :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
I guess not, there would be no logical reason to release a S915 (example name) with no 10 bit support when an older one does support it, but right now I cannot find any other way to detect the presence of S9 or S8, I could check "aarch64" in cpuinfo but IMHO is worse
Reply
(2016-02-03, 21:27)droidelec Wrote: @hdmkv

Just update over OTA, and inside you will have Kodi and WeTek Jarvis build, you will see on launcher description for every app.

CT is working with koying to remove Kodi name from our mod., as we want to follow rules and advice from Martijn to dont confuse anybody.

We also made all changes public and accessible to everybody.

I've done an OTA update and my Wetek Core is saying it is up to date. However I only have Kodi Isengard 15.2 installed on reboot. No Jarvis 16.2 custom?

Do I need to download the apk separately. Have done a check that there isn't an OTA Update after the previous OTA update.

On the home screen I just have the Kodi icon (which runs Isengard 15.2), the world icon, the apps grid icon, the folder icon and the google play store icon. Below that I have the YouTube, Aptoide and WE.Update icons.
In the app folder I have all my installed apps, and just a Kodi 15.2 Isengard. No 16.2?

Have I done something stupid.

I can see the mega download link in a post above - I can download that and install - but saw the post above suggests the OTA update should install 16.2 as an included app?
Reply
You can download the app to a USB Pen/mSD card and install, use ES explorer.

Just select the apk and install

You'll have a Kodi APP and the new modified app from WeTek
Reply
@noggin,
(2016-02-03, 21:37)ChristianTroy Wrote: ....with the help of koying I almost did it, now it starts but I don't have the binary addons in the apk, going to try to fix it now Smile
After that when tomorrow our graphic designer does a new splash image, banner and launcher icon it will be ready for the release
I don't think WeTek-Jarvis 16.x is out yet, that release that will include the custom WeTek graphics etc.

I don't think a working re-branded Android Kodi .apk is as easy as some make it out to be.
Even Koying has had "more fun than intended" to rebrand his custom Kodi - SPMC. Wink

Reply
Have installed from the Mega link earlier in this thread.

I get some very strange results. DTS HD MA tracks trigger my Onkyo amp into DTS HD MA mode (the right lights come on) but I get silence. Dolby True HD stuff appears to be output in a format that makes the receiver think it is PCM 2.0 (I get PCM 2.0 reported by the amp when I check what it thinks it is being fed), and I get silence and the odd bit of digital break up.

Are there settings in Android I need to alter. I've enabled bitstream (DD/DTS is fine bitstreamed) and have also enabled EAC3, DTS HD and True HD. I have tried with speakers at 2.0 and 5.1 (in case that was an issue)

Not sure what I've done wrong.

If I disable passthrough DTS HD MA plays back with 7.1 PCM output fed to the amp (though I've configured 5.1 speakers) No way of checking if this is DTS or DTS HD MA decode. The OSD codec overlay says "dts (DTS HD MA)" and the bitrate is around 3.8Mbs.

The same is true of Dolby True HD tracks. I get 7.1 PCM output to my amp, but no way of knowing if it is DD or True HD that is being decoded, though the OSD codec overlay says "true HD (AC3/ xxxxx)" and reports 3.4Mbs bitrate.

Assuming the overlay is correct, then I'm getting Multichannel PCM Decode - (yay!) - (as per the Pi 2) but not bitstreaming with my current set-up (boo!) ?

If this gets rolled into Linux stuff for the C1/C1+, C2 and other AMLogic devices then Wetek will have done an amazing service to the Kodi community. They appear to be doing a great job so far. Many thanks from me for all of their efforts both on their own products, which are very neatly packaged and made and ideal for people who want to avoid "DIY" and want Netflix etc. But they are also potentially helping us DIYers as well. Which is brilliant and in such an amazing contrast to others <cough> Vidon.
Reply
I really hope, that someone rebases on v17 - everything v16 / v15 delivers concerning passthrough is suboptimal. For example in v15/ v16 we send zeros (!) to not underrun the sink, this is just bad and bullshit. In v17 we can create pause packages in IEC format with different lenghts, so the sync is much, much improved.

Wetek sent told to send me a SXX sample - so I will see to get at least the AudioTrack parts in line in a non intrusive way, e.g. by not cluttering a well written sink full with #ifdeffery party. I hope amlogic can convince google to stop their insane non IEC passthrough stuff in the future. I think AMLogic offers a better way in that regard.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
@noggin
according to Amlogic on S812 it will not work with all the AVRs, I have an Onkyo TX-SR508 and it works though.
You don't need to do anything in Android but going to settings -> audio -> digital and set HDMI passthrough, in Kodi just enabling the HD audio formats like you usually do.
Reply
@noggin

Check SW version in Settings -> About. If you have only one Kodi then something is not ok with your SW. We tested latest SW and WeTek Jarvis mod on Onkyo TX-NR636 and Yamaha AVR and it is working OK.
Reply
Finally got a chance to evaluate... I have a Denon AVR-X2100W AVR:
  • AAC 5.1 = pass
  • DD5.1 = pass
  • DTS5.1 = pass
  • DD+ 5.1 = pass (nice surprise)
  • DD+ 7.1 = pass (nice surprise)
  • TrueHD 5.1 = fail (all 6 channels present, but dropouts every other second)
  • TrueHD 7.1 = fail (all 8 channels present, but dropouts every other second)
  • ATMOS = passed fine w/o dropouts as 7.1 as my AVR isn't ATMOS capable (surprising in light of above)
  • DTS-MA 5.1 = fail (no audio out of any channels)
  • DTS-MA 7.1 = fail (no audio out of any channels)
  • DTS:X = fail (no audio out of any channels)
  • LPCM 5.1 = pass (nice)
  • LPCM 7.1 = pass (nice)
Also, after OTA firmware update (this one was unusually long), Kodi WeTek-Jarvis-16.rc2 isn't automatically installed, so had to sideload it.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
@hdmkv

Tomorrow we will make video. At our Onkyo seems all OK as it should. About firmware we will check as well, but it should come preinstalled. Try to make factory reset or to make manual flash of firmware . Zip which You can download from:

http://178.63.47.80/DB-J33-wetekcore-ota...-15-22.zip

It would be nice if you could send kodi.log here or Core Beta test forum.
Reply
  •   
  • 1
  • 77
  • 78
  • 79(current)
  • 80
  • 81
  • 134
  •   
 
Thread Rating:
  • 4 Vote(s) - 4.75 Average



Logout Mark Read Team Forum Stats Members Help
WeTek Core (24p HD Netflix / HD Audio / Lollipop / OpenELEC / 4K / HEVC)4.754