Artist Art Not Showing
#1
Hi guys... after recently setting up Kodi for the first time. I noticed that almost all of the artist art (thumbnails, etc) was not showing in my music library. I tried the option to query all artists, but that was no good. I even tried deleting the whole music database and starting over... still no good.

In fact, the only way I can get it to add artist art is to individually refresh that artist. When I do this it immediately finds the artist and shows the artwork. However, doing this individually for each artist in my large library just doesn't make sense.

How can I automate this so that the artists for my whole library and the artwork is found?

Thanks for the help.
Reply
#2
In theory that should happen when you scrape the library, but if the scraper source (generally theaudiodb.com) is slow to respond, Kodi imports based on what it finds in the music files and not from the scraper. Given that, my first thought is that something between you and theaudiodb.com is running slow.
Providing a debug log: Log_file/Easy (wiki)
Leia Estuary mod: 333143 (thread)
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
Reply
#3
Thanks for the reply pkscout... when I re-query all the artists, should it not fill in some of the missing art?
Reply
#4
(2017-02-23, 04:15)Drybonz Wrote: Thanks for the reply pkscout... when I re-query all the artists, should it not fill in some of the missing art?

That hasn't been my experience. The only way I've found to force a rescan (for a song at least) is to change something in the file's metadata. I've never checked to see if that forces an artist refresh as well or not.
Providing a debug log: Log_file/Easy (wiki)
Leia Estuary mod: 333143 (thread)
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
Reply
#5
Unfortunately, if I start fresh it will skip many artists each time. The artists it skips each time are different... and each time if I individually select refresh it will find the artist and art almost immediately. There are a handful in my collection that just don't seem to have artist info, but for the most part it is skipping very common artists that, when I refresh individually, they often turn out to have multiple thumbnails available for the one artist.

The real issue is that it isn't completing the automated search for all artists.
Reply
#6
Music has "scanning" which reads metadata tags or cue sheets from song files and finds local art for album thumbs, album artist thumbs, and album artist fanart. There is a music setting that determines if newly scanned albums also trigger the album and artist scrapers to find online additional data and art. There is a second setting that determines if the online information will overwrite tag data in the library database.

There are also options to "refresh" which starts the scrapers on artists or albums that exist in the library database (have been previously scanned).

If scrapers find anything, the library database is updated with the "last scraped" date/time. This is used when exporting/importing the music library (unscraped db entries aren't exported). Unscraped music is otherwise fully usable in the music library views. In the past you couldn't open an info dialog for unscraped album/artist but that restriction has been removed.

Note that on local album artist art search, the scanner looks in the parent folder for folder.jpg and fanart.jpg and if not found will search up to two folder levels up in the source.

scott s.
.
Reply
#7
(2017-02-24, 23:06)scott967 Wrote: There is a music setting that determines if newly scanned albums also trigger the album and artist scrapers to find online additional data and art. There is a second setting that determines if the online information will overwrite tag data in the library database.

I have both of these options checked on.

All the files in my library are meticulously tagged and have album art. This art does show in Kodi.

What doesn't happen, is, even with these options checked, the artist info and art search is not adding info/art to the library... this is for artists that have info and art available. If I refresh that artist individually, after the auto-search has failed, it will find the info/art.
Reply
#8
You do not say what version of Kodi you are using?

But this issue is most likely that the servers providing additional artist and album information are overloaded. When this happens Kodi just gets timeout responses from them and not data. The weekend is also a particularly heavy time for server traffic, and TADB often runs out of bandwidth towards the end of the month.

This means that Kodi can not always fetch art when it tries. A single manual refresh request is more lilely to be successful then the batch of requests made during a scraping session, but is tedious for the user. All you can do is retry multiple times, using "query info for all" from the context menu, eventually you will pick up the extra info and art.

EDIT: moved to Music Support as this issue is not platform specific
Reply
#9
I'm using version 17.

This is 60-70% of my artists that it are missing after the search. If it's common for a problem of this scale when trying to retrieve the info/art, could an option be added to keep trying until they are all filled? A person could just leave it on overnight and have it completed by the morning.
Reply
#10
Just scraped, first attempt only 20% of the artists didn't timeout and came back with info, so yes at the moment that is normal.

Rather than keep hammering the servers, which will only result in more blockage, a better solution would be for Kodi to run its own server to mirrror the Musicbrainz db.
Reply
#11
(2017-02-27, 09:16)DaveBlake Wrote: Just scraped, first attempt only 20% of the artists didn't timeout and came back with info, so yes at the moment that is normal.

Rather than keep hammering the servers, which will only result in more blockage, a better solution would be for Kodi to run its own server to mirrror the Musicbrainz db.

I actually set this up once, its quite hard to keep up-to-date with all the MB server changes though.

Certainly something that should be considered though, it would be ideal for any of our users who have some spare server power and a good understanding of ubuntu hosting virtual images.
Image Image
Reply
#12
Hi everyone, new user here. I too have this same problem. I have done all the Picard tagging and sorted the folder structure so that the export to the artist info folder will be ok. Loaded my music into the library, been through all the albums and the ALBUM thumbs are fine, but there are no ARTIST thumbs. I was happy to let the scraper find artist thumbs online. Problem is, its not. I have deleted and reloaded the music into the library and cleaned the library 3 or 4 times now in an attempt to get it working and go online to find the artwork for the artists.
I have the "prefer online" ticked and also the "update extra information" ticked.
When I enter the artist node and highlight an artist and then select "query all artists" in the top right hand corner the scraper starts and it says "preparing 0%" for about half a second and then just shuts down......or doesn't even really get going at all.
I have tried doing this over and over in case the servers were backed up or for whatever reasons have been given prior, but nothing.....it simply will not work.
I also have the same thing happening whereby I can click through onto a singel artist and hit refresh and it will come up with a box that says "local info found would you like to ignore and us e the internet" to which I respond yes and it goes ahead and does exactly what I am asking it to do.....but the query all wont work. Is there a way to refresh the entire library?? my understanding is that the "query all" is the same as "refresh" only its the "refresh of the whole library not just one artist. I don't want to have to go through each artist individually and refresh and then select the art etc etc.
Please help its doing my head in.
There is nothing I can see as to why it isn't working?
Reply
#13
In addition.....I just did a scrape of the albums and that seems to be working...just the artist scrape isnt??
Reply
#14
Some background and some questions.

Background:

When you tag your music files, what Kodi gets is the artist name (the text string), the artist role (typically song or album artist, but could be other contributor such as conductor) and optionally (but preferred) the artist's MusicBrainz ID (MBID).

Mostly what "prefer online info" does is replace the artist name with the name from MusicBrainz (if it is different).

The preferred way to handle the additional artist info is to first create an "artist info" folder in your local file system, and point Kodi to this in your music settings.  This can help keep Kodi from finding local artist info you didn't intend.

When you tell Kodi to Query All artists, it will attempt to scrape any artists that have not been scraped in the past.  Kodi always looks for a local artist.nfo file first.  By setting an artist info folder, Kodi should only find an nfo file if you placed one there for that artist, either manually or by exporting separate artist files from the settings.

Artist art will work the same way.  It looks for local art in your artist info folder.

So the questions:

Do you have an artist info folder set?

Do you have local artist.nfo files or art?  If so, where are they located?

Also, posting a link to a kodi log with debug logging enabled and capturing a session where you attempt to scrape your artists will help identify what is going wrong.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Krypton
Leia
Reply
#15
Hi Scott, thanks for the reply.
I should have mentioned. Yep I followed the wiki getting started pages. I set up an artist info folder as a separate folder. ITs in the "my music" folder, but my song files are in a folder named "All music" and the artsit info folder is named "artist info" so it is separate form the music files. I also did the initial loading into the library as per the instructions NOT having the "prefer online info" unticked. After loading into the library I then set up the artist info folder and exported. 
THEN I ticked the prefer online info and did the second scrape....this is what isn't working.
So going on what you just explained, because I now have an artist info folder the scrape isn't bothering to go online and get extra info because the artist info is populated?? Is that right??
Problem is the artists dont have any thumbnail pics or any actual artist info until I manually refresh them individually one by one per artist??
Log files...I will have to work out how to do that......this is all new to me.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Artist Art Not Showing00