Thread Rating:
  • 0 Vote(s) - 0 Average
Kodi 17 - TMDb not scraping Director / Writer / Studio Information
#16
I have the same issue and waiting for the update.
Reply
#17
2 of my four kodi machines have updated.
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#18
I got the update on at least one machine, and all is back to normal for me there. I'm guessing each box has a different update schedule, so be patient, it should be coming.
Reply
#19
Exactly, go walk the dog, it'll come in due course.
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#20
Firstly, you don't need to dig into the file system and checking files to check version of scraper library.
Go to settings/system/add-ons and there is a mange dependencies option there. You see all libraries and their version over there.

Second thing is that I believe you can accelerate the update if you use the "check for updates" option from the side menu within add-ons from home screen.
Reply
#21
And make sure you automatic updates on as well I guess.
Reply
#22
Thank you Olympia. I was able to update to the proper version this way. I appreciate your help.
Reply
#23
The update solved the problem, thanks to the addon author for the quick fix.
Reply
#24
(2017-06-11, 09:26)olympia Wrote: Firstly, you don't need to dig into the file system and checking files to check version of scraper library.
Go to settings/system/add-ons and there is a mange dependencies option there. You see all libraries and their version over there.
That is quite true, but sitting here at my laptop I can check all my systems via ssh:
Code:
[email protected] ~ $ ssh [email protected] grep version .kodi/addons/metadata.common.themoviedb.org/addon.xml
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
       version="2.15.0"
    <import addon="xbmc.metadata" version="2.1.0"/>
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#25
(2017-06-11, 01:55)Karellen Wrote: Here is the response taken from one of the many threads regarding this issue.

Karellen Wrote:The scraper is not being updated so it will remain v3.9.4

metadata.common.themoviedb.org will be updated to v2.15.0 which is located in the program directory. As this is not an Addon, you cannot download a zip file to manually install. It has to auto update via the repository.

So, just make sure your Kodi is running and connected to the internet. When the update reaches the servers in your part of the world, it will update.

I have the TMDB scraper 3.9.4 and metadata.common.themoviedb.org v2.15.0, but something screwy happened...

Switching to 3.9.4 fixed the API problem that was mentioned a lot on the forums a week ago. However, a couple days ago I noticed the 13 most recent movies I added had no actor info. So I came here and found that there was a new issue where I should update metadata.common.themoviedb.org to 2.15, so I did that.

To re-scrape the 13 movies with missing info, I removed them from my movie directory and cleaned the Kodi library so their entries would be removed. That worked fine. The most recent 13 movies are no longer in my library. Then I added them back. But now when I run the scraper, it acts like those 13 movies aren't there. It doesn't seem to be seeing them at all. I just added a new movie that's never been in my database before and it worked perfectly. But those 13 that I removed, cleaned my library, then added back? The scraper acts like they're not there.

They're not in my kodi.log file, either. Last week's API thing that caused missing files for me, those files were seen by the scraper and noted in the log as not finding matches. These 13 files aren't being seen at all and aren't in the log and I have no idea why. The files are definitely there and their entries are definitely not showing up in Kodi and not being seen by the scraper.

Any thoughts?
Reply
#26
Could you try the following...
1. Move those 13 movies out of the Kodi movie Source
2. Run a Clean Library
3. Move the 13 movies back into the Source
4. Run an Update Library.

If that does not work, then navigate to one of those movies via Videos>Files>Movie Source. Highlight the movie and call up the Movie Information Page. It should start an automatic scrape.

Let us know if either of these work. If not, we will need a debug log while running an update library.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki) || Artwork (wiki) | NFO_files (wiki) | Import-Export_library (wiki) | HOW-TO:Create_Music_Library (wiki) | Movie_Sets (wiki)
Reply
#27
debug log (wiki) of scraping
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#28
(2017-06-14, 22:39)Karellen Wrote: If that does not work, then navigate to one of those movies via Videos>Files>Movie Source. Highlight the movie and call up the Movie Information Page. It should start an automatic scrape.

This tip worked perfectly. Thanks a lot. I never had to do it that way before.

Thanks so much for the quick response.
Reply
#29
Glad it worked Smile
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki) || Artwork (wiki) | NFO_files (wiki) | Import-Export_library (wiki) | HOW-TO:Create_Music_Library (wiki) | Movie_Sets (wiki)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
TMDb not scraping Director / Writer / Studio Information00