Req Kodi Plugin for MediaPortal 2.2 TV-Server
#1
Hi,

I'm from MP developer team. Can please somebody let me know who wrote the last working plugins for MP2.1.2 TV server?
MP2.1.3 is currently not supported and I want to ensure, that the coming major release 2.2 will be supported.
I can offer an internal pre-release by private message.

Ge2301
Reply
#2
@margro You seem the guy who wrote the plugin Blush 
Would you be able to update it to next major version 2.2? Just let me know which infos you need.
Reply
#3
You can download the sources from here -> https://users.scintilla.utwente.nl/marce...rxbmc.html for the MediaPortal plugin. You can update the MediaPortal dll's then recompile.
XBMC PVR Addon Unofficial Builds for Frodo Nightly Builds.
http://www.dotnetdevelopers.net/xbmc
Reply
#4
@wileecoyote 
I'm WPF coder and not familar with #C. I've pulled the branch. If you help me what to change, I can try.
I've seen that in the last commit for MP2.1.2 no dll's were changed, but assembly versions.
Reply
#5
I've got to be honest, and speaking as someone who was in the MediaPortal camp (and on the team) for several years, Kodi users are probably best off sticking with the older MP versions, since nothing has changed on the TV server side for years now, so there is no benefit in upgrading.

However, if you do want to update the plugin, it is best to check the GIT commits for when this was done previously. It shouldn't be too hard to figure out what needs changing.
Reply
#6
Your comment is misleading. Not all users had MP1 before, so "sticking" is definitely the wrong word (I've never used MP1). Lately there are many users coming from WMC using MP2 due to available and lean WMC GUI.
Apart from that users can have a central server with a MP2 client and some andorid based clients and then Kodi is often the choice.
MP2 has also builds with TVE3.5 engine. Next build will most probably also support TVE3.5 again (IP<SAT, DiSEqC2.0, ...), MP1 supports only TVE3.

A lot of users would like to have MP2.2 server supported and we just try to follow this request.
Reply
#7
(2018-04-22, 17:11)ge2301 Wrote: Your comment is misleading. Not all users had MP1 before, so "sticking" is definitely the wrong word (I've never used MP1). Lately there are many users coming from WMC using MP2 due to available and lean WMC GUI.
Apart from that users can have a central server with a MP2 client and some andorid based clients and then Kodi is often the choice.
MP2 has also builds with TVE3.5 engine. Next build will most probably also support TVE3.5 again (IP<SAT, DiSEqC2.0, ...), MP1 supports only TVE3.

A lot of users would like to have MP2.2 server supported and we just try to follow this request.
I don't think my comment is misleading at all. Whether you use MP1 or MP2, up to now the only TV server side change has been to bump the assembly revision, so this is 'artificially' breaking compatibility with Kodi. I understand the reasons on the MP side, as the TV server and client must match.

It is easy to do the same bump in the plugin, to fix that problem.

For TVE3.5, it depends on how much has changed. I have no current knowledge of this, so I cannot comment. It may be a trivial fix, or it may be a complete plugin rewrite.
Reply
#8
Hey ge2301,
Here are the high level steps to get your new DLL...

1. Go to https://github.com/margro/TVServerXBMC and download the zip of Margro's git project.
2. Go to the "Zip Location\TVServerXBMC-master\TVServerXBMC-master\TVServerKodi\References" folder and make a list of the DLL's
3. Copy the DLL's on the list FROM your MP 2.2 install "C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server" TO the folder listed in #2.
4. Open the Solution in Visual Studio and build
5. Copy the new DLL located in the "Zip Location\TVServerXBMC-master\TVServerXBMC-master\TVServerKodi\bin\Debug" folder to your MP TV Plugins folder (Be sure to stop MP TV Service first and BACKUP your old copy)
XBMC PVR Addon Unofficial Builds for Frodo Nightly Builds.
http://www.dotnetdevelopers.net/xbmc
Reply
#9
By default it will build in Debug mode. Probably best to build in Release mode before deploying to production.
XBMC PVR Addon Unofficial Builds for Frodo Nightly Builds.
http://www.dotnetdevelopers.net/xbmc
Reply
#10
Here the plugin for MP 2.1.3
Reply
#11
Here the plugin for MP 2.2 Build #205 (not open for public)
Reply
#12
(2018-04-07, 15:06)ge2301 Wrote: @margro You seem the guy who wrote the plugin Blush 
Would you be able to update it to next major version 2.2? Just let me know which infos you need.
 Sure, as soon as it is downloadable for me Wink . Somehow for MediaPortal 2.x I need to rebuild the plugin against the right MediaPortal dll versions for almost every release.
I saw that you already figured out how to compile it for 2.2. Does it still work as expected with TVE3.5?

Normally I will build a new version as soon as I got the news that there is a new version available.
I'm currently running both MP1.20 + TVE3 and MP2.1.3 + TVE3 on different PCs for daily use and development purposes.

Note that the 2.1.2 build does work also for 2.1.3 in case other people are searching for a 2.1.3 build.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#13
(2018-08-20, 21:03)margro Wrote:
(2018-04-07, 15:06)ge2301 Wrote: @margro You seem the guy who wrote the plugin Blush 
Would you be able to update it to next major version 2.2? Just let me know which infos you need.
 Sure, as soon as it is downloadable for me Wink . Somehow for MediaPortal 2.x I need to rebuild the plugin against the right MediaPortal dll versions for almost every release.
I saw that you already figured out how to compile it for 2.2. Does it still work as expected with TVE3.5?

Normally I will build a new version as soon as I got the news that there is a new version available.
I'm currently running both MP1.20 + TVE3 and MP2.1.3 + TVE3 on different PCs for daily use and development purposes.

Note that the 2.1.2 build does work also for 2.1.3 in case other people are searching for a 2.1.3 build.  
Yeah, my team mate figured out how to compile them. The latest plugin versions for MediaPortal2 can be found here.
TVE3.5 is currently not further developed, because the developer was not seen since March 2018. We are currently discussing internaly how to deal with that and how to proceed.
Probably some key features can be implemented into TVE3 by cancelling the development freeze. To summarize, there is an MP2.2 build with TVE3.5 existing for test purposes, but no public release.

Shall I inform you here about future releases? Next would be MP2.2.1.
Reply
#14
(2018-12-20, 12:39)ge2301 Wrote: Shall I inform you here about future releases? Next would be MP2.2.1. 
 Yes please. I'm checking this forum more often that the MediaPortal website Wink
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#15
Hi All,

Is there a Kodi TVplugin for mediaportal 2.2.1 yet?

Kind Regards

Bucky
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi Plugin for MediaPortal 2.2 TV-Server0
This forum uses Lukasz Tkacz MyBB addons.