v18 Music search in Estuary not working after upgrade to v18
#1
Question 
I have a large music library, so I used to search for song titles using the 'Search' function on the left side menu.
Now, since upgrading to v18, it never returns anything.

Here is a debug log of a search:
https://pastebin.com/tm7W0iQe

If anyone has any ideas of why this is not working, please let me know. Thanks.
Reply
#2
@jbrid

Which screen are you on when you pull out the left sideblade menu? Screenshot will be good.

Also maybe something here may answer the question... Advanced_library_filtering (wiki)
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2019-05-15, 02:37)Karellen Wrote: @jbrid

Which screen are you on when you pull out the left sideblade menu? Screenshot will be good.

Also maybe something here may answer the question... Advanced_library_filtering (wiki)
I am on the initial Music screen with the high-level categories - Genre, Artist, Album, etc.
Reply
#4
Just did some further testing and found it is something to do with the skin, Estuary. I performed the same steps with Aeon Nox and the search worked properly. Any idea why that would be? Confused
Reply
#5
(2019-05-15, 02:50)jbrid Wrote: I am on the initial Music screen with the high-level categories - Genre, Artist, Album, etc.
That looks like an incorrectly named Filter. Maybe @ronie might know better.

Using the Search Icon on the home page of Estuary, which uses Global Search add-on, and it works correctly.

I see that it does work in Aeon Nox, but have not looked at code to see why.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#6
Search in music lib from sideblade works fine in Confluenece too. This seems to be an Estuary specific issue, but I don't know enough about the skin to see what is broken.
Reply
#7
Not sure what the reason for it is in Estuary but that 'Search' button is actually the 'Filter' button (ID=9), whereas the 'Search' button is ID=8. You can see this in Confluence because they're both shown in the side menu.
Reply
#8
should be fixed in 16142 (PR)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#9
Thanks very much team-kodi!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Music search in Estuary not working after upgrade to v1800