Fade Animation doesnt work
#1
as Title sais


<animation type="Conditional" condition="System.IdleTime(1)">
                <effect type="fade" start="0" end="1" time="1000"/>
                <effect type="fade" start="1" end="100" time="2500" delay="1000"/>
            </animation>

i use this in a Multiimage control to Fade Extrafanarts comming from Skinhelper
<imagepath background="true">$INFO[Window(Home).Property(SkinHelper.ListItem.Art.ExtraFanArt)]</imagepath>
(Goal is to fade in the ExtraFanart afther "System.IdleTime(1)")


it also looks like "fade"-Animations are Inverted. ("100" Fade is the opposite, so not/0% Faded. And "0" Fade is fully/100% Faded. - No Issues with Zoom where 30(%) is 30% Zoomed, and 100(%) is 100% Zoomed.)
Reply
#2
For fades, this is the opaqueness as a percentage (ie start="100" is fully opaque, start="0" is fully transparent.

When you say it doesn't work what actually happens?
Reply
#3
(2020-03-07, 09:44)Hitcher Wrote: When you say it doesn't work what actually happens?

Doesnt show up. (I can wait half a minute and still nothing.)
EDIT: try to be clearer on this: Extrafanart Dont show up (always faded) /EDIT
 
(2020-03-07, 09:44)Hitcher Wrote: For fades, this is the opaqueness as a percentage (ie start="100" is fully opaque, start="0" is fully transparent.
So, to be pedantic, the Name "fade" was wrongly choosen.
Reply
#4
This part <effect type="fade" start="0" end="1" time="1000"/> means that it will never be more than 1% opaque.

What your animation is doing is:
Goes from 0% to 1% opacity over 1000ms
Goes from 1% OF 1% opacity to 100% of 1% opacity over 2500ms (i.e. from 0.01% opacity to 1% opacity)


But why even do things this way at all?

Just use a visible condition and a visible animation:
<visible>System.IdleTime(1)</visible>
<animation effect="fade" start="0" end="100" time="2500" delay="1000" reversible="false">Visible</animation>
Reply
#5
(2020-03-08, 00:58)jurialmunkey Wrote: What your animation is doing is:
Goes from 0% to 1% opacity over 1000ms
Goes from 1% OF 1% opacity to 100% of 1% opacity over 2500ms (i.e. from 0.01% opacity to 1% opacity)
Thanks, your offcourse totaly right. (did first thought the second fade animation would thake over afther the 1000ms, as both effects are in the same animation "wrapper", but rethinking about it, made it clear.)
 
(2020-03-08, 00:58)jurialmunkey Wrote: But why even do things this way at all?

Just use a visible condition and a visible animation:
<visible>System.IdleTime(1)</visible><animation effect="fade" start="0" end="100" time="2500" delay="1000" reversible="false">Visible</animation>

This is how i had it at first. But the problem was, that if done that way, it shows Extrafanart from the previous Movie afther scroll to the next. (also a hidden animation didnt help.) (seems like SkinHelper need some time to load the extrafanart for the Focused Item, and (guess beacouse of this), it did show Extrafanart from the previous Item.) This is also the reason i try to let it fade in slowly, to give SkinHelper the Time to load the new Extrafanart, beacouse if not visible Skinhelper doesnt seem to preload.

Dont see currently a lot of options, may best not to use Skinhelper there. But as there are currently different Options to store Extrafanart. (Movietitle-Fanart2, Movietitle-Fanart-3, and so on, or if the Box is Checked within (the Universal scraper or the Artworkbeef Addon - cant remember), in a Separate Extrafanart Folder, and not shure, but arnt there also other Methods? (mainly if movies arnt in different Folders?) - so may not quickliy donne to cover all. - have to investigate a bit.
How ever, for me using SkinHelper there seemd a easy and feasible Methode. If i got that right, SkinHelper is also capable to show Extrafanart right from onlinesources, so one wouldnt even need to have those downloaded.
Reply
#6
If you want the control to always be loaded but hidden then add allowhiddenfocus="true" to the visible condition:
Code:
<visible allowhiddenfocus="true">System.IdleTime(1)</visible>

Alternatively, just use a conditional animation like so:
Code:
<animation effect="fade" start="0" end="100" reversible="false" delay="1000" time="2500" condition="System.IdleTime(1)">Conditional</animation>

The reversible="false" animation tag is important.
https://kodi.wiki/view/Animating_your_skin#Attributes
Reply
#7
Nice Trick with the "allowhiddenfocus".

Thanks, top, works.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Fade Animation doesnt work00
This forum uses Lukasz Tkacz MyBB addons.